---
title: "User Hazard Classifications"
canonical: "https://help.innovyze.com/space/xps/19663375/User%20Hazard%20Classifications"
format: markdown
---
**User defined Hazard Classifications** can be entered in the **Global Database**. This allows for localized hazard mapping for 1D/2D and 2D models.

To incorporate the **User Defined Hazard Classifications**, you must first create and define it in the Global Database:

1. Go to **Tools > Results Post Processing > Apply Hazard Scheme**.> Macro (inline-media-image)
2. In the **Hazard Scheme** field, click **Edit**. In the **Select** dialog, add a new hazard scheme and then click the **Add** button to add the hazard classification.> Macro (inline-media-image)
3. After creating the hazard classification, the parameters must be defined. Select the hazard classification record, and click **Edit** to open the **Edit User-Defined Hazard Classification** dialog.> Macro (inline-media-image)
4. Define each category (**Low**, **Moderate**, and **High**) in terms of the applicable variables. In this case, the variables are **Velocity**, **Depth**, and the product of the two, **VxD**. Each variable is classified as a condition relative to its category. For example, the image above displays three categories, each with three conditions (i.e. velocity X depth < 0.6).
5. After the conditions are set for each category, variables can be set for each axis. Click the **Update Graph** button to refresh the graph based on the recent input.> Macro (inline-media-image)
6. Once the Hazard Classification has been successfully defined, it can then be applied to the model. Under the **Tools** menu, select **Apply Hazard Scheme**.> Macro (inline-media-image)
7. In the **Apply Hazard Scheme** dialog, select the **Hazard Scheme **from the drop-down menu.
8. Select the **Results Set** from the drop-down menu. **Engine Results** can be selected as shown below. The option exists to use other results sets as well. > Macro (inline-media-image)
9. In the **Data Set** column, select a value from the down-down menu.  
> Macro (inline-media-image)
10. When all items have been defined, click **Apply** in the dialog. The processing may take a few minutes. When completed, a new layer, called the **Hazard Classification ****Schemes** layer, will exist in the **Layers** control panel.


## Merging a User-Defined Hazard Classification with an Existing Database


1. Go to **File > Merge**.> Macro (inline-media-image)
2. Select **Merge Global Databases**, and then click** File**.> Macro (inline-media-image)
3. Browse to the location of the global database file that you want to merge into the previously defined hazard classification, and then click **Open**.
4. Go to **Configuration > Global Data**.
5. In the **Global Data** dialog, select** (2D) User Hazard Classification**, and then select the **Record Name **of the added database. Click **Edit**.> Macro (inline-media-image)
6. You can see that the added database is shown in the **Edit User-Defined Hazard Classification** dialog. You can then make edits in the categories and view the updated graph, as necessary.> Macro (inline-media-image)