---
title: "The Tools Menu"
canonical: "https://help.innovyze.com/space/xps/19662834/The%20Tools%20Menu"
format: markdown
---
**The "Tools" menu** lists commands that usually work outside the database and are not part of the model calculations. 

---

![image](media://f1c43956-0f36-4661-b846-7476ec48c394)

This page contains the following topics:

> Macro (toc)

## Utilities

This command invokes external utilities. These utilities allow manipulation of SWMM Interface Files and statistical post-processing of Interface Files.

![image](media://28148f5d-2a4c-46df-bd93-eb358ff10b77)

A full description of the parameters used by SWMM is provided in the [Utilities](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19663384) section

## Export to AutoCAD

This option opens an Explorer window that allows the user to specify the name and location of the .**dxf** file. This tool exports the 1D objects of the network to a single file. Separate layers for links, nodes, link labels, nodes labels, catchments, and text items are produced.

## > Macro (anchor)

Export Graphics

> ⚠️ The ability to export a World File to georeference an image has been included in XPSWMM and XPStorm 2015 onwards. .

This command allows for the network to be output to several graphic type formats. These are: Enhanced Windows Metafile (EMF), JPEG, GIF, and BMP and also create a World File to georeference the exported files.

Note that when the entire network is exported, MS Windows Enhanced Metafile is the only format available. When the current view is exported, all four format options are available. To export the entire network as a JPEG, GIF or BMP, use the [Fit Window](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662824/The+View+Menu#TheViewMenu-FitWindowFitWindow) tool.

When this command is selected, the following dialog will be displayed.

![image](media://45157661-4ee4-4ed7-955c-c782106f2fee)

Select Export and assign a target file name. 

## Calibrate Model

The **Calibrate** **Model** command launches a dialog box with a set of tools for automated calibration of the model. Full details of the feature can be viewed in the [Calibrate Model](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662956) page.

## Modify Elevations

**Modify Elevations** (previously named **Change Inverts**) allows you to raise, lower or grade the inverts of a selected set of links and change the ground elevation and inverts of selected nodes. Check boxes at the bottom of the dialog allow the inclusion of edits to nodes and links and recalculation of conduit slopes.

![image](media://bf575f82-0215-4075-af27-ffe002d5a51f)


Select the Type of modification by clicking the appropriate radio button

**Raise Inverts by. **Allows the invert elevations (nodes and links) to be raised or lowered (using a negative number) by the amount entered in the adjacent edit field.

**Generate Intermediate ****Inverts. **If this option is selected the Inverts of both nodes and links can be graded with a uniform slope between the two extremes of the selected line. The definition of a line is a continuous set of links and nodes without any branching. 

**Drop Inverts From Node Spill Crest. **This option sets the node inverts below the spill crest (ground level) by the value entered in the adjacent edit field. 

**Raise Ground Elevations. **This option adds the value in the adjacent edit field to the existing node spill crest (ground level). Using a negative value in the edit field lowers the spill crest (ground level). 

**Read Inverts From TIN Files. **Node and link inverts are set to the value obtained from the location of the node derived from the active TIN. 

**Set Node Invert to Lowest Connected Link Invert. **This option adjusts node inverts to the lowest invert of any connected link. This tool can lower or raise the node invert to be flush with the lowest connected link invert. 

**Match Crowns. **This option adjusts (for a<span style="color: #4a4a4a"> selected set of links)</span><span style="color: #4a4a4a"> from upstream to downstream lowering or raising the invert using the same slope (same adjustment to upstream and downstream invert) to make the top of each conduit match. If the check box for Set Node Invert is selected, it also would be adjusted.</span>

**Match Inverts.** This option adjusts (for a <span style="color: #4a4a4a">selected set of links)</span><span style="color: #4a4a4a"> from upstream to downstream lowering or raising the invert using the same slope (same adjustment to upstream and downstream invert) to make the invert (bottom) of each conduit match the upstream link to the next downstream link. If the check box for </span><span style="color: #4a4a4a">Set Node Invert</span><span style="color: #4a4a4a"> is selected, it also would be adjusted.</span>

**MultiConduit Number. **If any links in the selection set are multi-links, this edit box allows the command only to apply to conduits on this row (1-7).

Additional options can be implemented by placing a check on the following boxes: 

**Re****generate Slopes. **If checked, the program will recalculate and enter into the database the revised conduit slopes. 

**Set Node Inverts. **Allows nodes to be included in the modification of inverts. 

**Set Link Inverts. **Allows links to be included in the modification of inverts.

## > Macro (anchor)

Calculate Node - Catchment Area

From the Tools Menu, select Calculate Node, then Catchment Areas. The dialog will display the new values. Edit as appropriate and then click on OK

![image](media://839d0270-e5be-4e98-a4f1-1d532089e96f)

### Split Catchments into Pervious and Impervious

The **Split Catchments into Perv/Imperv** feature allows you to select a catchment and then split it into pervious area (with 0% imperviousness) and impervious area (with 100% imperviousness). You have the option to split any of catchment one through five into two other catchments, which will be the basis of your calculation.

#### Pre-requisites

- This feature runs on Runoff mode only. It does not run on Sanitary or Hydraulics mode.
- The subcatchment must be selected in the **Runoff Node** dialog. For more information, refer to [Runoff Node Data](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662464).
- The node must be active.
- The node must be unlocked in the **Layers** control panel.

#### Splitting a catchment into previous and impervious area

1. Select the node or a number of nodes in your network that you want to split.
2. Go to **Tools > Calculate Node > Split Catchments into Perv/Imperv**. Alternatively, you can right-click the catchment and select **Split Catchments into Perv/Imperv.**> Macro (inline-media-image)
3. In the **Pervious/Impervious Catchment Splitting Tool** dialog, select the node that you want to split using the check box. You can select multiple nodes.
4. In the **Split from Catchment** column, select from the drop-down menu the catchment that will be the basis of the computation. For more information, refer to [Calculations for Split Catchments into Pervious and Impervious](#TheToolsMenu-CalculationsforSplitCatchmentsintoPerviousandImpervious).
5. In the **Pervious Catchment** column, select from the drop-down menu the subctachmennt that will take the pervious value.
6. In the **Impervious Catchment** column, select from the drop-down menu the subcatchment that will take the impervious value.
7. In the **Route to Catchment** column, select from the drop-down menu. For more information, refer to [Route to Catchment](#TheToolsMenu-RoutetoCatchment).  
> Macro (inline-media-image)
8. In the **Pervious Infiltration data** field, you have the option to:
  - Click the grey box and then select the infiltration that you want to use. Click **Select**.> Macro (inline-media-image)
  - Select **Copy from Split Catchment** check box to copy from the infiltration data of the catchment selected in the **Split from Catchment** column.
  - Leave blank if you do not want to use any infiltration data.
9. In the **Impervious Infiltration data** field, you have the option to:
  - Click the grey box and then select the infiltration that you want to use. Click **Select**.> Macro (inline-media-image)
  - Select the **Copy from Split Catchment** check box to copy from the infiltration data of the catchment selected in the **Split from Catchment** column.
  - Leave blank if you do not want to use any infiltration data.
10. Select **Overwrite all existing data** to replace all existing data with the specified pervious and impervious infiltration data.
11. Click **OK**.

#### Route to Catchment

By default, the **Route to Catchment** is set to **Outlet**. If this option is set to anything other than **Outlet **(that is,** Pervious **or** Impervious**), the **Flow Redirection** setting in the not-selected catchment will redirect to the selected catchment before flowing to the outlet. For example, if **Pervious** is selected, the **Impervious** catchment will be redirect to whichever catchment was selected for the **Pervious** catchment, and then from the **Pervious** catchment it will flow to the **Outlet**. This becomes the opposite direction if **Impervious** is selected. 

#### Calculations for Split Catchments into Pervious and Impervious

The application performs the following calculations when splitting the selected catchment:

- The **Area** for the pervious catchment will be set to *((100-%Imp)/100) * (Area of Split From Catchment)*.
- The** Area** for the impervious catchment will be set to *(%Imp/100) * (Area of Split From Catchment)*.
- The **Imp. (%)** for the pervious catchment will be set to 0.0 and the impervious catchment will have its **Imp. (%)** field set to 100.0.
- The **Slope** and **Width** fields of the **Split from Catchment** will be copied to both the pervious and impervious catchments.

For example, you want to split Node 1 Subcatchment 1, with **Area** = **120**, **Imp. (%)** = **40**, **Width** = **20**, and **Slope** = **10**, as shown in the following figure.

![image](media://ffc98ca9-b051-4f9d-b905-e223ed09b617)


In the **Pervious/Impervious Catchment Splitting Tool** dialog, you want Subcatchment 2 to be the **Pervious Catchment**, and Subcatchment 3 to be the **Impervious Catchment**.

![image](media://2a8ae629-a84d-4d2d-ab89-1ff15d6e83ca)


After splitting Subcatchment 1, the **Runoff Node** dialog will show that Subcatchment 2 and 3 are selected with the following values:

**Subcatchment 2**

**Area** = ((100-40)/100)* 120 = **72**

**Imp. (%)** = **0**

**Width** = **20**

**Slope** = **10**

**Subcatchment 3**

**Area** = *(40/100) * 120 *= **48**

**Imp. (%)** = **100**

**Width** = **20**

**Slope** = **10**

![image](media://d917f0ef-425f-44eb-897c-52d778733d70)

## > Macro (anchor)

Generate Ground Elevations from TIN

With an active TIN, the program can automatically generate ground elevations for selected nodes found within the area of the TIN.

## > Macro (anchor)

Application Settings

This menu item provides access to the settings saved in the [SWMXP.INI](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19663113) file. Editing data from this dialog is the same as manually editing the INI file. The settings are grouped into the following categories:

- Automatic Backup
- Checks
- Config
- Display
- Engine
- Field Definition Overrides
- Language
- Launch Applications
- Main
- Most Recently Used Files
- Pest
- Printing
- Settings
- Web

![image](media://93b6246d-2df3-49b3-9949-b5b98631bece)

## Encrypt File for Viewer

This option allows users to create files that can be used by the XP Viewer application.

> ✅ **TIP**
> ✅ 
> ✅ **XP Viewer** is a standalone application. It is identical to XPSWMM with the exception that the Solve and File Save features are disabled. XP Viewer can only open files that have been encrypted and are accompanied by a file with the same name as the XPSWMM model and a .**vcf** extension.
> ✅ 
> ✅ The installation file may be downloaded from [www.innovyze.com](http://www.xpsolutions.com/). Contact your sales representative for the password required to unlock the file. XP Viewer and XPSWMM can be installed on the same machine. However, the programs require different .xcf files. It is recommended that the program be installed in a folder such as C:\XPS\XPVIEWER.

### Encrypting XPSWMM<span style="color: #007a87"> </span>Models

On the tools menu, select Encrypt File for Viewer. The Alert Window will ask “Save Changes?” Click on Yes. The program will report “File Encoded successfully for XP-Viewer Configuration File.”

The software will then produce a ***.xp** file and a ***.vcf** file with the same name as the XPSWMM model.

### Distributing Files for XP Viewer** **

XPSWMM can utilise a number of supporting file types to assist model development, including GIS data, CAD files and background images. These files however, are not required to run the model to create result data. 

To enable viewing, the *.**xp** and the *.**vcf** files **MUST **be distributed together. The minimum files that are required to run a one-dimensional (1D) integrated hydrologic and hydraulic model is the ***.xp**. With this file, the software is able to produce all of the relevant output formats. For models that include Global Storms or Scenarios, the ***.mdb **file is also required to maintain this information. Models that include two-dimensional (2D) elements, on the other hand, will require the surface data that is to be coupled to any 1D elements, if they are present in the model. Surface data for modelling purposes must be in either of the ***.xptin** or ***.asc** file formats for terrain data that is displayed within the interface or linked externally, respectively.

Suggested distribution files include:

| ***Extension*** | ***Contents*** |
| --- | --- |
| .out | Output text file |
| .syf | Hydraulics results |
| .syr | Runoff results |
| .syh | Runoff results |
| .syt | Sanitary results |
| .syq | Hydraulics water quality results |

### Model Output File Types

The model creates a large number of output file types that can vary depending on the relevant components that are being an assessed in the model. The following table summarises the standard files that are generated by the respective layers in the software for pure stormwater models (i.e. no sanitary elements).

|  |  |  |
| --- | --- | --- |
| **Runoff Layer** | **Hydraulic Layer** | **2D Model Data** |
| error.log | Model_Name.hdr | _All TUFLOW Simulations.log |
| Model_Name.dat | Model_Name.syf | _TUFLOW Simulations.log |
| Model_Name.mdb |  | Model_Name.tbc |
| Model_Name.MUT |  | Model_Name.tcf |
| Model_Name.out |  | Model_Name.tgc |
| Model_Name.res |  | Model_Name.tlf |
| Model_Name.rnf |  | Model_Name.tsf |
| Model_Name.syh |  | Model_Name.tsoilf |
| Model_Name.syr |  | Model_Name.wor |
| SWMENG.ver |  | Model_Name.xmdf |
| SWMPCTDONE.SCRATCH |  | Model_Name.xmdf.sup |
|  |  | Model_Name.2dm |
|  |  | Model_Name.2dm.info |
|  |  | Model_Name_1d_nodes.mid |
|  |  | Model_Name_1d_nodes.mif |
|  |  | Model_Name_2d_bc.mid |
|  |  | Model_Name_2d_bc.mif |
|  |  | Model_Name_2d_bc_code.mid |
|  |  | Model_Name_2d_bc_code.mid |
|  |  | Model_Name_2d_bc_db.csv |
|  |  | Model_Name_2d_iwl.mid |
|  |  | Model_Name_2d_iwl.mif |
|  |  | Model_Name_2d_mat_1.mid<sup>1</sup> |
|  |  | Model_Name_2d_mat_1.mif<sup>1</sup> |
|  |  | Model_Name_2d_po.mid |
|  |  | Model_Name_2d_po.mif |
|  |  | Model_Name_2d_za.mid |
|  |  | Model_Name_2d_za.mif |
|  |  | Model_Name_2d_zpt.mid |
|  |  | Model_Name_2d_zpt.mif |
|  |  | Model_Name_2d_zsh.mid |
|  |  | Model_Name_2d_zsh.mif |
|  |  | Model_Name_Mat.csv |
|  |  | Model_Name_MB.csv |
|  |  | Model_Name_MB2D.csv |
|  |  | Model_Name_messages.csv |
|  |  | Model_Name_messages.mid |
|  |  | Model_Name_messages.mif |
|  |  | Model_Name_PO.csv |
|  |  | Model_Name_POMM.csv |
|  |  | Model_Name_proj.mid |
|  |  | Model_Name_proj.mif |
|  |  | Model_Name_TS.mid |
|  |  | Model_Name_TS.mif |
|  |  | Projection.mid |

The table above demonstrates that there is substantially more information required to support models that include a 2D element. This is a direct consequence of the range of result types that can be produced from the complex calculations that are undertaken by the model.

Note that the above list is for 2D output for **velocity**, **water depth,** and **water elevation**. The inclusion of additional model layers, such as ‘**Time to Inundation**’ will create additional output files. 

> ❌ For models that include ‘Global Storms’ or ‘Scenarios’ the model amends the above file formats to include the ‘storm name’ or ‘scenario name’ in addition to the model name. The point of caution here is that the total file path **must be less than 80 characters in length**, which is from C:\...\Model_Name_*.*.


## > Macro (anchor)

Launch Application

The **Launch Application** option allows you to launch various utilities from XPSWMM. These utilities are accessible via **Tools > Launch Application**, or by accessing the installation folder and selecting the specific utility. Several default applications are provided in XPSWMM. Additional utilities can be added either by editing the **SWMXP.INI** file or by selecting the **Launch Application** item from the [Application Settings](#TheToolsMenu-ApplicationSettings) dialog. For example, you can add menu items to launch programs that you would use in combination with XPSWMM such as receiving water quality programs, GIS and other engineering applications.

![image](media://5db1e9a4-1322-4fbb-ae82-e4b9806f774a)

### **EpaSwmm5Reader.exe** 

A utility to convert EPA-SWMM 5 .inp file to an XPX that can be imported to XPSWMM. 

![image](media://a49782dd-9dbf-4f85-9dcc-696b6fd85d4f)

To use EpaSwmm5Reader.exe:

1. In the **EPA-SWMM Input File** field, click the **...** and browse to the location of the .inp file. The **XPX Output File** and **Summary Report Output File** fields will be automatically populated.
2. Click the **...** in any of the fields to change the location of where the file will be saved.
3. Click **Run**. The XPX and output files will be created. Click **OK** to exit the dialog.
4. Click the **Edit** button to open the file in Notepad and make the necessary edits.

### **CUHPtoXPXw.exe** 

A utility to convert CUHP data files to XPX files for import into XPSWMM.

![image](media://0144aa26-6b05-4b31-91a5-45888a3e98bb)

To use CUHPtoXPXw.exe:

1. In the **CUHP Hydrograph File** field, click **Select**, locate the hydrograph file, and then click **Open**.
2. In the **CUHP Input Data File** field, click **Select**, locate the input data file, and then click **Open**.
3. If you want to **Create XP-SWMM XPX Network File**, select this option.
  1. In the **File Name** field, click **Select** and then browse to the location where you want to save the file.
  2. Provide the filename accordingly, and then click **Save**.
4. If you want to **Create XP-SWMM XPX Inflow File**, select this option.
  1. The **File Name** field is populated by default. To edit this, click **Select** and then browse to the location that you prefer.
  2. Provide the filename accordingly, and then click **Save**.
5. If you want to **Create XP-SWMM Interface File**, select this option.
  1. The **File Name** field is populated by default. To edit this, click **Select** and then browse to the location that you prefer, and edit the filename accordingly.
  2. Click **Save**.
  3. Provide the following values accordingly:
    - **Starting Year**
    - **Starting Month**
    - **Starting Day**
    - **Starting Hour**
    - **Starting Minute**
    - **Starting Second**
6. Click **Run**.

### **InterfaceUtils.exe** 

A utility for converting XPSWMM interface files and binary results files to comma-delimeted text files. The utility also allows graphing and export capabilities.

![image](media://8ca2cace-5754-47be-85b3-b67cdccf9032)

To use InterfaceUtils.exe:

1. In the **File Type** field, select the type of file from the drop-down list. The following file types are available:
  - **Flow Interface Files**
  - **Rain Interface File**
  - **Runoff Results Flow File**
  - **Runoff Results Hydrology File**
  - **Sanitary Results File**
  - **Hydraulic Results File**
  - **Hydraulic WQ Results File**
2. In the **File Name** field, click **...** and locate the<span style="color: #333333"> </span>interface file or binary results file. Select the file and then click **Open**. The other parameters in the dialog will be automatically populated.
3. Select a node in the list of nodes.
4. In the **Parameters** section, select the parameters that you want to include.
5. Click the **Show as Concentration** option to enable this feature, provided this information is in the source file.
6. By default, the **Create CSV File** option is enabled. The default filename and location is provided in the field. You may change this by clicking the **...** button.
7. You can **Create INT File** or **Create SOBEK File** by clicking these options. The default filename and location is provided in the field. You may change this by clicking the **...** button.
8. If you want to view the graph of your data, click the **Graph** button.
9. Click **Run**.

### **XPXConverter_RatToSWM.exe**** **

A utility to convert XP-RatHGL data sets to XPX files for import to XPSWMM.

![image](media://a0b4f36c-96ab-44be-ba9c-8d7bfdcfd87c)

To use XPXConverter_RatToSWM.exe:

1. In the **Rat.XPX File to be converted to SWMM.XPX** field, click **Browse**, and then locate the Rat.XPX file.
2. Select the file and then click **Open**. The **SWMM.XPX File to be created from above file** field will be automatically populated.
3. Click **Convert**.

### **IFD.exe** 

A utility to create a Table of Intensity Duration and Frequency and calculate single rainfall intensites based on Australia Rainfall and Runoff 1987.

![image](media://df817221-211c-4d66-896f-5a7e20f8b073)

To use IFD.exe:

1. Enter a description in the **Description of region** field as necessary.
2. Enter all the parameters in the dialog. You will get this data from the Australian Rainfall and Runoff Manual or alternatively, from the [Rainfall IFD Data System](http://www.bom.gov.au/hydro/has/cdirswebx/cdirswebx.shtml).
3. Open the website of the Australian Bureau of Meteorology and click the **Create an IFD** tab. Enter the **Latitude** and **Longitude** of the location. Click the **Submit** button and finally select the IFD table option. You will see the IFD coefficients for the area in the bottom left of the IFD Table tab.
4. Click the **Solve** button, and the **Intensity** of the design storm will be calculated.
5. Click the **Save Data** button.
6. Click **Save Table** to save the table locally.

### **MalaysianIFD****.exe** 

A utility to create a Table of Intensity Duration and Frequency and calculate single rainfall intensites for Malaysian locations.

![image](media://f1c46032-a197-484b-9ac2-96f20f017bba)

To use Malaysian ifd.exe:

1. Enter a description in the **Description of **field as necessary.
2. Select whether the location is in the **East Coast** or **West Coast**.
3. Enter the other parameters in the dialog. You will get this data from the Workshop on Urban Stomrwater Management Manual for Malaysia [website](http://msmam.com/).
4. Click the **Solve** button, and the **Intensity** of the design storm will be calculated.
5. Click the **Save Data** button.
6. Click **Save Table** to save the table locally.

### **WriteInterfaceFiles.exe** 

A utility to convert CSV files to binary interface files of flow that can be read in the Sanitary or Hydraulics modes.

![image](media://c97f512e-342b-431d-835a-2ba8671f4d61)

To use WriteInterfaceFiles.exe:

1. If you want to create the **Flow Interface File**:
  1. In the **Node Name** field, enter the name of the node.
  2. In the **CSV File Name** field, click the **Select** button and locate the CSV file that you want to convert. Select the file and then click **Open**. The other parameters in the dialog will be automatically populated.
  3. Click the option to **Read Titles from INT File** to enable this feature.
  4. In the **Available Fields** section, select from the list and then use the **Data Type** drop-down list to associate a field with a particular data type. Click the **>>** button to include the field. Click **<<** to exclude a particular field.
  5. Select whether to **Append** or **Replace** the interface file that will be created.
  6. The default filename and location is provided in the **Create Interface File **field. You may change this by clicking the **...** button.
2. If you want to create the **Rain Interface File**:
  1. In the** File Name **field, click the **... **button and locate the SWMM Rain Interface file that you want to convert. Select the file and then click **Open**. The other parameters in the dialog will be automatically populated.
  2. The default filename and location is provided in the **Create CSV File **field. You may change this by clicking the **...** button.
3. Click **Clear All** to remove all entries for all parameters.
4. Click** Run**.

### **BomPluvioConverter.exe** 

A utility to convert BoM Pluviograph files. 

![image](media://a39c2494-2be4-425c-89f8-e8556bc7df3e)

To use BomPluvioConverter.exe:

1. In the **Input File** field, click** ..** and locate the input file. Click **Open**.
2. In the **Separator** portion, select whether to use **Blanks**, **Comma**, or **Semicolon**.
3. The option to **Disregard -888.8 entries** is selected by default. Clear this option to include this value.
4. Click **Convert**.

### **EpaSwmmReader.exe**

An EPA-SWMM data file converter. This utility converts most Hillsborough County SWMM, SWMM4.4 and SWMM5 data files to [XPX files](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662874/XPX+Format+File#XPXFormatFile-XPXCommandReference). 

![image](media://6fcbdbd2-c00f-45df-a830-532f4bc48345)

To use EpaSwmmReader.exe:

1. In the **EPA-SWMM File Format** field, select from the following:
  - **EPA-SWMM 4.4 H Extran**
  - **EPA-SWMM Hillsborough County Method**
  - **EPA-SWMM Hillsborough (with Weir, Pump, and Orifice Names)**
  - **EPA-SWMM 5**
2. In the **EPA-SWMM Input File to Read**, click **Select**, locate the input file, and then click **Open**. The **XP-SWMM XPX File to Create** will be automatically populated.
3. If you want to create an **XP-SWMM Results File**, click this option.
  1. In the **EPA-SWMM Output File to Read**, click **Select**,  locate the output file,and then click **Open**.
  2. The** XP-SWMM Results File to Create** field will be automatically populated.
4. If you want to **Get Node Coordinates from DXF File**, click this option.
  1. In the **DXF File to read** field, click **Select**.** **
  2. Locate the file, and then click **Open**.
5. Click **Run**.

### NOAAA14Reader.exe

This utility converts the NOAA Atlas 14 Temporal files to an XPX (for each quartile) that can be imported to the application.

![image](media://60b9ed88-5276-4dbd-b21f-a1e08ebbd602)

To use NOAAA14Reader.exe:

> ⚠️ Before performing this procedure, make you that you download the NOAA 14 Atlas Temporal files for your location from the National Oceanic and Atmospheric Administration [website](https://hdsc.nws.noaa.gov/hdsc/pfds/pfds_temporal.html).

1. In the **NOAA Atlas Temporal File** field, click the browse icon and locate the temporal file (.csv) you previously downloaded. Click **Open**.
2. The **Output Folder** field will be automatically populated. By default, the output files will be saved where the temporal file is saved. Click the browse icon to change this location.
3. Click **Run**.
4. A dialog will be displayed stating that the .csv file is successfully converted to .xpx files. The output folder location will also be displayed, as well the filenames of the created .xpx files. The converted files will be divided into four quartiles.
5. You can then import the .xpx files to the application. Refer to [Importing XPX/EPA Data](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662874/XPX+Format+File#XPXFormatFile-ImportXPXImportingXPX/EPAData) for more details about this topic.

## > Macro (anchor)

Snap Mode

This tool is used to navigate to a vertex or link of a selectable layer. When active, the cursor changes from a diagonal arrow to a double lined cross > Macro (inline-media-image)

as a target vertex or node is approached.

Snap Mode can be accessed from the **Tools Menu** or the [Job, Layer & Mode Control](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662717/The+Toolbar#TheToolbar-JobControlTools) tools.

## Calculate Conduit

From this menu option, users can calculate conduit lengths, slopes, cross-sections, and water level lines. 

### **Calculate Conduit Slopes**

The slopes of all conduits or of the selected conduit(s) can be calculated from the conduit invert elevations by selecting this command. The slopes can be modified, if so desired, prior to accepting the result.  
> Macro (inline-media-image)

> Macro (inline-media-image)



### **Calculate Conduit Lengths**

The lengths of all conduits or of the selected conduit(s) can be calculated from the node coordinates by selecting this command.

> Macro (inline-media-image)

> Macro (inline-media-image)

  


### **Cross Sections **

This tool requires an active [DTM layer](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19661222/Topography+Layers+and+Objects#TopographyLayersandObjects-DTMLayers). It is used to generate [shapes](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19661222/Topography+Layers+and+Objects#TopographyLayersandObjects-DynamicElevationShapes) of links that are Natural Channels and/or layouts of cross-sections. The generated cross-sections are straight lines perpendicular to the the channel centerline, represented by link.<span style="color: #ff0000"> </span>

<span style="color: #ff0000"> </span><span style="color: #5f6062">**Apply to**</span><span style="color: #5f6062"> options are:</span>

- All natural shape links
- [Selected](https://help-innovyze.atlassian.net/wiki/spaces/xprafts/pages/19007183) natural shape links

<span style="color: #000000">**Create**</span><span style="color: #000000"> options are: </span>

- **Layout then Shape from DTM. **Both the layout and the shapes are generated. The user defines:

> Macro (legacy-content)

- **Layout from Shape**. Layouts of cross-section are generated from user defined location data. Width of the existing shape is used and the lowest point in the section data is the centerline of the station.
- **Shape using Layout and DTM** - the shapes are developed from predefined layouts of the cross-sections. The options on crossection location are disabled.

The successfully generated cross-sections are reported.

![image](media://cd9c7681-5991-4683-bd2e-0164964fbb5f)


To view the layouts of the cross-sections the Cross-sections layer must be enabled on the [Layer Control Panel](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662727). To edit the cross-sections, select the link, right click and select Edit Cross-section from the pop-up menu. The Cross-sections Layer must Visible, Movable and Selectable in order to graphically edit the polyline.

### > Macro (anchor)

**Generate Water Level Lines**

Water Level Lines are polylines used to display 1D open channel and 2D results together. They should extend from the left bank to the right bank of the channel. These lines return elevations to the 2D map for Natural channel shapes.  Trapezoid shapes should be converted to Natural in order to produce these map results.  These polylines are used to create a TIN from the 1D node results which is spatially displayed as a flood map. Water level lines may be manually added or generated automatically.

Water Level Lines can be **automatically generated** by using the Generate Water Level Lines option. To automatically generate Water Level Lines select and right click on a Link. Hover over Water Level Lines and choose Generate Water Level Line from the popup menu. The Generate Water Level Lines dialog is shown below.

![image](media://66ded5b1-6ae0-4e07-8834-21b67033f90e)


The Water Level Lines can be automatically generated for either a selection of Links or all Links in the model. When generating the Water Level Lines you have the option to either replace or add to the existing water level lines. If no lines currently exist then both options will generate Water Level Lines.

A Maximum distance between lines must be designated as well as the distance (width) that the Water Level Lines will span either side of the Link. Additionally, the user can specify if a vertex should be generated where the Water Level Lines cross the Link as well as if a vertex is added at the downstream of each link.

Water Level Lines can be **added manually** to an individual Link by using the [Add Water Level Line](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19661542/Building+the+Runoff+and+1D+Hydraulic+Layers#BuildingtheRunoffand1DHydraulicLayers-WaterLevelLines) option. 

For an example on how the flood map is generated from the Water Level Lines please review the following:



![image](media://cf26de9e-cc0d-41db-bb9d-d63d904e0185)

**Consider the diagram above. **

**At a time step t**

`WSEL at u/s node = WSEL1`

`WSEL at the d/s node = WSEL2`

`WSEL at WLL1:`

`Y1= (WSEL1+WSEL2)/L*X1`

`WESEL at WLL2:`

`Y2= (WSEL1+WSEL2)/L*X2`

`For all the vertices along WLL1, the WSEL = Y1`

`For all the vertices along WLL2, the WSEL = Y2`

Finally the TIN will be created.

![image](media://7f84d89e-d599-491d-af71-b1621fb7bbcb)


## > Macro (anchor)

xp2d Utility Interface

The <span style="color: #ff9900">xp</span><span style="color: #333333">2D </span>utility interface <span style="color: #4a4a4a">works with 2D flow results generated by the </span><span style="color: #ff9900">xp</span><span style="color: #333333">2D </span><span style="color: #4a4a4a">engine, </span><span style="color: #333333">the TUFLOW-based overland flow module integrated with </span><span style="color: #0000ff">xp</span><span style="color: #333333">. </span>

![image](media://312d6ebc-73d2-482f-aef0-9cebd879f3be)


Through this tool, users can convert *.DAT files to *.XMDF, convert 2D results to GIS files, and output 2D Result Diff files. 

### > Macro (anchor)

Comparing 2D Results Diff File

The **XP2D Utility**<span style="color: #333333">** **</span>**Interface** provides you the ability to take the difference between two 2D result datasets (*.XMDF) or two grid files (*.ASC) in the application. The first input file is subtracted from the second input file. 

**To compare 2D results:**

1. After solving a 2D model with at least two scenarios, launch the <span style="color: #ff9900">xp</span><span style="color: #333333">2D </span>utility interface. Go to** Tools > XP2D Utility Interface**.
2. Select the **2D Results Diff** tab. > Macro (inline-media-image)
3. Click the ellipses buttons and locate the appropriate *.XMDF for the **Input File 1** and **Input File 2** fields.
4. For the **Output File** field, browse to the location where you want to store the file, and enter the preffered file name.
5. If required, enter flags for processing in the **Custom Flags** field.
6. Click** Execute**. Close the <span style="color: #ff9900">xp</span><span style="color: #333333">2D </span>utility dialog once complete.
7. On the [Layer Control Panel](https://help-innovyze.atlassian.net/wiki/spaces/xps/pages/19662727), right click **2D Results** under the **Reporting** layer and select **Add XMDF Result File** in the context menu. This will launch a file selection dialog. Navigate to, and select the output file generated (***.SUP** file extension). Click **Open**. > Macro (inline-media-image)
8. The **Reporting** layer should now show an entry for the selected results file. > Macro (inline-media-image)


**To compare 2D grids:**

1. Go to** Tools > XP2D Utility Interface**.
2. Select the **2D Results Diff** **Asc** tab.   
> Macro (inline-media-image)
3. Click the ellipses button and locate the appropriate *.ASC grid files for the **Input File 1** and **Input File 2** fields.
4. For the **Output File** field, browse to the location where you want to save the output file, and enter the preferred file name.
5. If required, enter flags for processing in the **Custom Flags** field.
6. Click** Execute**. A command line window will open that display the status of the difference calculations, and the location of the output files.
7. Browse to the location where the output *.ASC files are saved. There are two files generated:
  - ***<output_filename>.ASC - ***This output file contains the difference between the two .ASC files (Input File 2 - Input File 1). A difference value occurs only for grid cells that have values in both grids. If the cell does not have any value, in either or both .asc grids, no value will be generated in the output file.
  - ***<output_filename>_wd.ASC -*** This output file (with a _wd suffix) indicate which .ASC grid cells are either previously wet and are now dry, or vice versa. This output file is useful when displaying areas that are previously inundated or flood free.


> Macro (__confluenceADFMigrationUnsupportedContentInternalExtension__)