---
title: "Tutorial 14 - GIS Integration"
canonical: "https://help.innovyze.com/space/xps/19661106/Tutorial%2014%20-%20GIS%20Integration"
format: markdown
---
**The application** has several tools that may be used to integrate GIS data into the modeling environment. GIS data may be used as a background layer for a visual reference or it may be imported to build a working model. With this integrated GIS link, the interface enables you to exchange data with other external databases such as ArcGIS (*.shp files), MapInfo (*.mid/mif files), Asset Management Software, Access (*.mdb files), and Excel or any other ODBC compliant database.

---

The Layer Control Panel allows the management of geospatial data sets including visualization and direct import of geometric objects such as polygons, polylines, and points to the appropriate layer. GIS layers and background images may be color coded by layer or attribute to enhance visibility. The attribute values may be displayed in tabular format. The display of individual layers may be toggle on/off to enhance visibility.

## Part 1 – Adding GIS files and Viewing Attributes

GIS files (*.shp or, *.mif) may be included in any model as layers. The display properties and the order of the layers may be adjusted to enhance viewing. The **Quick Data View** tool is used to display values of attributes in the GIS layer.

| **Level** | Novice |
| --- | --- |
| **Objectives** | Add GIS layers to network model, adjust layer colors, and view attributes with the Quick Data view |
| **Time** | 0.5 hour |
| **Data files** | - RI.shp, RI.shx, RI.sbx, RI.dbf (municipal boundaries)
- Rivers_streams.shp, Rivers_streams.sbn, Rivers_streams.sbx, Rivers_streams.prj, Rivers_streams.dbf
- Lakes_ponds.shp, Lakes_ponds.sbn, Lakes_ponds.sbx, Lakes_ponds.prf, Lakes_ponds.dbf |


1. Launch the application.
  1. At the opening dialog, create a new file called *RhodeIsland.xp*.
  2. Set the units to Metric.
  3. Click **Continue**.
2. Load the GIS files:
  1. Right-click the **GIS Files** line in the Layers Control Panel.
  2. Select** Load GIS File** from the menu.
  3. In the **Add GIS image** dialog, navigate to the file *ri.shp*.
  4. Click **Open**.
  5. Repeat Step 2a through 2d, adding files *lakes_ponds.shp* and *rivers_streams.shp*.
3. Adjust the display colors:
  1. In the Layers Control Panel, right-click the *lakes_ponds.shp* layer and select **Properties** from the menu.
  2. Set the **Foreground Colour** in the **Fill Properties** and the **Colour** in the **Line Properties** to blue.
  3. Set the **Foreground Colour Opacity** slider bar approximately 70% to the right.
  4. Click **OK.**  
> Macro (inline-media-image)

** **> Macro (inline-media-image)
  5. Right-click the* rivers_streams.shp* layer and select **Properties **from the menu.
  6. Set the **Foreground Color **(in the **Fill Properties**) and the **Colour** (in the **Line Properties**) to light blue.
  7. Click **OK**.
  8. Right-click the *ri.shp* layer and select **Properties **from the menu.
  9. Set the **Foreground Colour** (in the **Fill Properties**) to white and the **Colour** (in the **Line Properties**) to black.
  10. Click **OK.**
  11. Adjust the network view to display the entire state of Rhode Island.
4. Open the Quick Data View:
  1. In the **View** menu, select **Quick Data View > Show/Hide**. The **Quick Data View** opens as a docked panel.
  2. Undock it by double-clicking the title bar.
  3. Select **GIS** from the bottom tabs.
  4. Click the maps in the network window to see data displayed in the **Quick Data View**.
  5. Adjust the size and position of the floating panel to display the attributes of a selected object in the GIS layer.  
> Macro (inline-media-image)
5. Select Objects. The selectable layer contains the municipal boundaries in the state of Rhode Island. Select the object **Providence** to display its attributes in the Quick Data View.
6. Save your file as *RhodeIsland.xp.*

### Questions

1. What municipalities border Providence?
2. What is the name of the large reservoir in the middle of the state?
3. What is the Surface Area?

## Part 2 – Adding GIS Files as Background Images and Color Coding

GIS files (.shp or .mif) may be included in the network model as background images. The layers may be color coded by attribute.

| **Level** | Novice |
| --- | --- |
| **Objectives** | Add GIS layers as background images and color code by attribute |
| **Time** | 0.5 hour |
| **Data files** | - RhodeIsland.xp (from Part 1)
- Road_edge.shp, Road_edge.sbn, Road_edge.sbx, Road_edge.prj, Road_edge.dbf
- Manholes_1.shp, Manholes_1.sbn, Manholes_1.sbx, Manholes_1.prf, Manholes_1.dbf
- Pipes.shp, Pipes.sbn, Pipes.sbx, Pipes.prf, Pipes.dbf |


1. Launch the program:
  1. Open the file *RhodeIsland.xp*.
  2. Turn the display in all GIS layers off.
  3. Right-click the **Background Images** line in the Layer Control Panel.
  4. Choose **Add Background Image** from the menu.
  5. In the **Add Background Image** dialog, navigate to the file *road_edg.shp*.   
> Macro (inline-media-image)
  6. Click **Open**.
  7. Click **OK** on the **ESRI Shape File Attribute** dialog.
  8. Click **OK** twice to return to the network view.
2. Add manholes:
  1. Right-click the **Background Images** line in the Layer Control Panel.
  2. Select **Add Background Image** from the menu.
  3. In the **Add Background Image** dialog, navigate to the file *manholes_1.shp* and then click **Open**.
  4. In the **ESRI Shape File Attributes** dialog, select the box next to **Encode Attributes**.
  5. Select **CITY** as the **Encoding Field**.
  6. If a color code is white, change it to something else.> Macro (inline-media-image)
  7. Click **OK** twice to return to the network view.
3. Add pipes:
  1. Right-click the **Background Images** line in the Layer Control Panel.
  2. Select **Add Background Image** from the menu.
  3. In the **Add Background Image** dialog, navigate to the file *pipes.shp*.
  4. Click **Open**.
  5. In the **ESRI Shape File Attributes** dialog, select the box next to **Encode Attributes**.
  6. Select **PIPE_SHAPE** as the **Encoding Field**.
  7. If a color code is white, change it to something else.   
> Macro (inline-media-image)
  8. Click **OK** twice to return to the network view.
4. Review the map:
  1. Zoom in to Providence where there is an intersect of two divided highways.
  2. Turn on the **Lakes_ponds GIS layer** to display the water bodies in the vicinity.
5. Save your file as *RhodeIsland.xp.*  
> Macro (inline-media-image)

### Questions

1. Does the manhole layer include stormwater drains? Why, or why not?
2. Is the CITY classification in the manhole layer consistent with the municipality boundaries?

## Part 3 – Direct import of Nodes and Catchments 

Object such as nodes, links, catchments, roughness areas, and fill areas may be directly imported from GIS files. Attributes are mapped to the variables.

| **Level** | Novice |
| --- | --- |
| **Objectives** | Use tools to:<br>- Import nodes from a shape file
- Import subcatchments from a shape file and subcatchment data from attribute table
- Use tools to calculate subcatchment areas |
| **Time** | 1 hour |
| **Data files** | - Inlets.shp, Inlets.shz, Inlets.dbf
- Catchments.shp, Catchments.shx, Catchments.dbf |


1. Launch the program.
  1. At the opening dialog, create a **New file** called *Runoff_project.xp*.
  2. Set the units to **Metric**.
  3. Click **Continue**.
  4. Set the mode to Runoff (**Rnf**).
2. Add nodes:
  1. Right-click the **Nodes** line in the Layer Control Panel.
  2. Choose** Import from GIS File **from the menu.
  3. In the Windows Explorer dialog, navigate to the file *Inlets.shp*.
  4. Click **Open**, and then click **Import**.
  5. In the **Node Import Properties** dialog, select the **Set Node Names from Attribute Data** radio button and then select the **Name** attribute from the drop list.> Macro (inline-media-image)
  6. Click **OK** and the dialog will report that 10 nodes are read.> Macro (inline-media-image)
  
3. Add catchments:
  1. Right-click the **Catchments** line in the **Nodes** section of Layer Control Panel.
  2. Select **Import from GIS File **from the menu.
  3. In the Windows Explorer dialog, navigate to the file *Catchments.shp*.
  4. Click **Open**, and then click **Import**.
  5. In the **Catchment Data Mappings** dialog, set the **Node Name** to **BASINID (10 Char)**.
  6. Select the **From Attributes** radio button and select **SUBCATCH (Integer)** from the list.> Macro (inline-media-image)
4. In the table section of the dialog, map the shape file attributes to variables:
  1. Highlight the attribute and click **Set** to open the Variable Selection dialog.
  2. Map the fields to the variables as indicated below. Make sure that each variable is set to **Subcatchment 1**. Then click **Import**.> Macro (inline-media-image)

> Macro (inline-media-image)

> Macro (inline-media-image)

> Macro (inline-media-image)
5. Calculate the catchment areas:
  1. In the **Tools** menu, select **Calculate Node > Catchment Areas**. The dialog displays the **Old Area** (existing area) and the **New Areas** (calculated by the program from the polygon areas).
  2. Click **OK** to accept.> Macro (inline-media-image)
6. Adjust the catchment display:
  1. In the Layer Control Panel, check the visible box to display a line from the centroid of the catchment to the runoff node.
  2. Right-click the **Catchments** line in the Layer Control Panel.
  3. Select **Properties**.
  4. Set the display properties as shown in the figure below. Click **OK** to view the network.  
> Macro (inline-media-image)

  
 > Macro (inline-media-image)

### Questions

1. Review the SCS Hydrology data. For Node A, how are the Hydrograph Shape and Initial Abstraction values entered into the model?
2. Use the Ruler Tool to measure the width of the catchment for Node E. What is the width value?