Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

The graphical user interface (GUI) utilizes the current Windows, icons, menus, and pointing device technology in a state-of-the-art intuitive user environment. This environment consists of:

    • A window with a series of menus along the top of the screen used for controlling operation of the program and a status bar at the bottom. The window displays a plan view of the active model.
    • Several tool strips containing icons for file operation, object creation/manipulation, and shortcuts to menu commands.
    • Panels for displaying data or managing network display that either float or are docked to an edge of the screen.

The interface may be used to create a new hydrology and hydraulics network, as well as edit an existing one. The user interface is object oriented, which means that you select the object and then select the operation to perform on it. You first select an object or range of objects using the pointing device, and then perform an operation on the selection with the menu command. For example, to delete a group of objects, select them first with the mouse and then select Delete Objects from the Edit menu. 

The GUI is an interface to a database (.xp file) storing all data required for the particular model that has been adapted. Through the user interface, the database is linked to various tools for result presentation, data exchange, and manipulation.

The elements of the interface, namely, the Window, icons (Toolbars), dialog box, layers Control Panel, and pointing device, and the method for the manipulation of the objects are described in this tutorial.

LevelBeginner
ObjectivesTo become familiar with the features and tools in the user interface
Time1 hour
Data filesLayoutdemo.xp

The Application Window

The application window provides the frame of reference for user interaction. The large area displays a current view of the created network of links and nodes, polyline and polygon objects, any associated background drawings, Digital Terrain Model (DTM), and text objects. The window title includes the version number and any service pack, and the current database (model).

A status message describing the current program activity, such as a description of the function and mouse position are displayed across the status bar located at the bottom of the window. The x, y and z (for models with a Digital Terrain Model) are also displayed. The status bar can be turned on/off using the Status Bar from the View menu.

The Network Overview panel provides a means of changing the position of the current view of the network. This tool is accessed in View > Network Overview.

The Pointing Device

The pointing device may be a typical mouse, track ball, touch pad, or other mouse compatible device. For the sake of consistency, the term mouse is used to indicate a generic-pointing device. The primary button is assumed to be on the left. 

The mouse pointer changes shape to indicate the type of action that is taking place. The typical pointer icons are:

Pointer icon

You may select objects, move, re-connect or re-scale the network using this tool.
Text icon

Image Modified

Text annotation is being added to the network.
Node icon

Nodes are being added to the network.
Link icon

Single Links (solid line) are being added to the network.
Multi-Link icon

Multi-links (dashed line) are being added to the network.
Bridge Link icon

Bridge Links (segmented line) are being added to the network.
River Link icon 

River Links (segmented lines and river nodes) are being added to the network.
Polyline icon

A polyline is being drawn.
Polygon icon

A polygon is being created.
Trigger Point icon

Trigger Points are being added to the network.
Ruler icon

Lengths or areas are being measured from the network.
Section profile

Displays profile of selected cross section.
Catchment to Node

The centroid of a catchment can be dragged to assign to a node catchment number.
Link Reattachment

The head and tail of a link can be removed and reattached to another node.
Blue Circle icon

This indicates that the program is busy performing a task. The specific task is generally displayed in the status message area of the window.
Hand icon

 You are currently panning around the network.
Movable icon

An object will be displaced.
Semi-Circular arrow

A polygon grid will be rotated.
Define Cross-section Layout

Creates a cross section along selected points.
Edit Cross-section Layout

Begins edit mode of selected cross section.
Insert Point icon

Add a vertex to a cross section, polylink, or polygon.
Move Point icon

Move a vertex of a cross section, polylink, or polygon.

The mouse allows you to select objects to operate through point and click, and similarly to initiate system commands through pull down menus and to select a tool.

Shortcut Keys

Numerous keyboard shortcuts are available. These are:

Ctrl-

NCreate a new project

A

Add all nodes to selection

F1

Launch the Help file

Ctrl-

A

L

Add all

nodes

links to selection

F2

Open the XPTables

Ctrl-

LAdd all links to selection

C

Copy

F3

Conduit Profile for selected conduit

Ctrl-

C

V

Copy

Paste

F5

Solve the model

Ctrl-

V

X

Paste

Cut data

Ctrl-F5

Snap Mode

Ctrl-

X

Cut data

F6

Browse file

Ctrl-

F

Find, opens the Go To dialog

F7

F6

Review Results

Browse file

Ctrl-D

Opens the data dialog

F8

F7

Profile Plot

Review Results

Ctrl-R

Redraws network view

F8

Profile Plot

Ctrl-Q

Exit the application

F9

Dynamic Long Section View

Ctrl-

OOpen a

S

Save the current file

Shift-F9

Dynamic Section Views

Ctrl-

Q

W

Exit

Close the

application

file

F10

Dynamic Plan View

Ctrl-

S

P

Save

Print the current

file

page

F11

Spatial Reports

Ctrl-

WClose the file

U

Run Utilities

F12

Graphical Encoding

Ctrl-

PPrint the current page

G

Go to an X,Y coordinate

DEL

Deletes selected objects and associated data

Ctrl-

U

Run Utilities

Ctrl-

M

Displays the count of selected objects

Ctrl-G

Go to an X,Y coordinate

Shift-F10

Displays the Ensemble Statistics Utility dialog

The Dialog Box

The dialog box is a graphical view of the attribute database. In other words, the dialog box is to attribute data as Windows is to the network spatial data. The dialog box contains different types of items or controls that represent different types of data or modeling choices. 

The three methods for accessing the node and link object dialogs are:

  • Double-click the link or node.
  • Click the link or node, then right click and then select Edit > Data (or Ctrl D).
  • Click the object and then select Edit > Data (or Ctrl D).

The common items in the dialog box are described in the following:

Static Text

Caption for editable text.
Editable TextText strings or numbers. The insertion point for the text is contained in a rectangular field. Double-clicking in the field will select all text, and subsequent entry will replace all existing text
Check box A check box is a flag for a particular option. You may select none, any, or all options. A check box with underlying data is located in an action button. Check boxes are always optional.
Choice ButtonThe circular choice buttons (radio buttons) indicate a choice of one item from a group. Only one may be selected. A choice button located in an action button indicates underlying data. The selection of one of the choice buttons is mandatory.
Action ButtonA rectangular action button controls dialog traversal (and therefore data structure). The OK and Cancel buttons are usually mapped to the <Enter> and <Esc> keys. The upper right hand corner X button on the dialog is also mapped to Esc and abandons all edits made in the dialog if pressed. A button item in the Job Control dialog contains mandatory data. Other action buttons include Run for the Utilities and Import for the Import dialog and More to load another dialog for the complete data entry for a particular model section.
PictureA picture data item is an icon or a symbol used to promote rapid comprehension. It is not a dynamic item and is only representative of typical modeling scenarios.

The first level of dialogs contain the most common data for the link, node, or 2D object. Additional data is entered in dialogs that are opened by selecting buttons on the first dialog. Even further data such as rainfall is entered in the global database. The first level dialogs for nodes and links are shown below.

Dialogs are mode dependent and therefore show different data depending on the current Mode. In the hydraulics mode, the dialog will be requesting hydraulic information while in the Runoff mode, hydrological data is requested. Refer to the following examples. 

Note
The mode and object name is displayed in the dialog title bar.

Hydraulics Mode – Node Data dialog

Runoff Mode – Node Data dialog


Conduit Data dialog


One of the unique feature is that picture items are used extensively to symbolize physical attributes associated with the data. This allows presentation of the model to non-technical reviewers.

Items are selected by using the mouse to position the pointer at an item then clicking or double-clicking with the mouse button. You may also optionally move through the editable text box items by using the <Tab> and <Shift-Tab> keys.

Pressing the <Enter> key is the same as clicking the OK button.

Pressing the <Esc> key is the same as clicking the Cancel button or selecting the red upper right hand X.

Holding down the <Shift> key while clicking an action button, which would normally cascade to another dialog, would only activate the check box or choice button and not cascade to the underlying dialog.

Clicking the OK button causes an embedded expert system to check the data. If the data is not valid, an error message or warning will be displayed and you will have to return to the dialog. If the data is valid, it is committed to the temporary database. The temporary database is written to the permanent database (your *.xp file) during the File >Save or Save As command.

Selecting Cancel or the red X in the upper right hand corner will ignore any changes that have been made and would not invoke the data checking.

Dialog Icons

These icons are present on the right hand side of each dialog. They are used to get information on and to copy individual fields including check boxes, radio buttons and editable text in a dialog.

Copy Data

This is used to copy one field in a dialog so that it may be pasted into multiple nodes or links. Click the copy icon , and then click the user field, radio button, or check box on the dialog. 

Help

Click this button to get help on the current dialog.

Field Information

This is used to get information on one field within a dialog so that it may be used in the creation of an XPX file. Click the information button icon, and then click the user field, radio button, or check box on the dialog.


The Menus

The pull-down menu titles appear on a menu bar displayed underneath the window title. Each menu title represents a group of related commands. If certain commands do not make sense in the current context of what you are doing, they are disabled and are indicated by being less prominent and shaded light gray. 

Commands that require more information that are typically entered in a dialog box, are indicated with ellipsis "..." after the menu item name. Items with sub-menus are indicated with a right arrow head ►.

Tools

Icons are provided for creating and manipulating objects comprising the network, performing calculations, and managing project files. These icons are called tools and are grouped as toolbars.

The display of the toolbars is managed by selecting Toolbars from the View menu. Use the check boxes to toggle the on/off appearance of the toolbars. 

In the default layout, there is one tool strip under the menu bar and another on the right side of the drawing window. If a less than optimal screen resolution is being used, these tool strips might span several rows and columns. Each of the toolbars can also be moved from the tool strip to form a palette or be docked to the outer sides of the window, providing you the flexibility to customize you work area. As a palette, clicking the "X" in the upper right hand corner can turn off the toolbar.

The strips may be returned to the original position (docked) by clicking the header and dragging the tool strip to the desired location or simply double-clicking the header.

The icons are grayed out when the tools are inactive. For convenience, the icons have all been presented in their active state. The selected icons have a yellow background highlight.

The descriptive title of the icon appears when you hover the mouse over the icon and the icon's purpose is described.

The tool strips are:

File Management Tools
Clipboard Tools
Scenario Tools
Job, Layers & Mode Control
Background Image Tools
Solve/Review Results Tools

Object Creation Tools
Network Viewing/Navigation
Global Storms
Project Tools*


*If launched in the project mode, the Project tools will appear to the left of the File Tools.

File Management Tools

The icons in this tool strip are used for file management functions.

New File

Creates a new database.
New Default TemplateCreates a new file using the default template.
Open FileOpens an existing database.
Save FileSaves an existing database.
Print NetworkPrints the current view of the network to the default Windows printer.
Browse FileLaunches the selected output file in the defined text editor; default editor is Notepad++.
HelpLoads the help file.

Clipboard Tools

These tools perform the standard Windows Cut, Copy, and Paste functions.

Scenario Manager Tools0/85

The Scenario Manager allows you to create an unlimited number of scenarios. A scenario can have child scenarios indicated by an indentation in the scenario tree control. Each child scenario inherits the attributes of its parent. To view the existing scenarios or to create a new scenario, select Edit in the Base Scenario list box.

See Tutorial 13 - The Scenario Manager for more information about using the Scenario Manager.

Job, Layers, and Mode Control Tools

These tools are used to access the Job Control dialog, show or hide the Layers Control Panel, and set the active mode.

Job controlOpens the Job Control dialog box of the current mode.
Layers controlShows or hides the Layers Control Panel.
Snap toolToggles the snapping mode off/on. Use to select objects or vertices of polygons.
Runoff (Rnf) Changes the mode to Runoff .
Sanitary (San ) Changes the mode to Sanitary. This is not be available inxpstorm.
Hydraulics (Hdr) Changes the mode to Hydraulics.

Background Image Tools

The icons in this toolbar are used to manipulate any background images that may be present.

Add PictureAdds a new background image.
Picture PropertiesViews or edits the properties of the background image.
Tip

Background images may also by managed using the Layers Control Panel.

Solve and Review Results Tools

These icons provide shortcuts to the more commonly used menu commands that are associated with reviewing model results.

XP Tables

Shortcut to the XPTables command under the Results menu.

Quick Data View

Shows or hides the Quick Data View panel. Quick Data View settings may be accessed from the View menu.

Graphical Encoding

Shortcut to the Graphical Encoding command under the Results menu.

Spatial Reports

Shortcut to the Spatial Reports command under the Results menu.

Review Results

Shortcut to the Review Results command under the Results menu.

Dynamic Long Section

Shortcut to the Dynamic Long Section command under the Results menu.

Dynamic Section Views

Shortcut to the Dynamic Section Views command under the Results menu.

Ensemble Statistics UtilityShortcut to the Ensemble Statistics Utility command under the Results menu.

Dynamic Plan View

Shortcut to the Dynamic Plan View command under the Results menu.

Solve

Shortcut to the Solve command under the Analyze menu.

Object Creation Tools

Pointer tool

This tool is used to select objects, move objects, reconnect links, re-scale the window, change object attributes, and enter data. At the network level, the Pointer tool is used specifically to manipulate the current selection, move the current selection around, reconnect links, and for re-scaling. At the dialog level, it is used to select a data item or to position the cursor for editing text.

The "current selection" is the set of objects that many menu commands operate on. Objects that are members of a selection are indicated in inverse video (bright magenta). To make a single object the current selection, just point to it and click. 

To select a group of objects in a single operation, hold the mouse button and drag the dotted outline of a box around the desired group. To deselect everything, click in open space. All the objects in a path between two nodes can be selected by first clicking one node, and then, with the <Shift> key held down, clicking the other end node.

To extend a selection, hold the <Ctrl> key in conjunction with the selection operation. The <Ctrl> key allows new selections to be toggled.

Text tool

This tool is used to annotate the network by placing text objects on the network. The selection of the text tool causes the cursor to change to an arrow with word "TEXT" below it. You may then move to the location to enter the text, press the mouse button, insert the text, and terminate it with the <Enter> key. 

The text serves as a comment or notation for the network and may be moved or modified in the same manner as any other object. The attributes of the text such as color and font can be edited by double-clicking the text string with the pointer tool

Node tool

This tool is used to create nodes on the network. These may physically represent a manhole or pit, an inlet for a catchment, a junction of links, a pond or retarding basin, an outfall or a Best Management Practice (BMP). Selecting the node tool changes the cursor to the node shape and places you in a mode for creating node objects. Clicking anywhere inside the window will create a new node at that point with default display attributes.

In some cases, the node shape may change to represent different physical structures. Triangular nodes have storage properties other than the system defaults.

Link tool

This tool is used to create an open or closed conduit between two nodes. Links cannot exist without nodes at the end points, and the direction is indicated by an arrow line. When the link tool is selected, the cursor changes to a link shape, and you are in a mode for creating links between nodes. The first click in the window defines the node from which the link emanates. The next and subsequent clicks identify the node to which the link joins. A straight line is then drawn between these two nodes with an arrow indicating direction.

If the mouse is not clicked on an existing node, then a default node is created at that point for the new link. Following each mouse click in the drawing area, a cyan colored line tracks the mouse's movements, indicating how the new link will appear. This is the most effective way of creating a new network.

The drawn link between nodes does not need to be straight and can contain vertices if it is drawn as a polylink. 

Note
polylink is a special type of link that has vertices between the two end-nodes. It may be used to define the path of a river, indicate a curved pipe, or used in any situation where the end-nodes are not connected in a straight path.
Multi-link tool

This tool is used to create a link that joins two nodes in a network by more than one conduit, such as a dual drainage model with a street and a closed conduit between each node. This type of link includes the choice of up to seven open and closed conduits applicable to the link tool but in addition includes diversion structures, such as pumps, weirs, orifices, regulators and other real time control elements. To create a multi-link, select the multi-link tool and the cursor changes to a pointer with a broken link underneath.

An existing link may be converted to a multi-link by selecting it, right-clicking and selecting Multi Link from the menu. Also, an existing multi-link may be converted to a link (single conduit shape) by selecting it, right-clicking and selecting Single Link from the menu.

The drawn multi-link between nodes does not need to be straight and can support vertices if it is drawn as a polylink as described in the Link tool.

Bridge Link toolThis tool is used to create a description of a bridge conduit that joins two nodes in a network. This link will allow a description of bridge overtopping as well as flow under the bridge using a natural channel shape. Piers, culverts, or other obstructions representative of the bridge hydraulic opening can also be described.
River Link toolThis tool is used to create a river link, or river reach. This link allows you to create a continuous series of links. Intermediate nodes are generated with each click. These node dialogs are unique to the river link. Each portion (area between intermediate nodes) of the river link can be defined with a separate natural section. When importing a HEC RAS model, the river link is used by default. 
Polyline toolDraws a polyline (line with multiple vertices). Polylines are used to represent 2D boundaries, 1D/2D connections, and breaklines. Before creating the polyline, you must select the type of polyline by selecting the appropriate layer in the Layer Control Panel. The layer also needs to be visible and unlocked.
Polygon toolDraws a polygon (enclosed area). Polygons are used to create catchments for the Runoff mode, and specific types of areas within the 2D domain. Before creating the polygon, you must select the type of polygon by selecting the appropriate layer in the Layer Control Panel. The layer also needs to be visible and unlocked.
Trigger PointA trigger point can be digitized to measure water level in 2D. If attached to a Dynamic Elevation shape, the trigger point’s water elevation can be used to modify dynamic elevation shapes.
Ruler toolMeasures the distance between two points, the length of a polyline, or the perimeter and area of a polygon. It also measures the current segment slope and the total slope when a DTM is present. Select the Ruler tool and draw line segments on the network.
Section Profile

Cuts a temporary free hand cross section on the TIN and displays the result in a graph. 1D and 2D water surfaces also display in the resulting section view.

Note: If the cross-section line has less than 10 points, the graph tool will pad additional points in between the farthest points recursively to have a minimum of 10 points. This is done to produce a smoother interpolation of the HGL on the graph.

Network Viewing and Navigation Tools

Add Objects to Mode +

Adds selected object(s) to the active mode.
Remove Object from Mode -Removes selected object(s) from the active mode.
Select All LinksShortcut to the Select All Links command under the View menu. Use Shift and this icon to select only active objects in the mode.
Select All NodesShortcut to the Select All Nodes command under the View menu. Use Shift and this icon to select only active objects in the mode
Fit WindowRe-scales the network to fit the current window.
Regenerate ViewRegenerates the network without changing the current location or scale.
Zoom In X2Magnifies your view of the network by a factor of 2X (or half the scale).
Zoom Out X2Shrinks your view of the network by a factor of 2X (or double the scale).
Window Area In Magnifies your view of the network by a user defined factor that is set by selecting this icon and dragging a box around the area you wish to see. 
Window Area Out Shrinks your view of the network by a user defined factor that is set by selecting this icon and dragging the box inside, which the current view of the network will fit. 
Pan Moves your view of the network by a user defined offset that is set by selecting this icon and dragging the network from the old location to the new location. 
Previous View Restores previous view. This tool may be used multiple times.
Tip

Scrolling the mouse is tied to zoom in and zoom out, and right-mouse-drag performs a pan.

Global Storms

If the Global Storms tool is selected (Configuration > Job Control > Runoff > Global Storms), a dialog displays the list of storms available for analysis. See Tutorial 10 - Creating Design Storms and Using Global Storms for more information on using this feature.

Project Tools

You can use this feature if Projects is enabled in the SWMXP.INI file or the check box Projects is selected in the License Details dialog of the Help menu.

New ProjectThis icon is used to create a new project database.
Open ProjectThis icon is used to open an existing project database.

Layer Control Panel

In the default setting, the application opens with the Layers Control Panel docked to the left side of the viewing area. This panel is used to manage settings for layers in both 1D and 2D models. The layers are organized in expandable groups in a Windows Explorer style fashion. If your version does not have all of the modules, some of the layers will not be disabled.

Viewing the Layers Control Panel

Clicking the Layer tool on the Job Control tool strip toggles the (show/hide) attribute of the Layers Control Panel. When the Layers Control Panel is showing, clicking the (x) on the right corner of the header will hide the panel.

Layers Control Panel Layout

The Layers Control Panel has two layout modes: docked and undocked. The default layout is docked to the left border of the main window.

The panel may be undocked by double-clicking the header or dragging it to a new location. It may be docked to the left or right border of the main window. When it is undocked, the panel may be resized by moving the mouse over an edge or corner. When the pointer changes to a double headed arrow, hold the left button and drag the edge or side. When the panel is docked, its width may be adjusted by selecting the right edge, holding the left button down and dragging to the desired position.

The layers are grouped together by a header indicated with a leading +/- check box. The groups may be expanded and collapsed by clicking the check box or double-clicking the layer name. 2D layers are added as necessary by right-clicking the 2D Model and/or Topography and adding any desired layers.

Managing Layers

Each layer name is preceded by two graphics. The check box toggles the display of the layer off or on. The second is either an icon for the layer or a locked symbol. When the icon is a filled square, it indicates the current display properties of the layer.

A layer is locked by highlighting the layer name, right-clicking and selecting Lock Layer from the menu. When a layer is locked, it cannot be edited in the graphical interface. Data associated with objects in the layer may be edited. Other tasks are accessed by right-clicking the name of the layer. The menu varies according to the function of the layer. A layer can be unlocked in the same way as Lock Layer, that is, selecting Unlock Layer from the menu.

On the layers, the numbers in brackets indicate the number of objects selected and the total number of objects in the layer. Layers will also become bold when their objects are selected. When a layer is selected in the Layers Control Panel, it promotes the layer to the top and allows it to be selected in the network view over other layers in the same vicinity. Toggling the visible check of a header row will automatically change all of the layers within the category. 

The boxes preceding the names of the layers indicate their display color. 

Layers Properties

The display properties of any layer may be adjusted by right-clicking the name of the layer. Note that this resultant dialog is different for layers that are polylines, polygons, vectors, and so on.

Descriptions of layers

1D Network

Nodes

Represents manholes, catch basins, inlets, wet wells, junctions, ponds, or outfalls.
Labels (Nodes)Text strings representing the name of nodes.
CatchmentsPolygons of areas draining to specific runoff nodes (inlets).
Catchment Connections Line from centroid of a catchment to a runoff node (inlet).
SewershedsPolygons of areas draining to specific nodes (inlets) in sanitary mode.
LinksRepresent open channels and river reaches, closed conduits, pumps weirs, orifices, and special structures.
Cross-sectionsPolylines showing layout for a cross section (requires a DTM).
Water Level LinesPolylines use to display 1D and 2D results map simultaneously.
Labels (Link)Text strings representing the name of links.
RiversRepresents a series of nodes and links in natural cross section.
TextsUser defined annotation.
Spatial ReportsBoxes, brackets or drop shadows of object data and results for Nodes and Links.
Graphical EncodingThematic mapping or changing the display properties of objects according to user defined criteria.
2D Model

Grid Extents

Polygon boundary of a 2D model domain with cell location and orientation.
Active AreasPolygon boundaries of the active cells in the 2D model or 2D floodplain.
Inactive AreasPolygon boundaries of the cells excluded for 2D analysis or polygons for the 1D floodplain.
Initial Water LevelsPolygon boundaries for assigning cells an initial 2D water elevation.
1D/2D InterfacesPolylines along active 2D area polygons that share water level with 1D nodes.
1D/2D ConnectionPolylines from nodes to the 1D/2D interface vertices.
2D/2D InterfacesPolylines along the 2D-2D domains to share water level between domains.
Head boundariesPolylines where constant or time series head boundaries are specified.
Flow boundariesPolylines where constant or time series flow boundary conditions are specified.
Head Flow boundariesPolylines with a head and flow rating curve.
Rainfall/Flow Areas Polygons used to define areas of a rainfall, runoff hydrograph, or user definedhydrograph.
Flow ConstrictionsPolygons and Polylines used to represent bridges and culverts modeled in 2D.
Evacuation RoutesPolylines following evacuation routes to record depth and time of flooding.
LanduseGroups of Polygons of defined landuses to assign roughness and infiltration to cells.

 

Topography

DTM

Digital Terrain Models (TIN).
Gully BreaklinesPolylines indicating locations of gullies.
Ridge BreaklinesPolylines indicating location of ridges or topographic divides.
Fill AreasPolygons indicating areas above the DTM filled to a constant elevation.
Dynamic Elevation Shapes Polylines and Polygons that react with trigger points.
Trigger PointsPoints that measure 2D water elevation to affect Dynamic Elevation Shapes.
Elevation ShapesPolygons indicating areas above the DTM filled to a constant elevation.
Reporting

1D Flood Maps

Color coded water depths of 1D natural channels intersecting the DTM.
2D Maps

Color coded water depths, WSEL or hazard (velocity times depth). Many other results may also be displayed (stream power, bed shear, and user defined values).

2D Vectors

Arrows (vectors) showing flow or velocity direction and magnitude for the 2D grid cells.

Times

Time to Peak velocity and depth results.

Time Series Outputs

Lines and Points recording 2D overland flow, velocity, and depths.

FlowLines and arrows showing the amount of water per time in a defined flow line.
Time Series Outputs

Points recording 2D water elevation and velocity.

Head/VelocityPoints that show the energy difference in the water column expressed as height.
Water Surface

Polylines to drape on surface to show 2D water profile and DTM.

Legends

Legends for the 2D vectors and maps layers.

Diagnostics GIS Files showing 2D geo-referenced error and warning messages.
Other Types

GIS Files

MapInfo or ESRI Shape files.

CAD Files

CAD .dxf or .dwg files.

Background ImagesOrtho-photos and other georeferenced image files such as .BMP, JPG, Tiff, and ECW.

Quick Data View

The Quick Data View panel is enabled using View > Quick Data View menu command. The panel may be docked next to the Layers Control Panel or floated. Double-click on the panel header to toggle between the two display modes.

This panel displays node or link data organized according to an XP Table. The drop list is used to select the table. Use the tabs at the bottom of the panel to select node or link objects.

When a GIS layer is active, the GIS tab is used to display the attributes of a selected GIS object.

Questions

  1. In the LayoutDemo.xp model, select the objects and open the dialog to find the value of the following parameters:

    Object

    Parameter

    Value

    Manhole

    Spillcrest


    Pipe1

    Diameter


    Outfall

    Invert


    Culvert 

    Length


  2. Use the Ruler tool to measure the straight line distance from the Catch Basin to the Outlet. _____
  3. Sketch the appearance of the mouse pointer after each step.
    • Click the Pointer tool
    • Select the Channel and hover over a segment
    • Right click and select Edit Vertices from the popup menu 
    • Mouse not over channel 
    • Mouse over line segment 
    • Mouse over vertex


Scroll PDF Exporter Ignore

Quick Link
imagecheckbox_checked.png
linkGetting+Started+Training+Material
titleBack to: Getting Started Training Material

Stylesheet
stylepadding: 20px; border-bottom: none !important;
classindent-list
Table of Contents
maxLevel2
minLevel2
indent20px
printablefalse