Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

xp models are used to simulate the hydraulics in sanitary and combined sewer systems. Models account for gravity flow in open or closed top conduits, storage in wet wells, pumps, and flow in force mains. Networks may be looped or have multiple outfalls.

Numerous tools are used to develop constant and time series flows and unit rated flows. Daily and weekly variation patterns may be assigned to any flow. Infiltration and wet weather flows are described in Tutorial 8 - Wet Weather Flows in Sanitary and Combined Systems. Water quality routing and treatment are described in Tutorial 9 - Modeling Stormwater Quality Best Management Practices.

Most sanitary utility managers make use of some form of asset management or GIS software to manage the collection system data. The program has a variety of tools to import such data as background images, GIS layers, or directly as objects in the model. The data used for this exercise has been received from a GIS department and is edited or appended to add additional information. Also, there are some instances where additional information may be needed (for example, conduit shapes, Manning’s n, etc.).

ESRI shape file, MapInfo MID/MIF, Autodesk DWG/DXF files, and georeferenced photographs with extensions of *.ECW, *.SID, *.JPG, *.TIF, *.BMP and others may be added to the models as background images. When shape files are incorporated as background images, the display can be color coded by attribute value.

In Part 1 of this tutorial, you will build a sanitary sewer collection system model by importing data from external databases. Fields in the xp model will be filled by data from *.dbf, *.shp,and *.xpx files. In Part 2, a Digital Terrain Model (DTM) will be constructed using the manhole (pit) ground elevations.

Part 1 – Building a Sanitary Sewer Model from External Data

A collection network can be developed in the graphical user interface using a variety of methods. In Part 1, you will learn how to utilize xp’s tools to import GIS and database files to develop a pipe network including dry weather flow data, node data, and conduit data. Global data is added using XPX files.

LevelNovice
Objectives

Introduce the steps required to:

  • Build a sanitary sewer model using external data
  • Load images using Shape files as the background image
  • Digitize a network importing all node and conduit data
Time2 hours
Data filesThe model will be developed from data contained in the files listed in Table 1.


Table 1 – External data files used to build sanitary sewer model
 


  1. Launch the program:
    1. At the opening dialog, select New.
    2. In Windows Explorer, navigate to the desired folder, and name the file LMW71. A file with the default extension (.xp) will be created.
    3. In the Units dialog, select Metric and then click OK.

  2. Add the background image:
    1. On the Layers Control Panel, check the visible box for Background Images. Right-click Background Images and select Add Background Image.


    2. In the dialog, browse for the file Cadastre.shp, and then click Open. This file is georeferenced so that the width, height, and destination rectangle boxes are read directly from the file and cannot be edited. 
    3. Fill in the ESRI Shape File Attributes dialog and select green color for both field values of FEATURE_TY. Click OK twice.



  3. Import the node data from shape file attribute tables. 

    Note

    For the Evaluation version of the software: Import the model node data by browsing to File > Import/Export Data > Import XPX/EPA file, then select the LMW71 Evaluation 20 Node Version.xpx file. Upon import, zoom fit the view using the Fit to Window tool in the right menu panel, and then skip to step 9. Note that the outfall will be node 87657303.

    For the fully licensed software version, please follow the steps outlined below:


    1. Go to File > Import/Export Data > Import/Export External Databases.



    2. Select New to launch the External Database Wizard dialog. 

       
       
    3. Click Select a File. In the Open dialog, highlight SanNodes.dbf and then click Open. Click Next.
       


    4. In the External Database Wizard - Step 2 dialog, select SanNodes in the Tables field. Click Next.



    5. In the External Database Wizard - Step 3 dialog, select Import Data only and then click Next.


       
    6. In the External Database Wizard - Step 4 dialog, select Create New or Update Existing from the list. Click Next.



    7. In the External Database Wizard - Step 5 dialog, fill in the texts as shown in the following. Click Preview Table Data to check the data in the table. Click Next.



    8. The final steps involve assigning the columns of data in the database to variables in the program. Use the variable selections shown below for the node and link spreadsheets. Highlight one field at a time and select Set to get the Variable Selection: Node Data screen to show. Choose the XP Variables that describe the Field (for example, SPILLCREST > Ground Elevation (Spill Crest)).

       
       
    9. Set the XP Variables for Ground Elevation, Invert, Ponding Type, and Outfall Flag. Click Finish to exit the External Database Wizard - Step 6 dialog.



    10. With SanNodes highlighted, click Import. A preview table will be displayed. Data may be edited here. After reviewing the data, click OK.



       
    11. The results of the import are displayed. Click OK.



    12. Click Close to view imported nodes in the network view. 
       
  4. Import Conduit, Pump, and Flow data. The database mappings for the remaining database files are listed in Table 2. For each file, repeat the procedure described in Step 2 for SanNodes.dbf. Create a new database connection and follow the steps outlined in the wizard. The figure below shows the layout of the nodes and links of the imported sanitary sewer model.

  5. Save your file as LMW72.xp and close.



  6. An alternative method to rapidly build a network from shape files:

    Note
    Note that this alternate method is just to make you familiar with another import method. It is not necessary that you follow this alternate method. If you would not like to go for an alternate method, go to Step 7.


    1. Reload the file LMW71.xp and Save As LMW73.xp.
    2. On the Layer Control Panel, make the nodes and links visible and selectable. Right-click the Nodes layer and select Import From GIS File.
    3. Next, select SanNodes.shp and then click Open. In the Import GIS File dialog, click Import.



    4. In the Set Nodes Names From Attribute Data field, select NODE_NAME(30 Char) from the list and then click OK. The results of the import are reported.



    5. Right-click the Links layer. 
    6. Choose Import From GIS File. Next, select SanCond.shp and then click Open
    7. In the Import GIS File dialog, click Import.



    8. In the Link Name section, check the Set Links to Attribute Data radio button and select LINK_NAME (32 Char) from the list. 

    9. Under Connectivity Options, select User Define and select US_NODE (30 Char) and DS_NODE (30 Char). Click OK. The results of the import are reported.


      Note
      Note that you have imported the nodes and links to the model. However, you have not imported the pumps or the elevations of links and nodes yet. This will be completed in the next step. 
  7. Import the Nodes’ and Links’ Elevations, Dry Weather Flow Temporal Patterns, and Pump Curves from XPX files.They can be imported by an XPX file which is an efficient method of importing several pieces of data for a number of objects.

    1. On the File menu, select Import/Export Data > Import XPX/EPA Data

    2. Click Select and Open the file that is called Elevations.XPX

    3. Click Import. Click OK on the generic Import Warning Message.



    4. Double-click and open the Node Data dialog. You will see the Spill Crest and Link Elevation are imported.

    5. Now, repeat the importing procedure for both the DWF.xpx and PC.xpx files to import the Dry Weather Flow Temporal Pattern and Pump Curves to the model.

      The contents of the DWF.xpx is as follows:

      Code Block
      GLDB "Temporal Variations" 0 "Residential DWF"     /* Daily and Hourly Peaking Factors */
      /* Daily variations */
      DATA T_DV "" 0 7 1.0 1.0 1.0 1.0 1.0 1.0 1.0
      /* Hourly variations */
      DATA T_HV "" 0 24 .71 .67 .64 .62 .64 .71 .95 1.36 1.48 1.45 1.26
      1.07 .98 .93 .9 .88 .95 1.24 1.3 1.14 1.07 .95 .88 .76


      The contents of the Pump Rating Curves XPX file are: 

      Code Block
      GLDB "Pump Ratings" 0 "FIXPUMP"     /* Pump Curve */
      /* Pump Curve */
      GLDBDATA PRATEY "Pump Ratings" "FIXPUMP" 3 0.025 0.025 0.025
      GLDBDATA PRATEX "Pump Ratings" "FIXPUMP" 3 5.45 2.05 0.150
    6. Now, go to Configuration > Global Data

    7. Find (SH) Temporal Variation in the left panel and click Residential DWF in the right panel.

    8. Click Edit

    9. Review the hourly variation pattern. Click OK twice to return to the network view. 


       

    10. Go to Configuration > Global Data

    11. Find (H) Pump Rating Curves in the left panel and click FIXPUMP in the right panel.

    12. Click Edit

    13. Review the pump rating curve. Click OK twice to return to the network view.



  8. Check the Time Control for the Hydraulics Job Control:
    1. Go to Configuration > Job Control > Hydraulics
    2. Change to the current date for the start time and three days later for the end time.
       
  9. Define the Outlet control:

    1. Use the Find tool (<Ctrl>+F) to locate node 88651701

    2. Double-click to open the Node Data dialog. 

    3. Double-click Outfall and then click Type 1, Free Outfall



    4. Click Use minimum of Yc_Yn. Click OK three times to return to the network view.



  10. The model contains two conduits that have lengths less than the default minimum length (10 m) required for the numerical engine. To avoid warning messages produce during simulation, add a Configuration Parameter
    1. On the Configuration menu, select Configuration Parameters
    2. Type MINLEN=9.0. Select Add and then click OK.
       


  11. Save your file.
  12. Solve the model. Click the Solve icon  .

Questions regarding Importing:

File extension for the node data table import?                           _____.

File extension for the dry weather flow import?                          _____.

File extension for the Import from GIS file?                                 _____.


Questions regarding the Pumps:

What is the pump flow rate?                            _____.

What is the pump speed factor?                      _____.

The pump is rated by?                                    _____.


Part 2 – Building a DTM from Node Ground Elevations

In Tutorial 2 - Surface Water Hydrology, you learned how to build a digital terrain model (DTM) by reading a XYZS text file. Part 2 of this tutorial will show you how to build a DTM using imported Node Ground Elevations.

LevelNovice 
 Objectives Introduce the steps required to:
  • Build a DTM using Node Ground Elevations
 Time 0.5 hours
 Data files LMW72.xp (same as file developed in Part 1)


  1. Build the DTM:
    1. Open the file LMW72.xp and Save As LMW74.xp
    2. On the Layers Control Panel, check the visible box next to Topography
    3. Right-click DTM Layers and select DTM Builder.

       

    4. In the DTM Creator dialog, click Read Node Ground Elevations. Click Create DTM.



    5. A dialog will open asking for the name of tin file. Type in the name LMW.xptin and click Save.
       
  2. Adjust the display of the DTM layers:
    1. On the Layers Control Panel, right-click the line corresponding to the xptin that was just created. 
    2. Select Properties from the menu. Click the Display Properties tab. 
    3. Adjust the display properties to Show Major Contours at 2 m and Show Minor Contours at 0.25 m intervals as indicated in the figure below. 
    4. Clear the Fill Color on Height Range box. 
    5. Select the Display Legend option. 
    6. Click OK.

       

    7. Right-click the xptin on the Layer Control Panel and select Edit Colors to open the DTM Gradient Colors dialog.
    8. Set the transparency to Opaque. Click OK twice.



    9. Review the project area in the network view. Note that a Z coordinate is included in the status bar at the bottom. You may clear the 1D Network layer for a better view of the created DTM. Move the cursor over the network and you will see the Z values for the cursor locations. 

       


 

Questions

  1. In regards to the DTM used in this exercise, what are the:

    Number of points                              _____

    Minimum elevation                          _____ m

    Maximum elevation                          _____ m
     

  2. On the File menu, select Properties and click Job Statistics. In the current column what are the number of:
    _____ links

    _____ nodes

    _____ pictures
     

  3. The program can read from ___ different external files to create a DTM.

Scroll PDF Exporter Ignore

Quick Link
imagecheckbox_checked.png
linkGetting+Started+Training+Material
titleBack to: Getting Started Training Material

Stylesheet
stylepadding: 20px; border-bottom: none !important;
classindent-list
Table of Contents
maxLevel2
minLevel2
indent20px
printablefalse