Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

After a polygon has been drawnIn Runoff mode (Rnf), the program simulates the rainfall, infiltration, evaporation, and depression storage for each subcatchment and calculates the runoff to a collection node. A variety of hydrologic methods is available to generate runoff hydrographs.


In this tutorial, you will learn how to utilize XP's tools to layout a collection system network and develop input data from GIS files. Standard design storms will be imported from a template file. Runoff will be simulated using both SCS and EPA SWMM hydrology. Finally, model results will be reviewed graphically and in tabular format.

You are advised to review The XP User Interface tutorial for an overview of the windows, menus, tools, and basic concepts for building and navigating a stormwater collection network with XP's graphical interface.

Note

The following tutorial uses  US Customary  units, for the metric document please download the METRIC TUTORIAL.

Part 1 – Laying out a network using GIS layers

A collection network can be developed in the graphical interface using a variety of methods. In Part 1, you will learn how to utilize XP tools to layout a collection system network over GIS background images and develop input data from information in GIS files. 

LevelBeginner
Objectives

Introduce the steps required to:

  • Layout a runoff collection network using a background image for node locations
  • Define subcatchment drainage areas using a DTM layer
  • Use XP tools to calculate subcatchment areas
  • Connect subcatchments to runoff nodes

Time

1 hour
Model Capability Number of Links/Nodes9/10
Add-on Modulesnone
2D Sizenone
Evaluation Version CompatibleYes
Data filesContours.xyz (used to create TIN)
Yarra_Area.dwg (background image)


  1. Launch the program. At the opening dialog, select New. In the Windows Explorer, navigate to the desired folder and name the file Yarra21. A file with the default extension (.xp) will be created. In the Units dialog, select US Customary and then click Continue.
  2. Add the CAD layer:
    1. On the Layers Control Panel, check the visible box for CAD Files. 
    2. Right-click CAD Files and select Load CAD File.
    3. In the dialog, select the file Yarra_Area.dwg
    4. Click Open to display the image on the network view. This file is georeferenced so that its x and y coordinates are coincident with the proposed drainage network. 
  3. Browse the project site. Hold the mouse wheel or right button down and the moving hand (Pan Tool)  appears next to the cursor. Drag the screen around. Roll the wheel forward to zoom in and backwards to zoom out. 
  4. Adjust layer display:
    1. Right-click the new layer with the name of the .dwg file. 
    2. Select Properties from the menu.
    3. Toggle the check boxes for the Edge of PavementLot Boundaries and Road Names layers and click OK to view the drawing. This view now exposes the storm water features on the site. 
    4. Then turn them back on again and proceed to the next step.

  5. Build the DTM:
    1. On the Layers Control Panel, check the visible box next to Topography
    2. Right-click the DTM layer and select DTM Builder
    3. In the DTM Builder dialog, select Read XYZ File.
    4. Navigate to the file contours.xyz and click Open. The X, Y, and Z coordinates of the survey points are displayed. The S column is used for break lines. Use this dialog to edit the coordinates. 
    5. Click Create DTM. A dialog will open asking for the name of the TIN file and the location to save it. Type in the name contours.xptin and save this in the default location. A contours.xptin file will be created. Click Save

    6. Adjust the display of the DTM layer: 
      1. On the Layers Control Panel, right-click the newly created surface in the Layers window. 
      2. Select Properties from the menu and click the Display Properties tab. 
      3. Adjust the Display Properties to show major contours at 5 ft and minor contours at 1 ft intervals as indicated in the figure below. 
      4. Uncheck the Fill Color on Height Range box.
      5. Select the Show Major Contour at and the Show Minor Contour at check boxes. 
      6. Click OK.


    7. Click Color to open the DTM Gradient Colors dialog and set the transparency to an opaque percentage of your choice. This setting would alter the appearance of the fill colors, but the contours are not affected. Click OK twice to exit.



  6. Review the project area:
    1. Zoom in on the upper right hand corner of the drawing. 
    2. On the View menu, select Set Scale
    3. Enter 1500 and click OK
    4. Hold the right mouse down so that a hand (Pan tool) appears next to the cursor. Drag the drawing towards the upper right corner (at the intersection of Malden and Black) so that the network view appears as in the image below. You can save this view in View >  Save View.



    5.  Release the right button and use the mouse wheel to zoom in and out. Locate the proposed gravity collection system beginning at Node 3/2.

  7. The next step is to draw the catchment polygons using the DTM:
    1. On the Layers Control Panel, check the visible box for the Catchments layer. 
    2. Right-click the Catchments line and select Properties from the menu. 
    3. Set the properties as indicated in the dialog below using shades of green. The colors can be modified by clicking in the existing color on the right side of the dialog.



  8. Draw the catchment for node 5/4. A catchment is defined as the area draining to a specified location. In the program, catchments are represented by polygons.
    1. Highlight the  Catchments  line in the  Layers  Control Panel and click the  Polygon  tool. A polygon symbol will appear next to the cursor.



    2. Click Node 5/4 and move to the location for the next vertex and click. Continue drawing the polygon and double-click to close. The catchment should appear about as shown in the diagram to the right. 
      Note: In this tutorial, as shown in the images below, the catchments were drawn with no pattern for maximum visibility and presentation.

    3. After a polygon has been drawn, it may be edited:
      1. Select the polygon. The vertices and the centroid will be highlighted. 
      2. Move the mouse over a vertex.
      3. Click and drag the vertex to a new location. Release the mouse when done.
        Note: Make sure that in the  Layers  Control Panel, the  Catchments  are not locked. If the  Catchments  are locked, you cannot edit the vertices. To lock or unlock the catchments go to the  Layers  Control Panel, under  Catchments . Tick on the catchments to make the layer visible, click to highlight the layer. Turn off the catchment labels as they are not necessary for this tutorial. Now right-click and choose Lock or Unlock Layer. 


    4. When a vertex is selected, right-click. A popup menu will access other editing options.

  9. Draw the catchment polygons for nodes 5/3, 5/2, 6/1, 4/1, and 3/2. They should appear about as in the diagram below. Use the snap on/off button  to allow you to attach to the previous drawn vertices.


  10. Add nodes to the model:
    1. Set the mode to Runoff by clicking the Rnf tool.
    2. On the Layer Control Panel, uncheck the visible box for the DTM and Catchment layers. 
    3. Click the Node icon on the drawing tool strip. A circle will appear next to the cursor   . 
    4. Click once on the location of nodes 3/2, 3/1, 4/1, 5/2, 5/3, 5/4, and 6/1 on the background image. A circle will appear on the network with the labels Node 1 through Node 6.
    5. Add additional nodes at the ends and junctions of the green line on the background image. Toggle the visible box of the CAD Files to review the locations of the nodes. Nodes may be moved by clicking one and holding the cursor over its location. The cursor will appear as a four-arrowed cross.
    6. Hold the left button down and drag the node to its new location. Release the left button. The layout of nodes should look like the diagram below. Do not worry if your labels are different as they have been assigned default names that may be changed later. 
    7. Uncheck the CAD Files in the Layer Control Panel for better viewing.
       
    8. Edit node display properties:
      1. On the drawing tool strip, select the Select All Nodes tool  . In the network view the nodes should be highlighted. 
      2. On the Edit menu, select Properties to open the Node Display Properties dialog. 
      3. Modify the Display Size of the Text Height and the Node Size by entering the data in the dialog as shown below. 
      4. Select the Modify buttons in the Text Height and Node Size sections. 
      5. Click OK.


  11. Add links:
    1. Click the Link tool on drawing tool strip. A vertical pipe will appear next to the cursor   . 
    2. Click the upstream node and extend the link to the downstream node. Click once and continue to the next downstream node. End the drawing by double-clicking. 
    3. To draw another link, click the link tool again and repeat the process.
  12. Rename the catchment nodes:
    1. Select Node5 and right-click. Select Properties from the menu to open the Node Properties dialog. 
    2. In the Node Name field, replace "Node5" with "5/4". Repeat for nodes 5/35/26/14/13/1, and 3/2.
  13. Make the catchment nodes active:
    1. Click the Select All Nodes tool and then the Select All Links tool. 
    2. Click the minus tool  . This will make all objects in the network inactive. 
    3. Next, hold the <Ctrl> key down and click nodes 5/4, 5/3, 5/2, 6/1, 4/1, and 3/2. 
    4. Click the plus tool  . This will make only the catchment nodes active in the Runoff mode. The network should appear as shown below in the Runoff Rnf mode:
  14. Define Catchment Connections display properties:
    1. On the Layers Control Panel, check the visible box for Catchment Connections
    2. Right-click and select Properties
    3. Set the display settings as shown in the figure below:

  15. Link the catchments to the nodes:
    1. Select Catchments  in the Layers Control Panel.
    2. Select a catchment in your network map.
    3. Move the cursor over the centroid. The cursor will appear as shown below. 
    4. Hold the left button down and draw a dashed line to the Node 5/4. The cursor will appear as a cross. 
    5. Release the left button and a menu will appear. Designate the area as Subcatchment 1 for the Node 5/4.


    6. Link the respective subcatchments (as Subcatchment 1) for Nodes 5/3, 5/2, 6/1, 4/1 and 3/2.

  16. Calculate catchment areas:
    1. On the Tools menu, select Calculate Node and then Catchment Areas. The program will display a dialog showing the old (0.0 because they have not been defined) and new (calculated from the subcatchment polygons) areas. The new areas may be edited to override the calculation. The actual value may vary due the the freehand drawing of the polygon.




    2. Click OK to accept the new value(s). All nodes with linked catchments will report new areas. This data is added to the model database. This function will report that the calculation was successfully completed. Review the data by double-clicking the node or the catchment. 
  17. Save your file as Yarra21.xp.

Questions:

  1. In regards to the DTM used in this exercise, what are the:

    Number of survey points_____
    Minimum elevation _____ ft
    Maximum elevation_____ ft
     
  2.  Open the File menu, select  Properties  and click Job Statistics . In the current column, what are the number of:

    _____ links
    _____ nodes
    _____ pictures
     
  3. Program allows up to _____ subcatchments per runoff collection node.

Part 2 – Adding Design Storms and SCS Hydrology

In the program, design storms and rainfall hyetographs can be imported by various methods. In the United States and elsewhere, a set of commonly used design storms are the SCS 24-hour cumulative storms. This section demonstrates how an SCS rainfall distribution is imported using XPX formated files and developed into a design storm.

LevelBeginner
Objectives

Introduce the steps required to:

  • Import global storms from XPX files
  • Assign design storms to subcatchments
Time0.5 hours
Data files
  • Yarra21.xp (model developed in Part 1)
  • Yarra_Area.dwg
  • contours.xptin (DTM developed in Part 1)
  • SCS Rainfall Distributions 1inch(mm).xpx (design storm hyetographs)


  1. Open the file Yarra21.xp
  2. On the File menu, select Import/Export Data > Import XPX/EPA Data. Locate the file SCS Rainfall Distributions 1inch(mm).xpx in the Templates folder. Enter the data in the dialog as shown below. Click Import.
    Note: The Templates folder can be populated by downloading and installing the templates from the xpswmm/xpstorm  Resource Center Downloads.

     

    Click OK on the Import Warning dialog. This warning always displays since importing can overwrite existing data, it allows you to not proceed by clicking Cancel. The SCS rainfall distributions have now been added to the Global Database.
  3. Create the 2.7 inch – 24 hour design storms from the SCS Type II distribution: 
    1. On the Configuration menu, select Global Data
    2. In the left panel, select (R) Rainfall
    3. In the right pane,l select SCS Type II
    4. Click Duplicate. A new storm "SCS Type II.1" is created.

       

    5. Select the "SCS Type II.1" rainfall. In the editing box below the Record Name column, change the name to 5yr-24hr SCS Type 2. Click Rename. Click Edit to open the (R) Rainfall dialog. 



    6. Click the Constant Time Intervals radio button.


    7. In the next dialog, enter 2.7 as the Multiplier. Note that this is the total depth in inches for the design rainfall. Total depth is equal to the average intensity multiplied by the rainfall duration. Click Graph




    8. Click Close and then click OK three times to return to the network view.
  4. Enter the SCS Hydrology data:
    1. Make sure that the mode is set to  Rnf  (Runoff Mode). 
    2. Double-click Node 5/4  to open the runoff dialog. In this model, only subcatchment 1 is used for each node. The area has been previously calculated. 
    3. Set the Impervious Percent (Imp %) to 20.The Width and Slope are not used in SCS Hydrology. However, the program requires that these fields have nonzero values – enter 1 for each. 
    4. Click the  1  button to activate the subcatchment and advance to the next dialog. 


    5. Click the box next to Rainfall
    6. Select the 5yr-24hr SCS Type 2 storm from the Global Database. 
    7. Click the SCS Hydrology radio button. In the SCS Hydrology dialog, set the Pervious Area Curve Number to 70 and the Time of Concentration to 7 minutes. Use the remaining default values.



    8. Click OK three times to return to the network view.

  5. In a similar manner, enter the following data for the remaining runoff nodes. 

    Node

    Imp. (%)

    Pervious Area Curve Number

    Time of Concentration (min)

    5/3

    60

    70

    5

    5/2

    40

    70

    5

    6/1

    45

    70

    5

    4/1

    20

    70

    10

    3/2

    30

    70

    8

  6. Save your file as Yarra22.xp.

Questions:

  1. In regards to the 5yr-24 SCS Type 2 storm used in this exercise, what is the:

    Total rainfall_____ in.
    Maximum intensity _____ in/hr
    Time of Maximum intensity_____
  2. Does the program require the rainfall to be the same over the entire network?

Part 3 – Job Control Settings & Running the Model

In the program, settings for the calculation are managed in the Job Control dialog. This part reviews some of the Job Control settings in Runoff mode.

LevelBeginner
Objectives

Introduce the steps required to:

  • Manage runoff job control settings
  • Run the analysis
Time0.5 hours
Data files Yarra22.xp (model developed in Part 2)
Yarra_Area.dwg 
contours.xptin (DTM developed in Part 1)


  1. Job Control settings:
    1. On the Configuration menu, select Job Control > Runoff
    2. Enter the text Yarra Storm Water Quality in the Job Title field as shown below. 
    3. Click Evaporation.


    4. Select Use default of 0.1 inch or 3 mm per day and then click OK.



    5. In the Runoff Job Control dialog, click Time Control. Enter Jan 1, 2014 00:00:00 for the start time and Jan 2, 2014 00:00:00 for the end time. 
    6. Select Use Simulation Start Time For Rainfall Event and then click OK.
      Image Modified

    7. In the Runoff Job Control dialog, click Print Control. Select the Print summary at end of simulation and Statistical summary only radio buttons. 


    8. Click OK twice to return to the network view.

  2. Go to Configuration > Mode Properties > Solve Mode to set the Current Mode to the following:

    Note
    Notes: 
    - If you are using xp storm, uncheck the RUNOFF and HYDRAULICS and then select Current Mode
    - If you are using xpswmm, you do not need to make any change since it is set to solve the Current Mode by default.

  3. Simulating the Hydrology:
    1. Save your file as  Yarra23.xp
    2. On the Analyze menu, select  Solve . Alternatively, the Solve icon can be toggled. A Windows Explorer dialog will open. Use the default name for the output file ( Yarra23.out ) by clicking Save . The program will display a dialog indicating the status of the calculation. When the simulation is completed, the application returns to the network view.



  4. Reviewing results. 
    1. Select the six nodes with subcatchments by holding the <Ctrl> key and clicking each node. 
    2. Click the Review Results tool  . This command will display graphs of rainfall and runoff for each of the selected nodes. Options for viewing these graphs are presented later in this tutorial.



  5.  Save your file as Yarra23.xp

Questions

  1. Which node had the highest ____ and lowest ____ peak runoff?
     
  2. Is it necessary to run the analysis more than 24 hours?

Part 4 – SWMM Hydrology (Non-Linear Reservoir Method)

Another popular catchment routing procedure is the EPA SWMM non-linear "Runoff" method. Overland flow hydrographs are generated by a routing procedure using Manning's equation and a lumped continuity equation. Surface roughness and depression storage for pervious and impervious area parameters further describe the catchment. The subcatchment width parameter is related to the collection length of the overland flow and is easily calculated based on the watershed area. The method can include infiltration modeled with the Horton or Green-Ampt equations or using a uniform loss rate.

LevelBeginner
Objectives

Introduce the steps required to:

  • Define the runoff parameters in a subcatchment
  • Use graphical interface tools to develop subcatchment data
  • Use the global database to manage infiltration data
  • Use graphical tools to obtain data from catchment parameters
Time0.5 hours
Data files Yarra23.xp (same as file developed in Part 3)
Yarra_Area.dwg 
contours.xptin (DTM developed in Part 1)


  1. Using "Runoff" Hydrology: 

    1. In the network view, double-click Node 5/4 to open the data dialog. 

    2. Enter 300 ft for the width and 0.02 ft/ft for the slope in the Subcatchment 1 column. 


    3. Double-click the 1 button to open the Subcatchment dialog. 

    4. In Routing Method, select the Runoff radio button. Click the Infiltration button to open the Infiltration Global Database list.



    5. Type soil properties in the blank field and then click Add

    6. With the soil properties record highlighted, click Edit. Enter the Impervious (Depression storage = 0.2 in, Manning's n = 0.015, and Zero Detention = 25 %) and Pervious Area (Depression storage = 0.4 in and Manning's n = 0.05) data as shown and click Green Ampt.



    7. In the Green Ampt Equation dialog, enter Average Capillary Suction = 5.0 in, Initial Moisture Deficit = 0.18, and Saturated Hydraulic Conductivity = 0.5 in/hr. Click OK twice.

       

    8. In the Global Database list for Infiltration, highlight soil properties and click Select, returning to the Subcatchment dialog with soil properties listed on the Infiltration button.



    9. Change the Routing Method to Runoff and edit the data for the remaining nodes according to the following schedule. Make sure to set the routing method to Runoff and select Soil Properties as the infiltration method for each node.

      Node

      Width, ft

      Slope, ft/ft

      5/3

      350

      0.01

      5/2

      200

      0.05

      6/1

      225

      0.05

      4/1

      150

      0.02

      3/2

      135

      0.03

  2. Using graphical interface tools to measure horizontal and vertical distances and areas:
    1. To measure distances, select the Ruler tool 
    2. Click to begin a measurement. Click once to locate a vertex. Double-click to end the measurement. The current distance is the length of the last line segment. The Total Distance indicates the length of a polyline. To measure an area, draw a closed polygon.



    3. The Ruler tool can also be used to generate slopes for the current line segment, and for all segments. Additionally, the Section Profile tool   can be used. The cursor will show a drawing polyline. Move the cursor to the start point. Click to begin. Move the cursor to a new location. Click to add a vertex. Double-click to end. The program will then display the cross section of the drawn polyline. Calculate the slope by dividing the difference in elevation by the total distance.


       
  3. Save your file as Yarr24.xp. Run the analysis.
     
  4. Review results:

    1. Follow the procedure described in Step 3 in Part 3 to review graphical results for the runoff nodes. 

    2. Click the Properties tool   to open the properties dialog. 

    3. In the Show section, select 1 Graph per Page from the drop-down list. 

    4. Select Infiltration in the Hydrology Rates section. 

    5. Click OK.

       

    6. With the cursor anywhere on the graph grid, right-click to reveal a menu for graph customization and export options.
       

Questions

  1. In regards to the results for Node 5/4, what is the:

    Maximum infitration rate_____ in./hr
    Maximum rainfall intensity _____ in./hr
  2. Why does infiltration peak before the maximum rainfall?

Part 5 – The Output File

In the program, a variety of tools are available for examining model results.

LevelBeginner
Objectives

Introduce the steps required to:

  • Add XPTables to an existing database
  • Review results in the output file
Time0.5 hours
Data files Yarra24.xp (same file developed in Part 4)


  1. Open the file Yarra24.xp. Go to the File menu and Save As Yarra25.xp.
  2. On the File menu, select Import /Export Data >  Import XPX/EPA Data. Click the Select button and navigate to the Basic-Tables.XPX file in the templates folder.  
  3. Click Open and then click Import. Click OK when the Import Warning is displayed.



  4. Click the XP Tables   icon. Use the arrows at the lower corner of the screen to navigate to the  Rain + Infiltration  table. Data with blue shading cannot be edited. Data with a white background is input data. Note that the rainfall reference can be edited as a drop list of all storms in the Global Database.


  5. Use the arrows at the lower corner of the screen to navigate to the Subcatchment Results table. Data with blue shading are results which cannot be edited. Data with a white background is input data. In the Name column, nodes that are inactive are displayed with a white text. After review, close the XP Tables window.


  6. Solve the model:
    1. Save your file. 
    2. On the Analyze menu, select Solve. A file called error.log is generated with each solve. If errors or warnings are produced, the file will be displayed with your default text file editor. If no errors or warnings are produced, the error log does not appear. The engine dialog will appear and the model will be solved.


  7. Review the Output File. On the Results menu, select Browse File, navigate to your project folder and open 1D/Yarra25.out with your default text editor. This file is generated every time the model is solved. It contains information regarding the settings, input data, and results. This information is useful for debugging, calibrating, and obtaining detailed model results. Selected sections are described here.


The beginning section presents information about the software version and the input data file. Users are encouraged to use the latest version of the product. 
Current Directory: C:\XPS\XPSWMM2012 
Engine Name: C:\XPS\XPSWMM2012\SWMMEN~1.EXE 
Input File : C:\XPS\xpswmm2012\Getting Started\2 - SWHydrology\Yarra25.XP 

===============================================

xpswmm

Storm and Wastewater Management Model

Developed by XP Solutions Inc.

===============================================


Last Update : October, 2015

Interface Version: 2016

Engine Version : 12.0

Data File Version: 12.62




===============================================  
The tables produced by a runoff analysis are listed below. 
===============================================


RUNOFF TABLES IN THE OUTPUT FILE.

These are the more important tables in the output file.

You can use your editor to find the table numbers,

for example: search for Table R3 to check continuity.

This output file can be imported into a Word Processor

and printed on US letter or A4 paper using portrait

mode, courier font, a size of 8 pt. and margins of 0.75


Table R1 - Physical Hydrology Data

Table R2 - Infiltration data

Table R3 - Raingage and Infiltration Database Names

Table R4 - Groundwater Data

Table R5 - Continuity Check for Surface Water

Table R6 - Continuity Check for Channels/Pipes

Table R7 - Continuity Check for Subsurface Water

Table R8 - Infiltration/Inflow Continuity Check

Table R9 - Summary Statistics for Subcatchments

Table R10 - Sensitivity analysis for Subcatchments


========================================================== 
Table R5 contains the continuity check and basin wide results for various runoff parameters. 
************************************************************

  • Table R5. CONTINUITY CHECK FOR SURFACE WATER *
  • Any continuity error can be fixed by lowering the *
  • wet and transition time step. The transition time *
  • should not be much greater than the wet time step. *
    ************************************************************
    Inches over
    cubic feet Total Basin
    Total Precipitation (Rain plus Snow) 4.428092E+04 2.700
    Total Infiltration 3.121430E+04 1.903
    Total Evaporation 1.640034E+03 0.100
    Surface Runoff from Watersheds 1.074659E+04 0.655
    Total Water remaining in Surface Storage 6.850230E+02 0.042
    Infiltration over the Pervious Area... 3.121430E+04 2.600Precipitation + Initial Snow Cover *
                • Infiltration + Evaporation + 
                  Surface Runoff + Snow removal +
                  Water remaining in Surface Storage +
                  Water remaining in Snow Cover......... 4.428594E+04 2.700
                  Total Precipitation + Initial Storage. 4.428092E+04 2.700
                  The error in continuity is calculated as
                  ***************************************
  • - Infiltration - *
    *Evaporation - Snow removal - *
    *Surface Runoff from Watersheds - *
    *Water in Surface Storage - *
    *Water remaining in Snow Cover *
    -------------------------------------
  • Precipitation + Initial Snow Cover *
    ***************************************
    Percent Continuity Error............... -0.0113 

    The output file ends with notes indicating that the calculation ended successfully. 

    ===> Runoff simulation ended normally.
    ===> XP-SWMM Simulation ended normally. 
    ===> Your input file was named: C:\XPS\xpswmm2012\Getting Started\2-SWHydrology\Yarra25.DAT 
    ===> Your output file was named: C:\XPS\xpswmm2012\Getting Started\2-SWHydrology\Yarra25.out 
    ==============================================================


    SWMM Simulation Date and Time Summary


    ==============================================================

    Starting Date... April 9, 2015 Time... 16:46:26:47

    Ending Date... April 9, 2015 Time... 16:46:27:37

    Elapsed Time... 0.01500 minutes or 0.90000 seconds

    ==============================================================

Questions

Review the output file ( Yarr25.out ) to answer the following questions.

  1. In the network, what are the areas:

    Total catchment_____ ac
    Impervious area_____ ac
    Pervious area_____ ac
  2. For the storm event, what are the volumes of:

    Rainfall _____ ft3
    Runoff_____ ft3
    Evaporation_____ ft3
    Surface storage_____ ft3
     
  3. Which subcatchment had the highest peak runoff rate?

    Subcatchment_____
    Peak runoff rate_____ ft3/s 

Part 6 – Network Building Tools and Shortcuts

In the XP interface, numerous tools are available to streamline the model building process. This tutorial demonstrates the direct import of nodes, links, and catchment polygons from shape files. 

Level

Beginner
Objectives

Introduce the steps required to:

  • Create a model from a template
  • Use default settings for network objects
  • Import nodes, links, and catchments from shape files
Time0.5 hours
Data files

Master_US.xpt (template file)
yarra_network_pt.shp (GIS files for nodes)
yarra_network_arc.shp (GIS files for links)
yarra_catchments_poly.shp (GIS files for catchment polygons)


  1. Create a new model from a template:
    1. Close any open model.
    2. On the File menu, select New > Create From Template.
    3. Enter Yarra-new.xp  as the file name and then click Save.
    4. In the Select Template File dialog, navigate to the templates folder included in the program installation. Select MASTER_US.XPT and then click Open.


    5. Click OK. Set the mode to Runoff ().
  2. Set object defaults for SCS Hydrology parameters:

    1. On the File menu, select Properties

    2. Expand the Node Defaults line and select Node Data. Select all rows in the table and click (X) to delete. 

    3. Click the ellipses (…) in a blank row in the table or click the (plus) button on the top right of the dialog to add a new row to the table. 

    4. In the Variable Selection dialog shown below, navigate to and select Sub-catchment Flag and then click OK

    5. Continue to fill in the fields with values indicated in the following table. 

      Field

      Value

      Sub-catchment Flag

      Hydrology Methods

      SWMM Methods

      Sub-Catchment Data > Routing Method

      SCS Hydrology

      Impervious Percentage

      10

      Width

      100

      Slope

      1

      Sub-Catchment Data > SCS Hydrology > Initial Abstraction Method

      Fraction

      Sub-Catchment Data > SCS Hydrology > Initial Abstraction Fraction

      0.2

      Sub-Catchment Data > Time of Concentration

      30

      Sub-Catchment Data > SCS Hydrology > Pervious Area Curve Number

      75

    6. Click OK to close the File Properties and Options dialog. 

    7. In the network view, create a new node. Open the Node Data dialog and note that the runoff parameters are the default values. 
       

  3. Import nodes from shape file:
    1. On the Layers Control Panel, check the visible box for the Nodes layer. Make sure that it is not locked. 
    2. Select the Nodes layer and right-click. Choose Import from GIS File.



    3. Navigate to the file yarra_network_pt.shp   and then click Import. 


    4. Click the Set Node Names From Attribute Data radio button. 
    5. Select COMNAME field from the drop-down list and then click OK. The application reports the results of the import. The network view should show 10 nodes.


  4. Import links from the shape file:
    1. On the Layers Control Panel, check the visible box for the Links layer. Make sure the layer is unlocked. 
    2. Select the Links layer. Right-click and select Import from GIS File from the menu. 
    3. Navigate to the file yarra_network_arc.shp  and then click Import.


    4. Click the Default Name and Link End Points radio buttons. Click OK. The application reports the results of the import. The network view should show eight links and 10 nodes. Note that there are two separate networks in the view.

       
  5. Load catchments from GIS:
    1. On the Layers Control Panel, Nodes group, check the visible box for the Catchments layer. Make sure the layer is unlocked. Right-click and select Import from GIS File from the menu.



    2. Navigate to the yarra_catchments_poly.shp and then click Import




    3.  In the Catchment Data Mappings dialog, set the Node Name to BASINID and then click Import. The application will report the number of polygons imported. 


    4. The catchment polygons are displayed in the network view. Right-click the catchments layer in the Layers Control Panel and select Properties to adjust the display of the catchments.

      Note: In the image below, the link labels are turned off and the links have their direction reversed. Also, the line thickness is reduced to 0.02.


Questions

  1. Open the data dialog for a runoff node and confirm that it has all of the default values defined in step 2.
  2. What is the length between node 4/1 and node Junction? ____ ft.
  1. Click Open to display the image on the network view. This file is georeferenced so that its x and y coordinates are coincident with the proposed drainage network. 
Scroll PDF Exporter Ignore

Quick Link
imagecheckbox_checked.png
linkGetting+Started+Training+Material
titleBack to: Getting Started Training Material

Stylesheet
stylepadding: 20px; border-bottom: none !important;
classindent-list
Table of Contents
maxLevel2
minLevel2
indent20px
printablefalse