xpswmm/xpstorm opens with a row of menus across the top of the window. The second row contains the icons grouped into tool strips. 


 Additional tool strips are usually docked against the right edge of the window. However, they can be configured as floating toolbars or docked to other parts of the main window to customize the workspace based on the users' preferences.

 

File Management Tools

New File

This icon is used to create a new database.

Open File

This icon is used to open an existing database.

Save File

This icon is used to save an existing database.

Print Network

Prints the current view of the network to the default Windows printer.

Browse File

This icon provides a shortcut to the Browse File command under the Results Menu

Help

Load the xpswmm on-line help (this file and associated resources)

Clipboard Tools

These tools perform the standard Windows Cut, Copy and, Paste functions.

Scenario Manager Tools

The Scenario Manager allows you to create up to 50 scenarios. A scenario can have different child scenarios, with each child scenario inheriting the attributes of its parent. To view the existing scenarios or top create a new scenario, click the ellipsis (…) beside the Base Scenario list box.

The checkbox is used to indicate which scenarios are active when the model is Solved or when Review Results or XP Tables is selected. If the checkbox is not ticked then this scenario will not be solved. Turn on a scenario to include its results in graphical or tabular output.

Unknown User (reynard.juanir) the links for Solved, Review Results and XP Tables are missing.

New is used to create a new scenario. The new scenario is created as a child to the currently selected (highlighted) scenario.

Delete is used to permanently remove an existing scenario. To temporarily disable a scenario remove the tick from the checkbox.

Rename is used to change the name of an existing scenario.

Properties is used to display the changes between a child scenario and its parent.

The currently active scenario is displayed in the Scenario Report listbox. This report may be printed or copied to another application. Although the cells may be edited, the edits are not saved when the report is closed with the OK button.

The scenario selected here is the active scenario and the one to which changes in network topology or data will be applied. This scenario will be used for data in Dynamic Section Views, Dynamic Long Section,  Dynamic Plan Views and, Perspective View.

However, in Review Results, a drop menu is used to select any or all scenarios. These tools are useful for comparing scenario results.

Unknown User (reynard.juanir) the links for Dynamic Section View, Dynamic Long Section and Dynamic Plan View are missing.

XP Tables show data for the currently active scenario plus results for all scenarios.

Job, Layer & Mode Control Tools

These tools are used to access the Job Control dialog, toggle the Layer Control Panel (show/hide) and, to set the xpswmm active mode.

Job Control

Used to access the Job Control Dialog Box

Layer Control

This icon toggles show/hide of the Layer Control Panel

Snap Tool

Toggles the snapping mode off/on. Use to snap vertices of model links and polygons to existing vertices of these objects and vertices in GIS Layers.

Runoff

This icon is used change the mode to Runoff.

Sanitary

This icon is used change the mode to Sanitary.

Hydraulics

This icon is used change the mode to Hydraulics.

Unknown User (reynard.juanir) links for Job Control, Layer Control, Snap Tool, Runoff, Sanitary, and Hydraulics are missing.

Background Image Tools

The Icons in this Toolbar are used to manipulate any background images that may be present.

Add Background Image

Use this icon to add a new image

Background Picture Image

View or edit the properties of the background image.

Background images may also by managed using the Layer Control Panel. 

Solve and Review Results Tools

These icons provide shortcuts to the more commonly used menu commands that are associated with reviewing model results.

XP-Tables

Shortcut to the XP-Tables command under the Results Menu.

Quick Data View

Toggle the Quick Data View panel visible/hide. Quick Data View settings may be accessed from the View Menu.

Graphical Encoding

Shortcut to the Graphical Encoding command under the Results Menu.

Spatial Reports

Shortcut to the Spatial Reports command under the Results Menu.

Review Results

Shortcut to the Review Results command under the Results Menu.

Dynamic Long Section

Shortcut to the Long Section command under the Results Menu.

Dynamic Section Views

Shortcut to the Dynamic Section Views command under the Results Menu.

Dynamic Plan View

Shortcut to the Dynamic Plan View command under the Results Menu.

Perspective View

Shortcut to the Perspective View command under the Results Menu.

Solve

Shortcut to the Solve command under the Analyze Menu.

 

Object Creation Tools

Icon

Function

Pointer Tool

This tool is used to select objects, move objects, reconnect links, re-scale the window, change object attributes and to enter data. At the network level the Pointer tool is used specifically to manipulate the current selection, move the current selection around, reconnect links and for re-scaling. At the dialog level it is used to select a data item or to position the cursor for editing text.

The "current selection" is the set of objects which many menu commands operate upon. Objects that are members of a selection are indicated in inverse video (bright magenta). To make a single object the current selection, just point to it and click.

To select a group of objects in a single operation the mouse button is held down and the dotted outline of a box is dragged around the desired group. To deselect everything, the mouse is clicked in open space. All the objects in a path between two nodes can be selected by first clicking on one node, then, with the <Ctrl> key held down, clicking on the other end node.

To extend a selection, the <Shift> key is held down in conjunction with the selection operation. The <Shift> key causes new selections to be toggled.

Text Tool

This tool is used to annotate the network by placing text objects on the network. The selection of the text tool causes the cursor to change to an arrow with word “TEXT” below it. The user moves to the location to enter the text, presses the mouse button, inserts the text, terminating it with the <Enter> or <cr> key. xpswmm remains in the text input mode until another object creation tool is selected.

The text serves as a comment or notation for the network and may be moved or modified in the same manner as any other object. The attributes of the text such as color and font can be edited by double-clicking on the text string with the pointer tool.

Node Tool

This tool is used to create nodes on the network. These may physically represent a manhole or pit, an inlet for a catchment, a junction of links, a pond or retarding basin an outfall or a Best Management Practice (BMP). Selecting the node tool changes the cursor to the node shape and places you in a mode for creating node objects. Clicking anywhere inside the window will create a new node at that point with default display attributes.

In some cases the node shape may change to represent different physical structures. Triangular nodes have storage properties other than the system defaults.

Link Tool

This tool is used to create an open or closed conduit between two nodes. Links cannot exist without nodes at the end points, and have a sense of direction indicated by an arrow line. When the link tool is selected, the cursor changes to a link shape, and the user is in a mode for creating links between nodes. The first click in the window defines the node from which the link emanates. The next and subsequent mouse clicks identify the node to which the link joins. A straight line is then drawn between these two nodes with an arrow indicating direction.

If the mouse is not clicked on an existing node, then a default node is created at that point for the new link. Following each mouse click in the drawing area, a dotted line tracks the mouse's movements, indicating how the new link will appear. This is the most effective way of creating a new network.

The drawn link between nodes does not need to be straight and can support vertices if it is drawn as a poly-link.

Multi-Link tool

 

This tool is used to create a link that joins two nodes in a network by more than one conduit such as a dual drainage model with a street and a closed conduit between each node. This type of link includes the choice of up to 7 open and closed conduits applicable to the link tool but in addition includes diversion structures such as pumps, weirs, orifices, regulators and other real time control elements. To create a multi-link, select the multi-link tool and the cursor changes to a pointer with broken link underneath.

An existing link may be converted to a multi-link selecting it, right clicking and selecting Multi Link from the pop-up menu. Also an existing multi-link may be converted to a link (single conduit shape) by selecting it, right clicking and selecting Single Link from the pop-up menu.

The drawn multi-link between nodes does not need to be straight and can support vertices if it is drawn as a poly-link.

Bridge Link tool

 

This tool is used to create a link joining two nodes in a network representing a bridge crossing. During HEC RAS imports, bridges will be modeled in bridge links by default. The bridge link can contain numerous openings (culverts, piers, etc.)

River Link tool

 

This tool draws a segmented River Reach comprised of river segments and intermediate river nodes. It is designed to simplify the modeling process for users with river modeling experience. The river link is the default object when importing HEC RAS models.

Polyline tool

Draws a polyline (line with multiple vertices). Polylines are used to represent 2D boundaries, 1D/2D connections and breaklines. Before creating the polyline the user must select the type of polyline by selecting the appropriate layer in the layer control panel. The layer also needs to be visible, movable and selectable.

Polygon tool

Draws a polygon (enclosed area). Polygons are used to create catchments for the Runoff mode, and specific types of areas within the 2D domain. Before creating the polygon the user must select the type of polygon by selecting the appropriate layer in the layer control panel. The layer also needs to be visible, movable and selectable.

Ruler tool

Used to measure distance between two points, the length of a polyline or the perimeter and area of a polygon. In version 2013 and later, the ruler tool displays the total slope of a multi-segmented line and the slope of the last segment. This can be used to determine and enter the slope for catchments and other fields. Select the Ruler tool and draw line segments on the network.

Cross section tool

Used to cut a temporary free hand cross section on the TIN and display the result in a graphic

Network Viewing and Navigation Tools

 

Tool Name

Symbol

Function

+ (Plus)

Adds selected object(s) to the active mode

- (Minus)

Removes selected object(s) from the active mode

Select All Nodes

This icon provides a shortcut to the Select All Nodes command under the View Menu

Select All Links

This icon provides a shortcut to the Select All Links command under the View Menu

Fit Window

Re-scales the network to fit the current window (Fit Window )

Regenerate View

Regenerates the network without changing the current location or scale.

Zoom In X2

Magnify your view of the network by a factor of 2X (or halve the scale).

Zoom Out X2

Shrink your view of the network by a factor of 2X (or double the scale).

Window Area In

Magnify your view of the network by a user defined factor which is set by selecting this icon and dragging a box around the area you wish to see.

Window Area Out

Shrink your view of the network by a user defined factor which is set by selecting this icon and dragging a box inside which the current view of the network will fit.

Pan

Move your view of the network by a user defined offset which is set by selecting this icon and dragging the network from the old location to the new location.

 

Project Tools

This Toolbar is only enabled if Projects is enabled in the SWMXP.INI file or the checkbox is on in the License Details dialog of the Help Menu.

New Project This icon is used to create a new project database.

Open Project This icon is used to open an existing project database.

See Also Project Menu .

Global Storms

The Global Storms tool is used to simultaneously solve the Runoff Mode for multiple storms.

The Global Storms drop list appears when the Global Storms is checked in the Runoff Job Control settings.

The Global Storms dialog is launched be either selecting the Global Storms button in the Runoff Job Control dialog or clicking on the ellipses (…) on the Global Storms  Tool Bar.

The dialog contains a row for each storm in the Global Database. Check the box for each storm to be included in the analysis. Contents of the remaining fields are described in Runoff Job Control settings.

When Global Storms are used, do not check the Run Hydrology/Hydraulics Simultaneously in the Hydraulics Job Control settings.