The Results menu contains the functions for data review and the display of results.


Browse File

This command allows the user to browse any text file on the system. This command is intended to allow users to view their output files without leaving the XP environment but can be used for any ASCII text file.

When you select a filename Notepad.exe, or the editor referred to in SWMXP.INI will be loaded. See the Help menu of your selected editor for more information.

To review the output file open the filename.out file with the Browse File Dialog. This file is located in the same folder as the XPSWMM project file.

Review Results

The Review Results tool provides graphical post-processing and presentation of the XPSWMM and XPStorm analysis. Graphical display of input data and hydrologic, hydraulic, and water quality results on a user defined set of network elements is provided.

 To use this tool the links and/or nodes you wish to examine must be: 

    1. active
    2. selected

See Selecting an Object to define the desired selection set then select Review Results from the Results Menu (or F7).

The graphs are titled:

Node: The name of the selected node

Conduit: The name of the link from upstream node to downstream node

Diversion: The name of the link from upstream node to downstream node

For conduits and diversions, upstream and downstream nodes are determined by flow direction.

Depending on the modes used in the model and the types of links, up 12 different graphs may be constructed. The parameters that may be plotted for each Element – Mode combination are listed in the table below.


Mode

Element Type

Runoff (Rnf)

Sanitary (San)

Hydraulics (Hdr)

Water Quality (WQ)

Node


Flow

Pollutant load

Pollutant concentration

Gauged Flow

Flow

Pollutant load

Pollutant concentration

Gauged Flow

HGL (Stage)

Pollutant load

Pollutant concentration

Gauged Level

Cumulative Overflow

Pollutant load

Pollutant concentration

Flow

Outflow

Duration

Percent Exceedence

Cumulative Percent

Subatchment

(Node)

Rainfall

Snowmelt

Infiltration

Evaporation

Rainfall Excess

Groundwater Flow

Groundwater Stage




Conduit


Flow

Velocity

Pollutant load

Pollutant concentration

Gauged Flow

Flow

Velocity

Pollutant load

Pollutant concentration

Gauged Flow

Upstream HGL

Downstream HGL

Flow

Velocity

Gauged Flow

Flow

Outflow

Velocity

Pollutant load

Pollutant concentration


Diversion

Pump

Wier

Orifice

Flow

Velocity

Pollutant load

Pollutant concentration

Gauged Flow

Flow

Velocity

Pollutant load

Pollutant concentration

Gauged Flow

Flow

Velocity

Gauged Flow

Flow

Outflow

Velocity

Pollutant load

Pollutant concentration

In version 2013 and later, all diversions and conduits can be viewed in the Review Results graphs. Each item in the multilink can be viewed by using the previous/next controls  on the Review Results toolbar. The conduit (if any) will be displayed by default. 

To view a diversion, users can toggle the red diversion button on the Review Results toolbar and then scroll through up to seven items within the same multilink, using the previous/next controls mentioned above.  

When more than one scenario is active, only one parameter is plotted. Drop menus are used to select the parameters and which scenarios results are plotted. In XPSWMM 2013 and later, multiple diversions are plotted simultaneously. Each graph can be maximized and variables to be plotted (flow, velocity, etc.) are selected from the menu in the Review Results toolbar. Individual scenarios or all scenarios can be selected and viewed for each item.

When running Continuous Simulations and using pollutants or Water Quality (WQ), the Duration, Percent Exceedence, and Cumulative Percent graphs can be created. The following images illustrate examples:

The Percent Exceeding graph is displayed below. Note, the properties of the graph were altered to a logarithmic scale via the Customization Dialog.


The Duration graph is shown below. Again, the Customization Dialog was used to alter the display properties of the graph.


The following tools may be used to navigate though the graphs and to customize the graphs.

Display first graph

Display previous graph

Display next graph

Display last graph

Display graph for nodes

Display graph for inlet capacity

Display graph for conduits (pipes and channels)

Display graph for diversions (pumps, wiers and orifices)

Open Review Results Options dialog

Print graph

Print preview graph

Open new window with the Runoff graph

Open new window with the Sanitary graph

Open new window with the Hydraulics graph

Open new window with the Water Quality graph

Open new window with the Base graph

Open new window with the Cumulative Probability graph

Open new window with the Percent Exceeding graph

Open new window with the Flow Durations graph

Close the graph window

To move from one element type (node, link or diversion) to the next use the icons for nodes, links or diversions.

To move within a category use the arrow keys. To go to the beginning of a category use the icon. To go to the end of a category use the icon.

Multiple graphs (1, 2, 4, 9 or 16) may be shown on one page. To change the number of graphs or the parameters plotted, select the Review Results Properties icon.

The Review Results window is a multi-document interface (MDI). Each time you select one of the Rnf, San, Hdr or WQ icons another window will be created.

From any graph, two additional sets of graphics options are available:

Doubling clicking the primary mouse button wil launch the Customization Dialog.

Right clicking will launch the Graph Options pop-up menu.

The user may zoom in on any section of the graphic by drawing a box over the graph with the primary mouse button. Undo the zoom by right clicking and selecting Undo Zoom from the pop-up menu.

Review Results Properties

The Review Results Properties Dialog allows the user to specify how graphs are constructed and displayed.

When Start Time and Stop Time are set to automatic, the graphs present the complete simulation period. For other time periods, set the Start and Stop times to the number of days from the beginning of the model.

The Y-Axis scales may be displayed as Normal (arithmetic), log scale or allowing XPSWMM to automatically select the appropriate scale.

The drop list allows the user to select 1, 2, 4, 6, 9, 12 or 16 graphs per page.

The check boxes allow the user to select which parameters are plotted. Note: only the parameters that are appropriate for the element type and mode are plotted.

For Runoff, Sanitary and Water Quality plots, the list of parameters in the model are displayed in the right column. The user may select any, some or all of the pollutants for the box.

Graph Customization Options

Right click on the graph to invoke the pop-up menu.

Viewing Style 

Review Results supports three viewing styles: 

  • Color
  • Monochrome
  • Monochrome with Symbols

This customization allows you to quickly adjust the image to best suite printing on a monochrome printer. If fewer than four subsets are to be included in a graph, then the Monochrome setting will probably be the best choice. If four or more subsets are to be included in the graph, then Monochrome with Symbols will help distinguish the different subsets.

Font Size

Review Results supports three font sizes, Large, Medium, and Small. Depending on the size of the graph, the user can select the font size that is most readable. When printing the graph, a font size of Medium or Small is suggested.

There are occasions, (mainly when attempting to generate an image for a highly rectangular graph) the graph may automatically reduce the size of the font in order to produce a higher quality image.

Numeric Precision

When placing data labels onto the graph, or exporting Text/Data from the Export Dialog, the number of decimal positions can be between 0 to 3.

Data Shadows

Depending on the Plotting Method, this option will draw shadows behind bars, points, and the area of an area graph. The shadow is always black.

Grid Lines

The graph can contain vertical grid lines, horizontal grid lines, both vertical and horizontal grid lines, or no grid lines. 

Grid in Front

By checking this option, the graph's grid is placed in front of the data graphics. Otherwise, the data graphics are drawn on top of the graph's grid.

Include Data Labels

If this option is checked then the object's plotting method will include Data Labels into the graph. Depending upon the implementation, Data Labels will either be numeric values, or text descriptors.

Mark Data Points

Depending on the Plotting Method, this option will mark each data point with a black filled circle.

Show Annotations

If the graph contains annotations then this check box allows you to remove/add the annotations from the image.

Undo Zoom

Zooming is the process of using the mouse to select new extents of the graphs grid.

To Zoom:

  1. Press and hold the Shift key.
  2. Press the left mouse button and drag the cursor to select the new extents.
  3. Release the mouse button.

To Undo the Zoom:

Press the Z key or use the popup menu to select the Undo Zoom menu item.

Maximize

Resizes the selected graph to use the entire video display. 

When maximizing the object, the object is actually copied to a maximized dialog. The dialog (maximized object) can be closed by pressing 'Escape' or by using the mouse to Click the title bar. Making customizations to the maximized object will not affect the original (non-maximized) object.

Customization Dialog

Launches the Customization options dialog. 

Export Dialog

The Export Dialog allows the user specify the format and the destination of the graph(s). Pressing "X" on the keyboard while a graph is selected will also launch the Export Dialog. 

Graphs may be exported in the following formats to the Metafile Clipboard, Printer, or as a File.

Export formats

 EMF, WMF, BMP, JPG, PNG, Text/Data


To export a graph: 

  1. Highlight a graph by right-clicking on it, and selecting "Export Dialog." Alternatively, press 'X' once an object selected.
  2. Select the type of export desired.. 
  3. Select the destination of the export.
  4. If available, select the size of the image to export.
  5. Press the Export/Print button.

File Destination

If information is to be exported to a file, then you must enter a target filename. Click the mouse over the Browse button to show the File Save As Dialog. Enter a filename and select OK to close the File Save As dialog.

Printer Destination

If exporting a metafile to the printer, pressing the Print button will show the Print Dialog. Use the Print Dialog to make changes to the selected printer, orientation, paper bin, and other printer options.

Exporting Text /Data

When exporting Text or Data, select the "Text/Data" radio button on the dialog. If exporting to a file, click "Browse" to launch a Windows Explorer dialog and navigate to the location where the file will be saved. 

Customization Dialog

The Customization Dialog is launched by double clicking the primary button on a graph.

General Tab

Main/Sub Title. These two edit-boxes allow adding, editing, and deletion of main and sub titles. If no title is present, entering one will add one. If you remove all the characters from a title it will be deleted from the image.

Viewing StyleReview Results supports three viewing styles: 

      • Color
      • Monochrome
      • Monochrome with Symbols

This customization allows you to quickly adjust the image to best suite printing on a monochrome printer. If fewer than four subsets are to be included in a graph, then the Monochrome setting will probably be the best choice. If four or more subsets are to be included in the graph, then Monochrome with Symbols will help distinguish the different subsets.

Font Size. Review Results supports three font sizes, Large, Medium, and Small. Depending on the size of the graph, the user can select the font size that is most readable. When printing the graph, a font size of Medium or Small is suggested.

There are occasions, (mainly when attempting to generate an image for a highly rectangular graph) the graph may automatically reduce the size of the font in order to produce a higher quality image.

Show Annotations. If the graph contains annotations then this check box allows you to remove/add the annotations from the image.

Numeric Precision. When placing data labels onto the graph, or exporting Text/Data from the Export Dialog, the number of decimal positions can be between 0 to 3.

Grid Lines. The graph can contain vertical grid lines, horizontal grid lines, both vertical and horizontal grid lines, or no grid lines. 

Grid in Front. By checking this option, the graph's grid is placed in front of the data graphics. Otherwise, the data graphics are drawn on top of the graph's grid.

Plot Tab

Plotting Method. Review Results supports 15 plotting methods:

      •  Area
      • Bar
      • Box Plot (Candle Stick)
      • Bubble
      • High-Low Line
      • High-Low Bar
      • High-Low-Close
      • Line
      • Open-High-Low-Close
      • Points
      • Points plus Best Fit Curve
      • Points plus Best-Fit-Line
      • Points plus Spline
      • Spline
      • Sticks

The Polar/Smith Chart Object supports 4 plotting methods:

      • Line
      • Point
      • Points + Line
      • Stick

Depending on the implementation, some plotting methods may not be available. Also, many but not all of these plotting styles can be set for a secondary comparison plotting style. If the graph has multiple y axes, then you can control plotting and comparison plotting styles for each individual axis by selecting the axis in the axis-button group.

The graph can display up to 14 subsets at once, however, it is suggested that no more than three subsets should be displayed at any one time.

If the Comparisons as Normal check box is checked, the secondary comparison plotting style is ignored and all subsets are plotted in the primary plotting style.

Data Shadows. Depending on the Plotting Method, this option will draw shadows behind bars, points, and the area of an area graph. The shadow is always black.

Subsets Tab


This group allows the user to view subset information is a variety of ways:

    1. If nothing is selected in the listbox and Scrolling Subsets equals zero, then the object will display all subset information (14 subsets graph maximum, and no limit on the amount of subsets tabled.)
    2. If there are selections in the listbox and Scrolling Subsets equals zero, then the object will display only those subsets selected.
    3. If nothing is selected in the listbox and Scrolling Subsets is non-zero, then the object will scroll through subset information by the amount defined by Scrolling Subsets.
    4. If there are selections in the listbox and Scrolling Subsets is non-zero, then the object will maintain those selected subsets as permanent subsets and revolve through the remaining subsets in increments of Scrolling Subsets.

Fonts Tab


The graph only supports True Type fonts (because they’re scaleable). The user can select fonts for the:

    • Main Title
    • Sub Title
    • Labels Including, X-axis label, Y-axis label,
    • X-axis grid numbers or point labels,
    • Y-axis grid numbers.
    • Tabular Data Data labels included into the graph.

 For the Main Title, Sub Title, and Labels, the user can also select font attributes of Boldness, Italics, and Underline.

Colors Tab

The graph supports two sets of color parameters. A Monochrome color set and a Color color set. Depending on the Viewing Style, the Colors Dialog will customize the appropriate set.

To adjust colors:

  1. Select the desired object attribute in the Graph Attributes section. The corresponding color for that attribute will be highlighted in the color selection grid.
  2. To change the color, either use the mouse to click an alternate color, or use the keyboard arrow keys to move to adjacent colors. As the highlighted color selection changes position, the sample image will be updated with the newly selected color.
  3. Finally, Pressing the OK button will update the color parameters of the object.


Desk Background. This is the color that surrounds the bounding rectangle of the graph's grid.

Desk Foreground. This is the color that is used when placing text onto the Desk Background. This includes the main title, sub title, subset labels, grid numbers, and axis labels.

Shadow Color. The rectangle that makes up the graph's grid is bounded at the bottom/right edges with shadows. To remove the shadows, choose the same color as the Desk Background.

Style Tab



The Style tab allows the control of subset color, subset line style, and subset point style.

  • Select the desired subset in the Subsets list box. The corresponding color and possible line and point styles are then highlighted in their respective controls.
  • To change the color, either use the mouse to click an alternate color, or use the keyboard arrow keys to move to adjacent colors. Adjust the subset line and point styles as desired.
  • Finally, Pressing the OK button will update the object’s image.

Profile Plot

The Runoff and Sanitary layers do not require elevations to be entered and therefore plotting is only relevant to the Hydraulics layer. The Profile Plot allows you to save several different branches in your project and view them simultaneously in your screen. To produce a plotted profile:

  1. Select a line to be plotted by using any of the techniques in Selecting an Object or Group of ObjectsThe direction of the plot will be determined by the first link or node selected. This link or node will be plotted on the left-hand side of the sheet.  
  2. Go to View > Save View.  

     
  3. Enter a name in the View Name field (for example, Line1), and then click OK.

     
  4. Select another set of objects and then click View > Save View
  5. Enter a name in the Name field (for example, Line2), and then click OK.

    You can save as many views as you want.
  6. Go to Results ribbon and then click Profile Plot.

     
    The Profile Plot dialog shows the different branches saved for the project.

     

  7. Click the Select All button to select all branches in the Stored Views section.

    To select multiple views, hold the Ctrl key and click the preferred views. Click OK.

    To clear selections, click the Deselect All button.

     

  8. Click OK to load the ProfilePlot Parameters dialog.

     

  9. Set the horizontal and vertical scale for the plot. By default, the Scale to Fit button is selected, which causes the horizontal and vertical scales to be set such that the plot will fit on the sheet size selected. The scales selected will be a multiple of 1, 2, 2.5 and 5. 
     

  10. You may set the elevation of the Datum line for the plot. Enter chainage and depth in the format “Chainage;Depth” and then click the Add button. To modify the entry, click Edit. Click Delete to remove an entry.

  11. You may enter the Image Origin for the plot on the sheet by entering coordinates in the x and y coordinate boxes. The coordinates entered refer to the hot spot of the plotted profile. 
     

  12. In Display, select accordingly to provide annotation of DateTimeFile Name and Scales
     

  13. Click OK to display the profile plot for the branches selected.
     
     

  14. Each profile plot can be moved. Click a profile in the drop down menu and move the plot by right-clicking and dragging the plot to change the position.
     
     

  15. Move the outline of the plot around the screen using the mouse and click with the mouse button at the selected location. Press any key to return to the plot control dialog box.
     

  16. To change the scale:

      1. Clear Scale to Fit and then click OK.

      2. Go to Edit > Plot Parameters.

      3. Use the slider to change the scale.

Plot Setup

Plotting parameters such as line types, pen numbers, character sizes, precision, format of data titles and even the type of data to be presented may be changed by using this command. Note that because this facility requires invert and surface elevations to plot the profile, and all this information is not available in the Runoff or Sanitary layers, this command is only available when the current mode is the Hydraulics layer. The type of data that can be plotted is shown below.


The four main groups of data are the General, Manhole , Box Label and Attribute Data. The General data is mandatory, all other information is optional and will be plotted if the check box is enabled.

Click on the number or the check box or description to view the appropriate dialog box

Load. This command allows you to load a previously defined plot setup file (. DEF file) and saves the necessity of re configuring the plotting parameters for every plot.

Save. This command may be used to save the plotting parameters as a plot definition file for future use. It removes the necessity to define these parameters every time a plot is needed.

Use Surface Data

The Use Surface Data feature allows you to render the irregular shape of your surface data.

    1. Select a continuous set of nodes and links in your model.

      It needs to be one continuous set of links and nodes only. You cannot select pipes.
    2. Go to Results > Profile Plot. 
    3. In the Profile Plot dialog, select Use Surface Data. Click OK.


      The irregular shape of the surface data is shown in the profile plot. Moreover, the resulting profile plot shows where the conduits are and where they intersect with the current DTM.

Dynamic Long Section View

The Runoff and Sanitary layers do not require elevations to be entered; therefore plotting is only relevant to the Hydraulics layer. To produce a plotted profile (or long section):

  1. Select a line to be plotted by using any of the techniques in Selecting an Object or Group of Objects. The direction of the plot will be determined by the first link or node selected. This link or node will be plotted on the right side of the sheet. 
  2. A multilink (indicated by a dashed link) can be selected for dynamic and profile plotting, however within the multilink dialog you must indicate the conduit or diversion to be plotted. The conduit within the multilink with the "plot" radio button selected (on the Multiple Conduits or Diversion Links) will be plotted. To plot a diversion such as a pump, orifice or weir make the appropriate selection using the Plot button in the lower right hand corner of the Multiple Conduits or Diversion Links and assign a length to be used in profile since no such physical length exists. In the Dynamic Long Section and Dynamic Section Views tools the diversions will be indicated using appropriate symbols.
  3. Select Dynamic Long Section from the Results menu or press the F9 key, and a profile similar to that shown below will be displayed.


The magenta line shown in the profile is the maximum depth that water reaches during the simulation, or the Maximum HGL. This depth is independent of any MAXPTS value you might set in Configuration Parameters and is the true envelope of the maximum HGL.

The Rewind, Previous, Pause, Next, Play and Stop controls are used to start and stop the animation. The Slide Control can be used to move to a particular time step in the animation. The Faster and Slower icons are used to increase and decrease the speed of animation.


The Fit to Window, Zoom In, and Zoom Out tools are used to manage the scale of the long-section view. You can pan around the window by clicking and dragging the mouse.


The Show Grid, Show Data, Show Flow, Show Diametertools are used to change the display of the profile.

On the File Menu, the Customize command is used to access other display options.

There is an icon for orifice structures, and dynamic replay of the HGL is possible even with timesteps smaller than 1 second. Additionally, an HGL for each Scenario or Global Storm is displayed in profile for easy, quick comparison. The image below displays an example of the results in the profile (long section).  

Options

The "Options" button allows you to control the display format. You are able to display Flow and Velocity in a conduit, water levels and depths in a node plus the node and conduit names with an optional scale.

Simulation. The simulation parameters entered here control the dynamic replay of results.

Display Text Size. You may change the size of the text being displayed and printed, the major impact of this feature however is only appreciated when using true type fonts. 

Display Font, You may change the font of the text being displayed by selecting a font. The normal Windows conventions regarding bitmap and true type fonts are supported. 

Step Sensitivity. You may change the number of steps that are skipped as the simulation is played back. The default value is to show each step of the simulation. 

Note: To reduce the size of the intermediate files the number of steps in the simulation is modified to be a maximum of 500 cycles, i.e. if the simulation consists of 2,500 time steps, the 1st, 6th, 11th, etc. time steps will be printed as the 1st, 2nd, 3rd, etc. cycles.


Start Cycle No. 
The first cycle number to be used in replaying the simulation.

End Cycle No. The last cycle number to be used in replaying the simulation.

Delay (seconds). The delay between successive cycles when replaying the simulation.

Display Mode. The simulation parameters entered here control the dynamic replay of results.

Dynamic Display. When this option is selected the results of the simulation are replayed for each time-step or multiple of time steps of the simulation.

Envelope of Maximums. If this option is selected an envelope showing the maximum value the selected parameter reached during the simulation, regardless of its time of occurrence. The parameter may be Manhole Depth, Conduit Flow or Conduit Velocity.

Display Data. The Flow, and Velocity in a conduit and the Depth and Level (Elevation) in a node can be displayed by enabling the appropriate check box. Node Names, Conduit Names and Scales can be turned on or off by toggling these check boxes. When a check box is clicked on a pop-up menu is displayed from which you can select the colour in which the selected data is to be displayed.

DTM Surface Display

xp now displays DTM surfaces for Dynamic Long Sections and Dynamic Section  views by default.  DTM surfaces are shown as a brown polyline representing the elevation and length of the selected links. The DTM surface display  can be turned on or off in the Long Section Properties dialog in the File → Properties menu. 

NOTE

DTM surfaces are only available for Dynamic Long Section and Dynamic Section views.


Dynamic Section Views

The mechanism for selecting the profile to be plotted and the zooming and simulation controls are the same as those provided in the Dynamic Long Section View.



The Dynamic Section View launches in a new window with 3 panes separated by movable dividers. The top pane is identical to the Dynamic Long Section View. The lower left pane shows cross sections of the downstream end of the conduits in the selection set. The lower right panel shows the hydrographs of each conduit int the selection set. The hydrograph and cross section views can be modified in the same way as the graphs displayed using the Review Results option.

The results of the model are displayed in synchronized animation. In version 2013 and later, the Title for the long section is printed with the rest of the graphics and text.

Dynamic Plan View

The Dynamic Plan view launches in a 2-pane view. The upper view is the Bird's Eye View. The lower pane shows the color coded view of the network, the model time step and the legend.

Network objects are color coded to indicate the values of various parameters during model simulation. The display options are:

Object Options
Nodes Stage, Off
Links Flow, Velocity, Off

Display is controlled by the buttons labled “Node”, “Flow”, and “Vel.” 

The display of node and link labels is toggled with the button labeled with a flag.

While the animation is running, flow in conduits is indicated by moving slugs. The width of each conduit is proportional to the flow or velocity. Flooding of nodes is indicated by the  graphic.

The color coding of the nodes varies by node type as indicated by the table below (for Freeboard = 0).


On the File Menu, select Properties to open the Plan Section Properties dialog. Click on a colored rectangle to customize the 15-category Link scale or the 5-category Node scale.

Freeboard is the distance from a user defined safety elevation to the spill crest. If a value greater than 0 is entered, then the interpretion of the node color coding is indicated by the following table.

Spatial Report

Spatial reports of model data and simulation results can be displayed in text boxes onscreen, sent to a printer or plotter or, exported to a graphics file.

The report attributes dialog may be accessed via:

This command allows you to specify the display format of the Spatial Reports by selecting the physical attributes of the reports and the data to display in each report. This dialog specifies data for all the reports.

Destination

 

Use this dialog to specify the destination of the Spatial Report.

Frame Display Properties

 

Use this dialog to set display properties of the text boxes in Spatial Reports. It is used for links and nodes

  • In the left panel toggle the +/- (expand/collapse) box next to Nodes or Links and highlight Frame.
  • In the Backgroung section, select the Frame type and click Transparent. When Transparent is checked, a slider bar will appear to allow adjusting the transparency form 0 (left) to 100% (right).
  • Click on the Font button to select the desired font.
  • Click on OK to exit.

Node Variables

This button loads the Data Variables dialog which allows you to select the data fields you wish to display in the Spatial Report for nodes. The list displayed in the following dialog contains the full names of all data items that will be included in your spatial report for nodes.

Insert/Append 

These buttons allow you to insert a report data variable before the highlighted field in the list or at the end of the list respectively. When you select either of these buttons the following dialog showing all available data is displayed. When OK is selected the highlighted field is added to the list shown in the preceeding (parent) dialog. If the variable selected has multiple instances (ie. Catchments, Pumps, etc.) then a combination of Variable and Instance must be selected. To show all instances of a selected variable all combinations of Variable: Instance must be selected.

Delete

The delete button removes a report data variable from the list.

Format 

This button takes you to a format dialog which allows you to select the format of the highlighted variable (the format specification is always attached to the data variable, even when that variable is removed from the list). The description of the variable to be formatted is shown in the title bar of the dialog.

Text Formatting

Precision. This value specifies the number of places after the decimal point to display on the Spatial Report.

Accuracy. This value specifies the tolerance of the displayed data.

Mnemonic. This allows users to add a mnemonic to the start of each line of data displayed in the Spatial Reports.

Unit. This allows you to add a unit to the end of each line of data displayed in the Spatial Reports.

Text Attributes 

Font. This allows users to specify the font in which you wish to display the currently selected variable of the Spatial Report. The normal Windows conventions regarding birmap and true type fonts are supported.

Apply to All. If this check box is enabled then this font style will be applied to all the spatial report data for nodes. 

Size. The height of the text (in mm) in the report line is entered here. 

Apply to All. If this check box is enabled then this font size will be applied to all the spatial report data for nodes. 

Text Colour. These buttons allow you to set the colour of the report text.

 Apply to All. If this check box is enabled then this font colour will be applied to all the spatial report data for nodes.

 Link Variables

This button loads the Data Variables dialog which allows you to select the data fields you wish to display in the Spatial Report for Links. The list displayed in the following dialog contains the names of all data items that will be included in your spatial report for links.

Insert/Append. 

These buttons allow you to insert a report data variable before the highlighted field in the list, or at the end of the list respectively. 

When you select either of these buttons the following dialog showing all available data is displayed. When OK is selected the highlighted field is added to the list shown in the preceding (parent) dialog. 

If the variable selected has multiple instances (ie. Conduits, Pumps, etc.) then a combination of Variable and Instance must be selected. To show all instances of a selected data item, all combinations of Variable: Instance must be selected.

Delete

The delete button removes a report data variable from the list.

Format 

This button takes you to a format dialog which allows you to select the format of the highlighted variable (the format specification is always attached to the data variable, even when that variable is removed from the list). The description of the variable to be formatted is shown in the title bar of the dialog. The functions are similar the format dialog in the Node Variables screen. 

Location

These two radio buttons define the location of the spatial report data.

Real World Coordinates

When you select this option, the location for each report box is fixed in the coordinate space of the network. This means that a change of scale affects the position of each report on the screen, but not on the coordinate plane.

Display Offset from Attachment Point

When you select this option, the location for each report box is a given offset from the attachment point to the relevant object. The offset is independent of the scale of the displayed network.

These items can be used to modify the relative offsets of the Spatial Reports. To do this:

      1. Set the location to real-world coordinates then hit OK.
      2. Zoom in or zoom out your network view until the attachment lines are an acceptable length.
      3. Open the Spatial Reports dialog and set the location to display offset.
      4. Return to the network window and the Spatial Reports should be correctly displayed. If not then repeat this procedure.

Text Size

Display Size

With this option selected the text size is shown in a constant size (mm or inches) regardless of the scale selected. 

Real World Coordinates

When this option is selected the text will be shown relative to the scale of the drawing. As you zoom in the text will get larger.

Creation

When new nodes or links are created the location of the Spatial Reports is controlled using the options described below. 

Locate Interactively

When this option is on, the user defines the location of the Report Boxes interactively when the Nodes or Links are created. 

Use Default Offset

When this option is invoked, the reports are created in a default location, as opposed to you explicitly placing them. 

Hide on Creation

When you select this option, the Reports are hidden when a Link or Node object is created. Otherwise, the Reports are displayed as they are created.

Redrawing

These options control the speed of redrawing and the appearance of the spatial reports. 

Minimize Memory

When you select this option, reports occupy the minimum space in memory, thus allowing you to load a greater number of nodes. Selecting this option may significantly increase the time taken for redraws.

Maximize Speed

When you select this option, reports are drawn significantly faster than the Minimize Memory Option. The trade-off is that more memory is required and hence a smaller number of nodes can be handled.

Hide Inactive Fields

This field controls whether fields with no data will be displayed. If this flag is OFF fields without data will be displayed as blank lines within the report.

Hide Blank Reports

This flag controls whether reports with no data will be displayed, ie all the fields are blank. Objects with no data will then not display any Spatial Report. 

An object with no attached Spatial Report on the screen does not imply that there is no data there. Spatial Reports can also be hidden/shown from the “Display Reports” menu command, and may also be hidden if the “Hide on Creation” flag is enabled when the node/link is created. Thus, to confirm whether data exists, you need to “Show” Spatial reports for that node/link; if no Spatial Report appears, then you can safely assume no data exists.

Save 

This button saves the report settings to a user - specified file. All the global attributes excluding the flags on this dialog are saved.

Load Report

This button loads the report settings from a user-specified file. All the global attributes excluding the flags on this dialog are loaded.

Display Report

This list controls the hidden or show status of Spatial Reports, in much the same way as other layers are controlled.

To acces the list, highlight the Nodes or Links line in the Spatial Reports section of the Layer Control Panel.

 

The following options are available in the right-click popup menu: 

Show Spatial Reports as Tooltip. A report pops up when the mouse is moved over the node or link

Show Spatial Reports for all Objects

Show Spatial Reports for Selected Objects

Hide Spatial Reports

Note: to display the Spatial Reports, the visible box must be for nodes or links.

Graphical Encoding

Graphical Encoding, often also called thematic viewing or plotting, allows variables (or themes) to be displayed using graphical entities of objects. Currently three entities are supported for both links and nodes. These are; Colour, Size or Width, and Text Label Size. The variables (or themes) include all input data plus selected results of the SWMM analysis. Read more about the available options and parameters for this dialog in the Graphical Encoding options  page 


XP Tables

XP Tables allows the user to create a spreadsheet for data entry and manipulation in the model. The XP-Tables view is used to generate and manipulate data quickly and easily in the model. This format can be used to view results and create networks. The tool is launched from the main window by selecting the XP Tables tool from the Solve and Review Results toolstrip, selecting XP Tables from the Results menu, or pressing F2. A table similar to the one displayed here will appear.

The following options are available in the XP Table:

  • Field Statistics  - This button opens the Field Statistics dialog that displays the statistical values for an entire column or multiple cells selected from one column.
  • Block Edit  - This button allows you to edit all values for an entire column or multiple cells selected from one column.
  • Sort Ascending / Descending -  This button allows you to sort the values of the selected column in an ascending or descending order.
  • Show Network Objects  - This button allows you to display the network objects.
  • XP Tables List - This button allows you to display the list of options for the XP Table.
  • Setup Table Variables  - This button allows you to define the variables in the current table.
  • Table Diplay Options  - This button allows you to edit the display properties of the XP Table.
  • Export to GIS  - XP Tables can be exported to a *.shp file by using this icon on the XP Tables toolbar, which launches the Export to GIS dialog.

Field Statistics

The Field Statistics dialog displays the following statistical values for an entire column or multiple cells selected from one column:

  • Minimum Value
  • Maximum Value
  • Sum (Total) Value
  • Mean (Average) Value
  • Standard Deviation


Block Edit

The Block Edit dialog allows you to edit values for an entire column or multiple cells selected from one column. To edit:

  1. Select an entire column or hold the Ctrl key while selecting multiple cells from the same column.
  2. Click the Block Edit  icon.
  3. In the Operation field, select an operation from the drop-down list. The following operations are available:
    • Set Equal
    • Add
    • Subtract 
    • Multiply By 
    • Divide By
  4. In the Value field, enter the value for the operation.
  5. Click OK.
  6. Note: These edits are only saved to the working database once the Save icon is pressed before closing the xptable.


XP Tables Selection

This dialog is used to manage the tables in your project.

Object Selection 

This dropdown menu is used to define the selection set for the table. The options are:

      • All Objects in Model
      • All Objects in Current Network
      • Selected

The Explorer like (expandable/collapsible) panel displays the currently available tables grouped according to:

      • Global Database Tables
      • Global Tables
      • Node Tables
      • Link tables

View

Displays the currently selected table. Check boxes next to the table names indicate the other tables to be included in the workbook tabs.

Cancel

Closes the dialog and returns to the XP Tables window.

Up and Down arrows.

Used to restore the list of tables.

Add

Clicking this button launches the Add Table dialog, which is used to define a new table for display.

Note that a name must be entered for the new table. Clicking OK will close the dialog and launch the Variable Selection dialog.

Edit

Launches the  Variable Selection dialog. This is used to define the variables included in the table. 

Rename

Edits the name of the currently selected table.

Delete

Removes the currently selected table.

Import

Opens the Import dialog.

Setup Table Variables

Use this dialog to define the variables in the table.

Table Options

The Table Options dialog allows users to change the display options for XP tables. 

Import XP Tables

Use this dialog to import predefined tables from another XP project or a template. Many tables are shipped with the software, and are available in the Basic-Tables.xpx file in the Templates folder within the XPSWMM installation directory.