The following lists detail the various maintenance fixes made in this release, as well as the fixes made in the previous releases of the application.

Maintenance for 2019.1.2

  • WSPG Elliptical Diameter precision is preserved.

Maintenance for 2019.1.1

  • 2D Landuse fields now show correctly when exporting to XPX.
  • Unsupported elements are skipped when XP2D Extreme is selected.
  • When using the XP2D Extreme Engine, the 1D Continuity volume exchanged between the 2D was not being adequately counted for the 1D log at each 2D Sync time step resulting in the continuity error from being correctly calculated. The volume exchanged was correct; however, individual continuity error calculation incorrect, and reporting a higher than expected CE overall.
  • Editing in XPTables will now provide a better data validation experience when doing a block edit or a single row edit. A Log of Validation errors will now appear to show what value did not validate.
  • The Global Database settings in the XPTable now works correctly.
  • ARR Storm Generator now correctly reads the pre-burst rainfall regardless of BOM format changes.
  • Exporting to SWMM INP format would leave Horton Dry Time Infiltration column blank. This value is no longer skipped, allowing EPASWMM to read remaining columns correctly.
  • XPSWMM now supports the configuration parameter PUMP_CURVE_POINTS=x, where x is the desired number of data points beyond the default number of 30 points.
  • The graphing of an invalid date or time would prevent the application from properly viewing the chart. The application now defends against data corruption in the time series and will show the graph correctly.
  • The 2D simulation summary graph results now work as expected.
  • XPSWMM will no longer occasionally crash during the loading of results when invalid surface contouring is specified.
  • The application will establish the default simulation start and end Day, Month, and Year.
  • Adaptive time-stepping for the Classic engine is now disabled to prevent unexpected behaviors when running the model.
  • The discoverability the Rainfall Intensity column in the LA County Hydrology method is now fixed. Both the Runoff Coefficient and Intensity columns will be displayed in the dialog box.
  • A crash when reading certain data in FLT files would cause the application to crash. The crash will no longer occur.
  • 2D Results for Maximum and Minimum (Depth, Elevation, Velocity) values now correctly tracks the results.
  • XPViewer license issue where there was incomplete elements installed is now resolved.

Maintenance for 2019.1

  • An issue with the Dynamic Profile Hydrograph not changing with the selected Global Storm is now resolved. A change in the global storms will result in the changes in the hydrograph in the Dynamic Profile, as expected.
  • An issue when performing a save to a model with a large number of sewersheds would result in a long save time has been resolved. The file open process decreased the read time by about 25%.
  • An issue where the Global Rainfall would not set when using Generate Storms to create FEH/FSR rainfall has been resolved. A secondary step for viewing the Global Rainfall record is no longer required.
  • The enhanced 2D Advanced Control Settings now allows for Tuflow Attribute Position Control together with relative path settings.
  • WSPG Channel types errors no longer produce validation errors.
  • The export of LandXML now successfully overwrites an existing LandXML file.
  • An issue where a large number in the X column of a Natural Section Shape dialog box would prevent the left and/or right station value from being corrected. The issue was the field length of the X column and the Bank values were mismatched. To solve this, the Left and Right Overbank stations will now snap to the nearest X value with a bias in the direction of the Bank.
  • Importing LandXML channel sections into the application would import the incorrect value for the Maximum Depth value. This value is now correctly imported.
  • An issue where a large ASC file imported into the application would result in a crash when drawing contours is now resolved. The application will now also report the proper high and low elevation in the XPTIN, which prevents style values from being incorrect.
  • When a non-valid setting is added to the 2D Job Control, the application would allow the dialog box to close. This requires the user to reopen the dialog box. The application now remains on the dialog box with the invalid data to allow the user to make the edit.
  • An issue is addressed where the date and time values being set outside of normal values would not properly validate.
  • When negative Initial and Continuing Losses are imported, the application will warn users that the expected values are out of range.
  • An issue with the Floodway Definition dialog box not working has been addressed. It now works as expected.
  • The Find or Go To dialog box functionality has been restored to allow a user to find objects and utilize the Next button to step around a network. This now works as expected with Partial names as well.
  • An issue where renaming an object (link or pipe) with the same name as an existing element would result in a number of error messages has been resolved.
  • Validation is added to the ARR Storm Generator to prevent incorrect latitude and longitude from being sent to BOM or being processed by the application. Each data entry includes a tooltip providing the valid limits of BOM data.
  • An issue is now resolved where a bridge link that is incomplete could be created, which would cause the simulation to fail. This issue is no longer encountered and the user is directed to add the missing information.
  • An issue where the application would crash when using Gauge Flow button is now fixed.
  • An issue where an error message would be encountered when using the XP2D Extreme Engine, where two different grid layers would prevent a model run. This issue is no longer encountered, however, a warning will be reached indicating that multiple linked domains is not supported configuration, but the simulation will run regardless of the number of grid layers.
  • An issue was encountered where the model simulations might encounter a crash due to a memory leak. This issue has been addressed and multiple simulations will no longer fail to run.
  • A number of 1D Log Output tables have been adjusted to prevent numerical run-on where two columns would run together. This issue was done to reduce scientific notation in a couple of places.
  • Australian Rainfall Generator issues using the latest BOM website changes allow the Generator to properly acquire the data.
  • Global Storms now export the value associated global storm selected out to the GIS export.
  • An issue that caused the water surface elevation not to be in sync with the active scenario is now resolved. A change in the scenario will properly reload the correct set of results files as expected.
  • The opening of LandXML files from write-protected directories no longer cause the application to crash. The temporary files are written to the applications temporary file folder.
  • An issue with variable speed pumps on the same reach would automatically turn each other off unexpectedly. The issue is no longer encountered.
  • An issue with the EPASWMM5 Reader would incorrectly convert the reporting time step without converting the unit of time. This is now resolved.
  • An issue was resolved in the reading of large ASCII Text or ASC terrain data where a single elevation reported as zero in the statistics of image causing the color and contouring to appear incorrectly. This issue is no longer encountered.
  • Simulations will run when the path includes a comma.
  • The Interface Utilities now works as expected on Windows 10.
  • An issue with groundwater modeling where the selection of nodes affected the routed water quality concentration has been resolved. The selection of a node will no longer change the results of pollutant graph values and all catchments now correctly route the pollution concentrations via groundwater.
  • The entire bootstrapper installation will no longer fail if a prerequisite fails during installation.
  • An issue where the 1D hydraulic start time was set at a non-zero hour value resulting in the 2D Simulation results that do not appear correct has been resolved. The workaround to utilize a zero hour start time is no longer necessary. The use of a start time with a non-zero hour value works as expected.
  • The application no longer allows Advanced User Settings that modify the XP2D calculations to include pre-2012 settings with the XP2D Extreme engine. These configurations are untested and had resulted in unexpected engine results, including application and engine crashes. A warning would occur when attempting to use these options.
  • An issue when changing the order of the Hazard Classification schemes would result in an improper argument has been resolved. The error is no longer encountered.
  • An issue where viewing results of an unsolved model would result in the application crashing is now resolved. This issue is no longer encountered.
  • Reserved Characters that cause issues with file names, global storms, scenarios, and multi-links no longer crashes the application. Users should get warnings when those situations might occur and get prompted to make the necessary changes to the model.
  • A new version of XPDIAGNOSTIC is now available.
  • The application no longer fails to provide 2D results in a consecutive solve situation where either Scenarios or Global Storms are involved. Results using Solve Manager were not impacted. Solve now will correctly provide 2D results for any consecutive simulation.
  • The software checks for non alpha numeric characters before solving since the analysis engine cannot manage these characters. For example #, ! and multi byte characters for Chinese, Korean, and Japanese cannot be used in file names, scenario names, and global storm names.
  • An issue with Green Ampt Infiltration and the Snyder Unit Hydrograph that used to return no results now returns the proper runoff.
  • An issue where Unit Hydrograph Runoff Method in Child Scenarios would not allow the input variables to be preserved has been fixed. The Unit Hydrograph input values can be changed in Child Scenarios and the simulation will occur without issue. However, the method is not allowed to be changed for a single node between the parent to child.
  • In certain cases, the use of invalid characters in Scenarios and Global Storms would prevent the application from completing simulations, which include invalid characters that would break the simulation engine. Error messages will now occur if invalid characters are used in Scenarios, File Name, or in Global Storms.
  • In leveraging Advanced 2D settings file path settings, regression is introduced where the value column in the 3rd row and beyond, that setting was forgotten and not saved. This issue has now been resolved. This effected 2018.2.1 and 2018.2.2 models with more than three rows of Advanced User Settings in the 2D Job Control.
  • The application no longer improperly reports the summation of Inflow from the 2D Layer for 1D/2D Interface connections when US Customary unit models.
  • XPTIN Gray Scale and Quantification values now persist as expected.
  • Microdrainage Manholes now correctly import with the correct diameter.
  • The application no longer crashes when showing a profile that contains a bridge.
  • The ARR Storm Generator now correctly interfaces with the ARR BOM due to changes to the BOM website.
  • An issue where special forcemain loss values resulted in incorrect headlosses has been fixed.
  • With the release of the XP2D Extreme Engine, a number of Advanced 2D Configuration Parameters that target prior 2D Configurations [e.g. Pre 2012] no longer are advised as they will encounter engine errors.
  • The Context sensitive right-click > Delete Link will now delete all selected links, rather than only the first link selected.
  • HEC-RAS Culvert imports correct model geometry. An issue where data was unable to be edited no longer occurs.
  • Clearing the Create Shortcut during the installation now properly does not create the shortcut.
  • Invalid characters in the filenames or file paths that cause issues with the simulation engine are prevented at model save. The invalid characters added are !, # added to the list of Windows reserved characters: < (less than), > (greater than), : (colon), / (forward slash), \ (backslash); | (vertical bar or pipe), ? (question mark), (double quote), and * (asterisk).

Maintenance for 2018.2

  • An issue in the Wallingford Procedure runoff equation was resolved regarding incompatible unit conversions when determining the storage volume in the non-linear reservoir routing.
  • An issue where double-clicking on a link resulted in a rename action rather than a dialog box open has been resolved.
  • 2D Job Control Advanced Setting character limit now allows 80 characters
  • The file extension is automatically added when exporting to xpx format.
  • An issue with misplaced XPTABLE fields for groundwater variables was resolved so that they appear correctly in reports for the Groundwater Global Databases.
  • A progress bar provides the status of the 1D Results loading, including the ability to cancel large 1D Results sets.
  • The object selection drop-down width in XPTABLES with has been increased for usability.
  • The application properly handles an attempt to exceed the licenses node/link limits without closing the application.
  • Inlet Edge Design dialog width is increased to identify the inlet edge condition.
  • Closing the current model now consistently closes the canvas.
  • Usability of Scenario selection in Review Results now provides clearer options.
  • An issue regarding two missing Projecting Arch Corrugated Metal Culvert Inlet Edges was resolved.
  • The Help Check for Updates now correctly resolves to the new website.
  • The rebranding of the application to Innovyze.
  • River Links now successfully import and export using the XPX Exchange format.
  • The application now uses Visual Studio 2017 compiler which might reflect slightly different numerical results.
  • Box and Whisker plots will include all results including those with zero values. Null results or unrun storms will not appear in the Box Plot.
  • The export/import precision of groundwater values via XPX properly preserves the needed precision.
  • The software is now updated to use the Sentinel Protection System 7.6.9.
  • Storage Optimization option to Limit Downstream Discharge and other settings for Design properly provide proper warnings and errors.
  • Tooltips have been added to the User Inflow dialog.
  • A spelling issue in error logs has been resolved.
  • Custom Variables in XPTABLES no longer cause the application to crash.
  • A save progress bar now prevents premature application closure while the database is saved.
  • An issue with where the result is not found in the Find dialog no longer returns an invalid message.
  • Various spelling errors were corrected which appears in dialog and warning messages.
  • When leveraging the Solve Manager, a warning is now displayed to when a user closes the Engine Viewer altering them to the shutting down of the Solve Manager.
  • The naming of objects during creation no longer collides with existing objects.
  • Export to file formats will auto-populate the File Extension type.
  • An issue with unchecked results being loaded during Reload 1D results is no longer encountered.
  • The Inlet Control icon in Review Results for displaying Inlet Capacity is disabled unless a node with Inlet Capacity is included in the object selection before launching this graphing tool.
  • An issue in the Profile Plot output where the XPWSPG Resulting Hydraulic Grade Line would fall to the downstream invert has been resolved.
  • XPTABLE variable formatting changes are properly previewed.
  • An issue with the Progress Monitor not responding when cancel is selected no longer occurs.
  • Copy from Split Catchment checkbox now works as expected.
  • The pavement cross fall dialog box tabs work correctly.
  • Creating a 1D Flood Map while attempting to close the application no longer causes premature exit.
  • Removing elements using the Delete button in the File Properties and Options default settings now properly removes entries.
  • Updated and sharper icons used for Review Results. Inlet Capacity icon is now a grate with a drop of water.
  • The Inlet Control icon in Review Results for displaying Inlet Capacity is disabled unless a node with Inlet Capacity is included in the object selection before launching this graphing tool.
  • An error message displays when a 1D/2D Flow Interface SX line connects to a 1D Node connected with an Open Channel element by suggesting a better modeling practice.
  • Clarified use of Read Elevation from Attribute Data for break lines.
  • An issue where a custom variable may not appear to validate was resolved. The Preview of the custom variable expression now evaluates.
  • Quick Data View now properly shows appropriate XPTABLE headers.
  • The Load 1D results dialog now only shows the filename, scenario name, and storm name. There is no longer a long path which was truncated, and the important unique identifiers were not shown.
  • All pathways of name change for objects (links, nodes) will verify if the name is in use and prevent acceptance of the new name unless it is unique. Previously changing the name in the node properties did not verify uniqueness which was then found as an error when solving.
  • The Node dialog has become "modal" to prevent issues when performing other functions while the dialog has been left open. This means that node and link dialogs cannot be opened together. However, the Conduit Profile dialog allows link and connecting node elevation data to be edited together.
  • The tabs for Review Results have the redundant term "Review Results" removed from the tab title.
  • When deleting and creating a new rainfall record from the 2D Rainfall/Flow Areas the new rainfall record will be started with default data rather than previous data. To use previous data, choose the Duplicate option for the rainfall record.
  • Pressing the Retry button while managing open file conflicts no longer results in program termination. If the file is closed in the other instance of XP and then the Retry button is used the file will be loaded. As always proceeding with OK will allow the file to be opened but it cannot be saved to the same name as the original.
  • Result values can now be seen independently in XP Tables and Quick Data View for structures in multi-links where multiple structures are turned on in the same conduit line (1-7).
  • An issue with hydrographs not appearing properly in the Dynamic Section View is resolved.
  • The 'No' button now functions as expected in the ARR Storm Generator and does not append to existing storms. Before the fix, the button functions the same as 'Add to Existing'. It now cancels the operation.
  • Some defensive code has been added to the Solve Manager if the timing has been interrupted during the communication with the User Interface.
  • The Section Profile tool now only allows points to be selected within the DTM. Attempting to select points outside the DTM will generate a message "Invalid point location, please place inside DTM area."
  • When duplicating rainfall records from the 2D Rainfall/Flow Areas the complete contents of the rainfall record are properly duplicated including date and rainfall data. Previously some default data was duplicated in older versions.
  • The software can now successfully save a Template to a nonexistent folder as opposed to a fatal exception. It now creates the destination folder and file.
  • When creating a new model from a template the software will no longer generate a false message regarding a missing JSON file of rainfall data.
  • An error was resolved regarding Tipping Bucket rainfall that prevented a simulation from solving completely.
  • Custom Header variables in XPTABLES now export and imports properly via XPX.
  • An issue where a copy-paste workflow from a multilink to single link reported a missing dialog box and past failure was resolved. The dialog box and paste are now successful.
  • When exporting a Bridge Link, the property value of 142 is used to preserve the link type. Exporting and Importing a Bridge through LandXML now keeps the link shape, but no Bridge Data is preserved.

Maintenance for 2018.1 

  • The Cancel button is now working as expected for 2D result Recording. When attempting to record the 2D Results animation, you can now cancel and when the filename is blank, the recording will not start.
  • The Copy icon has been disabled on the Dual Drainage Batch Converter as it is not applicable in this dialog. Copy is for objects and not for unique command dialogs.
  • The Base Scenario state (on or off) is now saved and when the model is reopened its active/inactive property is correctly reflected from the last model save. In previous versions, this Base Scenario was always returned to active.
  • When exporting the sewer network and DTM to LandXML, the software will now stamp the version of the software that created the export.
  • When the results of Multiple Conduits are shown in the Dynamic Long Section and dynamic section views we now place the results in order using a / to separate the values. Previous versions placed the text on top of each other.
  • The External Data Import/Export dialog showed only a truncated file and path. This dialog has been upgraded to have a scroll bar so that long file and path names can be visible.
  • The printing of the Scenario Manager Report has been improved by using a smaller font.
  • The ability to search for text has been removed from the Find dialog as it has never been implemented in the program.
  • The X in the upper right hand corner of message dialogs has been disabled when appropriate, as there is typically a Cancel or No button within the dialog to answer in the contrary to the message.
  • The Save As Template dialog has been modified with improved text, expanded text field to show more name and path as well as a more precise confirmation message.
  • An issue has been fixed where in unrelated data was updated in xptables and riverlinks were also in the xptables the node inverts would be reset to zero.
  • The tab order for the Hydraulics Job Control Time Control is now similar to Runoff and Sanitary mode. It will now move the cursor from left to right when pressing the tab key, meaning from year to seconds then start to end rows.
  • The Maximum Database Cards set in the SWMXP.INI file has been increased to 4000000 to reduce the likelihood of filling the static database to capacity when using a lot of Global Storms. This can be manually adjusted as well by editing the SWMXP.INI file or using the Tools> Application Settings > Config > MaxDBCards.
  • New rainfall records will start with default date of January 1 of the current year at midnight. Date and time, as always, can be edited for each record.
  • When exporting to XPX, the first conduit name of multilinks was not being exported in version 2017.1 and 2017.2. This is fixed now in 2018.1 and later versions.
  • The Calibrate menu item found in Tools is now disabled when the option is not present in the license. Note: this module is no longer available and has not been available for many version.
  • In version 2017.2, some fields were not displaying when the field info button was used in the dialogs. This is now fixed for version 2018.1 and later.
  • The ARR2016 Storm Generator button is now removed from the Global Storms dialog for non-English versions.
  • The tool tips for the Scenario Manager and Global Storm drop-down selection have been updated.
  • Multiple conduits will no longer populate conduit names with defaults, such as Pipe then Pipe.1, Pipe.2 etc. Conduit names will now remain blank unless filled in by the user.
  • Some specific models had issues when copying an object and then pasting to create a duplicate object. This has been fixed by managing internal pointers.
  • An issue of showing Evacuation Routes when Use Project Units is unchecked has been resolved.
  • In some cases, there are security issues usually with group policy that prevents a core part of the installation to modify the firewall for the Solve Manager. Version 2018.1 allows the installer to continue and not fail. The firewall will need to be updated in these cases for the Solve Manager to function. Normal Solve is not affected.
  • There was an issue with Rainfall Records that were generated with the Storm Generator in the Global Database. Those storms were not being passed to the .json file and hence showed storms without the time series. This is now fixed for 2017.2.1 and later.
  • Version 2017.2 failed to save changes to the Scenario Manager for 2D Layer Active flag. This meant that edits for layers or new Scenario changes were lost once the model was reopened. This is now fixed with the 2017.2.1 update.
  • Some code in the Scenario Manager was limited to 30 character names. This has been increased to prevent any overflow that could result in abnormal software behavior.
  • A more complete Scenario Description is now included in the Scenario report for making 2D Layers inactive.
  • Added ARR Storm Generator support for locations without preburst data.
  • All possible methods of naming link and node objects now allow 80 characters as a maximum string length. Some methods were previously restricted to 79.
  • In some cases, using a rainfall interface file was not allowing the analysis engine to recognize that the rainfall to use was the binary time series. The internal flag is now persistent and there are no more issues using the rainfall interface file option.
  • Some cosmetic changes were made to the Subcatchment dialog as a few resources were clipped by text fields.
  • The tooltips for node names in the conduit profile have been restored. They were missing in the 2017.2 version.
  • The Bridge Low Chord elevation and hydraulic opening calculations are now correctly calculating the bridge components when certain Hydraulic Opening conditions are met.
  • ARR16 Storm Generator now correctly aligns temporal patterns with AEP for certain Exceedances.
  • An issue with ARR16 Storm Generator with Preburst rainfall containing certain values is addressed.
  • An issue has been fixed where the Region and Language settings for decimal symbol interfered with the application on open.
  • Some text strings were missing for instance and index in the Graphical Encoding. These place holders have been updated with the correct strings.
  • The plan view is now refreshed when any 2D Layer is disabled. Previously, the screen would have needed a manual refresh for the new state of the layers to be seen.
  • The software now requires a value greater than zero for active subcatchment area, width and slope. This is now consistent if the data dialog is accessed from the node or the subcatchment with double-click.
  • If the low chord is above the highest point of the bridge opening creating a gap as they do not intersect, then a new vertex aligned to the first and/or last vertex's x coordinate with the low chord height as their respective y coordinate is now internally added.
  • ARR Storm Generator is now suppressed in the software for Chinese, Korean and Japanese versions. This is appropriate since it is for Australian rainfall generation.
  • With the inclusion of a JSON database for rainfall values, an issue allowing the storms to be duplicated was not populating the new rainfall record with the existing data. This has been fixed and appropriate data is now present in the duplicated record.
  • The SWMM5 export now exports coordinates without scientific notation. This change is important as some other programs have had difficulty interpreting the number when importing the XP exported file.

Maintenance for 2017.2.1

  • This release fixes an issue with Rainfall Records that are generated with the Storm Generator in the Global Database. These storms were not being passed to the .json file and hence showed storms without the time series.
  • License files for libraries used by the storm generator are now included in the install for 2017.2.1 and later as they were missing in the previous version.
  • The user is allowed in conjunction with ARR 2016 to enter the number of pre-burst timesteps (let's call this N) that would represent the anticedent / pre-burst rainfall. Then when the storms are imported and generated the median pre-burst rainfall depths from the ARR datahub text file, the program places N increments of value pre-burst ratio for that AEP and Duration divided by N' before the main temporal pattern. This version fixes an issue where the pre-burst values did not carry enough precision.
  • Version 2017.2 failed to save changes to the Scenario Manager for 2D Layer Active flag. This meant that edits for layers or new Scenario changes were lost once the model was reopened. This is now fixed with the 2017.2.1 update.
  • Added ARR storm generator support for locations without pre-burst data.
  • In some cases, there are security issues usually with group policy that prevents a core part of the installation to modify the firewall for the Solve Manager. This new release will allow the installer to continue and not fail. The firewall will need to be updated in these cases for the Solve Manager to function. Normal Solve is not affected.

Maintenance for 2017.2

  • Catchment connections are now preserved after a File > Merge command. In previous previsions, the catchment connections were lost (reset) in the Merge process.
  • The four Configuration Parameters that were on by default for many versions through the SWMXP.INI file are now hardwired to on in the analysis engine. These are: SCSIADEPTH=ON: SUBCATCHMENT_RES=ON and PUMP_NEGHD=ON. Values of OFF in the configuration parameters dialog can effectively remove these defaults.
  • A few additional write strings in the model output file were using internal ID as opposed to the object name when the object name is less that 21 characters. This has been fixed and object names up to 20 characters are now being used in the model output file.
  • When the user selects the Generate button on the ARR Storm Generator, a copy of the: Data hub text file, Temporal patterns, and IFD is saved along with the generated .xpx file of storms with a timestamp all contained in an archived zip file.
  • When using the ARR features files are created using the object names. Since the following are prevented by the OS \/:*?""|<> for file names these are converted to html equivalents such as / to %2f.
  • In cases where the old TIN format tin name was very long a crash could occur when presenting the warning message to the user about the conversion. This is now resolved and the warning message no longer causes an overflow.
  • An issue migrating older models with groundwater redirection has been fixed. In version 2016 to 2017.1.1, some groundwater redirection could not be set or changed. This is now fixed moving forward from 2017.2.
  • Some bridge geometry were missing the low cord in the wetted perimeter calculation. This has been fixed for 2017.1.
  • The units for catchment total surface runoff have been updated to ft^3 and m^3, which are appropriate for the result when displaying in xptables.
  • The Rainfall Record dialog now shows the dialog title with the record name.
  • The 2D Job Control setting for the initial water surface elevation is now found in the .tgc file. It had been located in the .tcf file recently but historically in the tgc file. So it is now back where it belongs.
  • Significant code refactoring was performed for Quick Data View so that it redraws with speed and can be docked/undocked and always shows the correct and current information. A few memory leaks were also detected and repaired as well as some cosmetic issues.
  • The quality of graphed water results is dependent on the number of points in the Section Profile view. In this new version, a minimum of 10 points is created if the user creates less then 10 points while digitizing the line.
  • An issue involving long names of objects when splitting a conduit is now resolved. Conduits can now be split successfully with names up to 80 characters.
  • An issue with the 64 bit engine and conduits without shapes has been resolved by converting the warnings of no shape to errors and forcing all conduits to have shapes before the model can be solved.
  • The warning messages for the Inlet Capacity > Efficiency Factor have been rationalized to warning if the value is below 0.1 and an error if it is not greater than 0.
  • The 2D Only Mode button in 2D Model Settings has consistent behavior when being turned on and off.
  • The catchment polygon vertices are now prevented from inadvertent edits when the catchment is not visible and not a locked layer.
  • The Layer Control menu item to toggle on/off the panel is now located under the View menu and has a keyboard equivalent of Shift-L.
  • Data persistence has been restored for the Multilink Special > Other Factors.
  • Multiple nested surfaces are now properly exported to LandXML. In previous versions the closing /Surfaces xml command was not placed with each exported surface.
  • Pipe diameter conversions are now managed when importing from LandXML. For example, 18 inches in the LandXML is now imported to the target units of feet as 1.5 ft.
  • The Copy icon for dialog items is now suppressed in the Natural Section Shape dialog as it is not applicable there to copy and paste between objects. That data is Global data and hence cannot be copied and pasted that way.
  • A spelling error in the simultaneous warning message has been fixed.
  • Node names are now written to the output file as opposed to internal ID for scenario and Global Storm runs. This is true as long as the object names remain under 20 characters
  • An issue introduced in 2016 regarding the Flow Details printout to the output file for conduits in multilinks has been resolved. Now all conduits whether in multilinks or single links can create detailed printout.
  • File > Page Setup no longer has issues in the Chinese version.
  • Error messages are now displayed for the case of pipe diameters exceeding the height of a node in the Japanese version when performing a Pipe Design run.

Maintenance for 2017.1

  • Laurenson method has been modified to take into account values of n other than the default of -0.285 as expected.
  • Special Characters are prevented from being used in Global Storm and Scenario names. These names are appended as result file names and therefore characters such as /,|,:,*,?,",<,>, and | as well as a comma are prevented from being used as Global Storm and Scenario names.
  • The DTM color graduation legend now will graduate or have sharp color transitions to follow the plan view display. The numerical values also better align.
  • The UK hydrology data can now be copied and pasted from one node to other nodes.
  • The smoothing at the edge of 2D Maps has been made consistent across the depth and elevation maps.
  • An issue where when zooming and panning filled 2D arrows would become unfilled has been fixed.
  • Both polylines and polygons in Dynamic Elevation Shapes and Elevation Shapes can now be deleted by right-click and choosing Delete Selected Polygon/Polyline.
  • The Hydraulics mode pump dialog has been updated to specifically label depth and elevation fields and hide fields if the pump type did not require the data.
  • A special case of restricting the display with a value starting with a zero such as 0.50 was causing an issue. This has been fixed and 0.05 and .05 etc. are valid inputs.
  • The Horton infiltration has been added for 2D overland flow. Together with the existing Green Ampt and the Initial and Continuing Losses there are now 3 options to infiltrate water in to the 2D cells from water flowing on the cells and as rainfall hits the cells.
  • Hydraulics Node User Inflow dialog has been updated to a grid when pollutants are added so that it facilitates and easy copy and paste from other applications like Excel for the hydrograph and pollutograph.
  • The max velocity which is not computed for a weir is now suppressed as a subtitle in the Review Results graphs for weirs.
  • The dialog text for DTM has been updated to be less confusing when introducing DTM, XPTIN and Grid files.
  • The Snap feature is now on by default when creating a new model.
  • The 2D Landuse Dialog was arranged to require less height and be useful at low resolution 768 vertical.
  • Node and Link labels are no longer selectable when visibility is off in the layer control panel.
  • The grid for the network view has been improved to allow line thickness and automatic square grid option. The dialog has generally been cleaned up and improved for the user experience.
  • When exporting the model to XPX a rainfall referenced file had additional backslashes. This has been fixed and no longer happens.
  • An issue that prevented some 2D model results display for Global Storms with spaces in the name has been resolved. Model runs with spaces in the name are no longer an issue.
  • Text objects are no properly ordered so that deleting some did not delete the wrong items as evidenced by reopening a model after some text was deleted.
  • Some of the close file alerts dialogs have been updated to be consistent with newer dialog formatting. This was purely a cosmetic change.
  • Step 5 in the Import/Export Wizard correctly suppresses Optional data for Node and Link but exposes the option when needed i.e. Multilink.
  • A small cosmetic change has been made to the Depth Varying Roughness button height in the Natural Channel dialog.
  • Depth Varying Roughness is no longer allowed to be left active and blank as this previously created a run failure.
  • Optimization of loading XMDF results has reduced the load time of results in some cases a 5 fold increase in speed has been obtained.
  • An issue that prevented Multilink conduits to plot and printout tabular hydrographs has been fixed. This issue was introduced in version 2016 and now fixed in 2016.2.
  • When creating a new fill area the default is now 9999 for both metric and US Customary units.
  • The help was updated to explain that the depth varying roughness is a step function and not a linear interpolation like the graph might suggest. See the help for a more complete explanation.
  • FLT files are now supported in addition to ASC Grid files previously. All the locations where ASC files could be referenced or imported now allow FLT or their binary equivalent to be used.
  • It was possible when creating Global Database records like Rainfall to make them longer than 20 characters when they are created from the Select dialog. This could cause an issue since the maximum record length is 20. This has now been prevented in a similar way that it is prevented in the Global Database dialog.
  • The persistence of CAD layer visibility has been implemented. This means that the layers made visible and invisible in XP for the attached CAD files are now saved and recalled when a file is opened.
  • An issue when displaying Velocity angle for Head/Velocity points being multiplied by the US/Metric conversion has been fixed.
  • The Snyder Time to Peak Calculator has been updated so that it returns the correct Time to Peak to the Unit Hydrograph dialog in both the US and Metric Units.
  • An issue where the precision was lost with very large Save Results values for the review Results has been fixed. In previous versions the interval was not exact and large values greater than 3 minutes would actually be a bit less than 3 minutes.
  • The Calculate Node Catchment Areas dialog has been made wider to reduce the requirement to make it wider to see the new and old areas.
  • An issue when exporting profile plots to DXF files has been fixed. In some previous versions the software failed due to an array out of bounds.
  • An abrupt step behavior has been observed in some Green Ampt models when the rainfall rate was very close to the Hydraulic Conductivity. We have rework the routine so that this does not occur and the cumulative Infiltration is not falsely reset. Similar issues were reported in SWMM5 and fixed in 2016.
  • A recently introduced issue in 2016 and 2016.1 involving the reading of interface files produced by xprafts has been resolved. This means that version prior and after 2016 versions can successfully read interface files from xprafts.
  • Issues with Ariel font have been fixed for the Korean version
  • When using Project Units in 2D to allow native calculations in US Customary units the software was previously converting the value of wet/dry depth and not directly assuming the input was in feet. This is now corrected and the value is no longer converted and the input is ft or m depending on the unit choice and the Use Project Units check box.
  • An issue when merging models with Natural Channels has been fixed in that it no longer falsely removes some cross sections.
  • A drawing issue has been resolved for Bridge Cross Sections in the Dynamic Section Views. Previously these items would automatically fill to zero before they started to fill hydraulically.
  • A small issue in that a newly loaded image was not allowed to have new coordinates has been fixed. In 2016.1 the image must first be loaded before updating the coordinates, but now new coordinates can be entered when the file is opened.
  • An introduced problem in 2016 version would drop the destination node or link name in the Runoff Node->Sub-Catchment dialog. This is now fixed and new and older models no show the target node or link for the groundwater outflows.
  • Fixed an introduced issue regarding strings in File->Properties that could crash the application.
  • Most program strings are now moved to an XML file for easy translation and on the fly program language swapping.
  • The binary results file has its header updated to version 27 and data file format 12.62 for 2016.2 version.
  • A few help buttons were not launching the correct help screen or were inactive and have been fixed including the button in the Application Settings dialog.
  • The conduit profile changes for the node ground elevation and invert are now saved in the scenario manger. Previous version were not treating the edits of node data in the link dialog correctly.
  • A software crash caused by display of the Quick Data View and then navigate to another scenario (to or from the Base Scenario)has been fixed.
  • Updates to Recent OS have deprecated a previous C++ function for date handling which caused some Gauged Data to not display in Review results for the full time period.  This has been fixed in 2016.2.
  • The WSPG engine has been updated and compiled using Visual Studio 2015 Update 3. No simulation differences are expected.
  • A possible crash when using Graphical Encoding on variables that have no numeric range such as the node name has been fixed. A reasonable workaround was also possible to choose a parameter that has a range such as node area.
  • The EPA SWMM Reader has been updated to allow for Circular Filled conduits and box culverts. Some other conduit shapes not yet supported generate a warning and the conduit is imported as circular.  In addition, the software continues to have a restriction that object names with an asterix (*) will cause import issues. They must be manually changed before using the current importer.
  • Some warning messages for Bridge links have been upgraded to error messages as they were errors for the analysis engine. This prevents the situation that the engine would report the errors and that the interface would allow the model that could not solve to get that far in the process.
  • The HDR->Evaporation dialog now accepts decimal numbers and is no longer restricted to integers
  • An issue with US Customary units and 2D Flow areas not using the correct flow units has been fixed. Previously these flows were being falsely interpreted as metric values.
  • The first major release will now be named year.1 so this release is named 2017.1
  • For backwards compatibility the 2D models automatically write Defaults==PRE2016 to the TCF file.
  • The software now has a larger default for database size. It is now defaulted to 2000000 Database Cards which does use a larger memory allocation but will reduce the number of issues of the default being too small. The setting of the MaxDBCards is controlled in the SWMXP.INI file.
  • Correct translation for the Japanese version has been added to the 2D Results Utility and a few other dialogs.
  • A Windows10 issue with the tree control getting reordered for XPTABLES has been fixed. The order and indentation is no longer being altered inadvertently.
  • The help jump location has been updated to land at the correct location for Runoff Job Control.
  • An issue that prevented some models to not fully display in the Dynamic Plan View has now been addressed by proper initialization. Previously the model needed to be saved and reopened. That is no longer required.
  • The X and Y axis labels have been rewritten for rainfall as the units were previously shown with double parenthesis such as ((hours)) and now show (hours).
  • The curb (kerb) Manning's n range has been updated so that warning are generated outside of the range of 0.005 to 0.5.
  • The Sanitary Job Control in the Korean version had bad button graphics which has been fixed for the 2017.1 version and later.