Projects are composed of files that are grouped together. The files are not interdependent in any way. An XP file can be included in different project groups.

The Project Menu will only be active if the parameter PROJECTS=ON is present in the SWMXP.INI file.

When in Project mode, the opening of files is restricted to project files only. Files can be added to and deleted from a project when the project is edited. On creating a new XP file or saving an existing file under another name it is automatically added to the project.

Multi-runs can be set up to solve a selection (or all) files in the project. If a current file is open it will be closed first. The selected files will then be loaded and the data checked for errors. If there are errors in the data then that data set will not be solved. After a multi-run has completed the last XP file to be processed by the multi-run is loaded. The results from the run are loaded for this file only. The results for the other XP files that were part of the multi-run are not updated to the XP file straight after a multi-run. The next time the file is opened the results from the multi-run are loaded.

Project files can also be loaded from the command line (when project mode is on).

If project management is enabled, the Open command under the File Menu will only list the files contained in the current project as shown in the following dialog. This dialog can also be accessed from the Project > Edit menu on the menu bar. 

Project menu commands

The following describes the available Project menu commands.

  1. New. This menu command is used to create a new project database. Upon selecting this command a dialog box requesting the name of the new database appears. If the name of an existing project is entered, confirmation to overwrite it is requested and, if granted, the existing project is destroyed.  
    The program then proceeds to enable and disable appropriate menu commands. Only one project can be active at any one time. Although not mandatory it is good practice to give the new file a .XPP extension. This makes retrieval of the file more straightforward when using the "Open" command.
     
  2. Open. This command is used to open an existing project database and make it active. When this option is selected the Get File dialog box below will be shown with a default mask "*.xpp". To select a project, double-click on the name or type the complete name instead of the mask. If the file selected was not created by XP, the results may be unpredictable.


  3. Edit. Use this command to add, delete or modify the files associated with the project. There are no limitations on the make-up of the project files. They can have any network configuration and can be located in any directory. Below are the available commands within the Edit dialog.

    1. File Description. Enter a one-line description relating to the highlighted file. 

    2. Add. Select this button to show a list of XP files that may be added to the project. You can navigate your way through directories using the normal file selection process.

    3. Delete. Select this button to delete the currently highlighted file. 

    4. DetailsThe Description, Client, Officer and Modeler are alphanumeric strings used to describe the project. "Date Created" and "Last Modified" are set by the program and cannot be modified by the user.


  4. Close. Choose this option if you are finished with this project database and want to open another existing project or create a new one. If no changes have been made to the current project, it will be closed immediately, otherwise a "Save Project?" prompt will appear, allowing you the option of closing without saving changes, or cancelling the "Close" operation. 
     

  5. Save. XP maintains an internal working copy of the project database for editing sessions. Changes made while editing are not committed to the permanent database unless explicitly instructed by using the Save command. The Save command commits all changes made to the working database to the permanent database.

  6. Save As. Copies of the working database (see Save command) can be saved under different names by issuing this command. A dialog box prompts for the new database name; the copy is then made and the new name becomes the current database. The "Save As" and "Save" commands provide flexible control over the timing and permanence of data changes.

  7.  Multi-Run. The Multi-run command allows users to solve any (or all) of the files in the project in a single batch run. A highlighted file may be tagged or untagged by clicking on the file name.  When Run is selected each tagged (highlighted) file is opened and solved (ie., the data file generated) in the sequence shown in the Project files list. If an error is encountered in generating the .DAT file the Multi-run is terminated and an error log describing the problem is created. If no errors are found the SWMM engine begins execution and each of the files is solved.

  8.  Multi Review. Allow users to Review Results of any of the Multi-Run results.