The following list provides the features and improvements in the previous versions of the application.

Features and Improvements for 2018.2

New 2D Simulation Options

  • Introducing the new xp2D Extreme engine! This new engine provides multi-threaded CPU simulations – and 1D-2D GPU accelerated simulations.

Model Build

  • NEWLandXML import speed improvements for importing LandXML Data, including surfaces up to 2 million points and large pipe networks, occur with vastly improved processing time. The model imports allow the user to build a model and preserve the TIN triangulation within XPS.
  • NEW: Land Use polygons can now be referenced in 2D Advanced Settings.
  • NEWPostgreSQL database connections are now fully supported.
  • NEW: The new EPASWMM Reader is available to process EPASWMM5 conversion to XPX format that is faster, more robust, and with improved ability to handle larger SWMM5 model sizes.
  • NEW: AutoCAD 2018 file format is now supported.
  • ENHANCED: Default Label Locations for links are revised to improve usability.
  • ENHANCED: The default for 12da surface files are now "full tin" meaning the nulled triangles are included. XP has been updated to accept both old and new formats.

Productivity

  • NEW: The file association of XP model files is now associated with the installation of 2018.2. Windows now recognizes the associated file extension of XP correctly. XPSWMM File Extension now registers correctly allowing a double-click on the file name to open the latest version.
  • NEWEnsemble Statistics for Multilinks are now available.
  • NEWHead/Velocity points and Flow lines for Time Series Outputs now include the ability to select between default naming or naming from a GIS field when importing these elements from GIS.
  • ENHANCEDProfile Plot now includes the multilink.
  • ENHANCED: The Catchment Splitting tool refinement now provides ‘overwrite existing data warnings” when multiple nodes are updated.


  • ENHANCED. The legacy Use Project Units option in the 2D Engine is no longer available. The 2D simulation option will always perform the 2D calculations using the project units. This prevents unnecessary translation between imperial and metric during the simulation on load. This change impacts check files and output files from the 2D engine.
  • ENHANCED: The Review Results toolbars icon are updated for clarity.
  • ENHANCED: Exporting Link Data to GIS now includes upstream and downstream freeboard.
  • NEWBridge High Chord now is now shown on the Bridge Hydraulic Opening dialog box.
  • ENHANCEDGlobal Storms now includes an All Storms checkbox that will globally toggle all Global Storms on or off.


  • ENHANCED: XPX export and import of active Global Storms and Global Storm Ensemble names is now added.
  • ENHANCED: The Global Storms can be exported and imported using XPX. The key command is GLOBAL_STORM. A sample syntax is provided here: GLOBAL_STORM 35 1 "1Q-25-10P-6Hr" "" "25Yr" "AT14-V2-1Q-10P-6Hr" 1 3.470.
  • ENHANCED: Tool tips have been added for the remaining Review Results icons in the toolbar.


  • NEW: Gauged Inflow Filename, File Format, and Station can now be added and edited in XPTABLES. This allows a simple copy and paste in XPTABLES to update the user inflows which can be beneficial when there are many inflows of this type to update.
  • ENHANCED: When a series of runs have been performed using the Solve Manager all the 2D results are loaded and available. In older versions it was necessary to use the option to Reload 2D Results after a Solve Manager simulation.
  • ENHANCED: At the completion of a Simulation using the Solve Manager the software now opens the Reload 1D Results dialog. This improvement semi-automates the results getting to the database by prompting the user to invoke the option to load or cancel the load process.


  • NEW: The user can now split a conduit at the location of the cursor. Right-click on the selected link and choose Split Conduit on Click and then select the split location by clicking on the link. The ground and invert levels are automatically interpolated to yield the same slope and other conduit properties are also duplicated.
  • ENHANCED: The selection and conversion of links to a different link type now allow multiple selections for the conversion between link types.
  • ENHANCED: After using the Block Edit in XPTABLES it is no longer necessary to press the Save Icon to commit those edits. They are now persistent by default.
  • NEW: The User Defined Inflows can now be imported and exported using an XPX file. This allows rapid edit of file-based inflows to nodes. These can also be edited or copied and pasted in XPTABLES.
  • ENHANCED: When splitting a catchment, the Routing Method and the Routing Method Parameters are copied to the split nodes. For example, the Laurenson settings for B or the SCS CN and time of concentration are duplicated to the new sub catchments for the pervious and impervious areas.
  • ENHANCED: Dynamic Elevation Shapes export to GIS with the proper attribute values for elevation.
  • NEW: The performance of the model is improved when the 2D Land Use layer is locked.
  • NEW: Exporting to GIS 2D Elevation shape polylines and polygons now includes the elevation information.
  • NEW: When exporting to GIS file formats, the polylines now includes the Z attribute elevations.
  • NEW: Elevation data for Gully Breaklines, Ridge Breaklines, and Fill areas are now available for import/export.
  • NEW: Quick Data View now properly shows appropriate XPTABLE headers
  • NEW: Windows now recognizes the associated file extension of XP correctly.
  • ENHANCED: Result values can now be seen independently in XP Tables and Quick Data View for structures in multi-links where multiple structures are turned on in the same conduit line (1-7).
  • ENHANCED: Reference Grid Surfaces now perform as expected when a polygon is added to the layer.
  • ENHANCED: Updated and sharper icons used for Review Results. Inlet Capacity icon is now a grate with a drop of water.
  • ENHANCED2D Soil Type dialog box now includes the grouping of method selection and the associated method's parameters.


  • ENHANCED: Tool tips have been added for the remaining Review Results icons in the toolbar.

Interoperability

  • LandXML structure diameter size properly exports based on Junction Surface Area of the node.
  • LandXML import\export of data is now provided as Feature information which validates correctly.
  • LandXML Exports now includes Inlet HEC22 data.
  • LandXML export extraneous values removed.
  • LandXML custom property for XPSWMM/XPStorm no longer produces a validation error.
  • LandXML import/export functionality now includes feature settings that validate correctly in LandXML 1.2.
  • LandXML Hydraulic node elements export and import to valid Feature data.
  • LandXML channel links now include Feature data.
  • The application now handles oddly formatted LandXML surface data.
  • Improved the LandXML importing. For example, although not computationally necessary the slope is now imported, and the schema has been updated.
  • Fill area now exported in LandXML as surface data.
  • Conduit Features exported to LandXML are correctly validated.
  • LandXML Export of Node Hydrology data now validates as Features.
  • Internal Rating Curves now correctly export to EPASWMM 5 file format.
  • LandXML exports now validate properly.
  • An issue when exporting inactive pumps to EPASWMM5 format is no longer encountered.
  • Importing ISIS Models now supports Channel Markers and panel markers.
  • Inactive elements in the current scenario are no longer included in the EXPORT to EPASWMM5.
  • EPASWMM5 Storage Nodes no longer include the Constant area for Power Functions.
  • Export to EPASWMM5 of Culvert entrance conditions now correctly provide the proper index for all 57 SWMM5 culvert conditions. The two missing entrance conditions are now properly selectable in the Interface.
  • The export of multilink data to SWMM5 (.inp) file now filters based on the check box and will only export the active conduits and ignore other named conduits that are not active.
  • Improvements in ISIS importer for stability and precision.
  • Elliptical Pipe now exports Geom1 Geom2 and Geom3 Index per the latest EPASWMM5 file format.
  • An issue with the Sanitary Sewer Census-based DWF average flow exporting to EPASWMM5 format is resolved.
  • XPX export and import of active Global Storms and Global Storm Ensemble names is now added.
  • The Horizontal and Vertical Elliptical Pipe dialog box correctly responds to reflect the correct rise/width values. These pipes now export correctly for newer releases of EPASWMM5.
     

  • Exporting the DTM to GRID did not always export the surface to the correct location. This has been fixed and now exporting to GRID creates a surface in the expected location
  • An issue where an incomplete model was exported has been resolved by requiring a save prior to the model export to EPASWMM5, LandXML or XPX Export.

Features and Improvements for 2018.1

Hydrology:

  • In Runoff mode, a new tool to provide the ability to split a catchment into the impervious and pervious sub‐catchments is now available. The Tools > Calculate Node > Split Catchment in Perv/Imper tool has now been provided. The tool provides you of SCS or Laurenson hydrology methods the ability to perform better simulations and provides the ability to make sub‐catchment redirections from the impervious to pervious sub‐catchment. 

XPTables

  • A new FIELD STATISTICS tool in XPTABLES allows you to select a column or part of a column and generate the MaximumMinimumMeanSum and Standard Deviation of the contents selected. 
  • A new Block Edit tool in XPTABLES allows you to perform group edit functions on a selection of cells: 
      • Equal to: replaces all selected cells with the new number or string.
      • Add: Adds the entered value to each selected cell.
      • Subtract: Subtracts the entered value to each selected cells. 
      • Multiply By: Multiply the entered value to each selected cell.
      • Divide By: Divide each selected cell by the entered value.
  • Ascending and Descending icons now available in XPTABLES.

Results

  • The Review Results for a Hydraulic Node now has a new graph button (Inlet Capacity) that provides the direct time series results for Inlets display. The new icon (IC) in the Review Results allows you to display flow and levels for selected nodes with Inlet Capacity enabled.
  • Tooltips are available in the Media Control bar for 2D and 1D flood animation. 
  • The Dynamic Long Section (Profile) and the Dynamic Section Views shows an interpolated line of node ground elevations when no DTM exists in the model. 

Resources

  • The NRCS and NOAA Temporal Distributions are now available at the Resource Downloads area. 

Features and Improvements for 2017.2

  • The software will now offer an option to solve the model with the Solve Manager when the total number of storms or scenarios exceeds 50 model runs.
  • The Solve Manager has been successfully tested using 2000 Global Storms.
  • When a model is solved by using the Solve Manager, the engine windows and Solve Manager windows now start minimized. This ensures that there is no interruption to other programs and allows the solve to be in the background.
  • The Engine dropdown is now disabled in the Solve Manager UI to prevent the user from selecting incorrect engine type.
  • A warning is generated when more than 2000 storms is attempted to be solved with Solve Manager.
  • An issue with result windows open was previously not handled correctly with the Solve Manager option. This is now correctly managed and results windows can be closed by the application and the solve will proceed correctly.
  • To make the Box and Whisker plot practical for use, an option to filter the AEPs the Box and Whisker plot by a combo box. Now the results can be filtered to view an individual AEP allowing easy identification of the critical duration/ensemble for that AEP.
  • While using the ARR Storm Generator if the ARR Data Hub Text File does not contain any temporal patterns, then you can select an Increments File to be loaded. These will be used to load temporal patterns that are included in the generated Rainfall Global Databases
  • The user is allowed, in conjunction with ARR 2016, to enter the number of pre-burst timesteps (let's call this N) that would represent the anticedent / pre-burst rainfall. Then when the storms are imported and generated the median pre-burst rainfall depths from the ARR datahub text file, the program places N increments of value 'pre-burst ratio for that AEP and Duration divided by N' before the main temporal pattern.
  • The ARR Data files (Data Hub Text file, Temporal patterns file, and IFD table file) can be downloaded including selection from map. Conversion to XPX and import to XP is now all available from the Select ARR Data Files dialog.
  • The number of Global Storms has been increased to 2000. This now allows ensemble groups such as sets of storm shapes to be simulated for multiple durations and multiple return periods. Clearly this could have hit the previous limit of 100.
  • As part of the overall new feature for updated ARR procedures, a new tool has been created to fetch ARR 2016 data files directly from respective websites/APIs.
  • When doing a Save As for an existing model, the .XP extension is forced as it is for a new model.
  • Gutter, Width, Velocity, and Depth are now available for display in XPTABLES. Previously, these values were only showing in the model output file in Table E9.
  • A new tool to clear 1D Results in the Results menu will remove the model contents in the 1D folder for all scenarios and Global Storms. This will also clear the contents of the .JSON file, which holds some specific Hydrologic and Hydraulics results for the new Global Storms Ensembles.
  • Invert Elevation label has been added to the HDR: Node Data dialog.
  • In version 2016 through 2017.1.1, nodes with inlet capacity did not report the surface node storage for maximum surface area but rather reported the subsurface node area. This has been put back to the earlier intended way. In all versions the model, output file reported all the surface areas of surface and subsurface nodes.
  • The software now protects itself from attempting to triangulate a set of 0,0,0 or identical points for the DTM. In older models, these situations may have resulted in an adverse situation but now the message "Cannot Create TIN file, no triangles generated" is displayed.
  • A persistence issue in the Variable Time Interval rainfall dialog has been fixed. For example, the selection of Absolute depth can now be remembered.
  • Inappropriate menu items were removed from the File menu when inside result windows such as Review Results or xptables.
  • In the case of missing results for active scenarios and global storms not solve: for example, many error messages have been displayed for each missing time series. These messages are now directed to a new ReviewResultsErrors.txt file.
  • Individual or Ensemble groups of storms can now be selected in the Review Results for time series graphing.
  • Some overlapping text has been detected with catchment labels. This has now been fixed and cosmetically, it appears much cleaner and will draw faster with one single write of text to the screen.
  • Statistics for the processing of many Global Storms is now included. Columns have been added to identify the storm that generates the result closest to the average of many storms.
  • In the xptables view, the menu has been trimmed to only show appropriate items in the Window menu.
  • Deleting Time Series Output lines and points could cause adverse issues when no extent was defined in the project. This has now been resolved and these objects can be deleted either graphically or from the Layer Control Panel without affecting program stability.
  • New XPX commands exist for the Rainfall data and time fields: - R_RAINSYR, R_RAINSMTH, R_RAINSDAY, R_RAINSHR, R_RAINSMIN, R_RAINSSEC. These allow separate imports whereas the previous imports of F_R_TZRDT and F_R_TZRTM brought in all date and time fields respectively.
  • A new Global Storm XPX command has been created. This allows import of storm name, ensemble name, and all other parameters for the row. For example, GLOBAL_STORM 0 1 ""CS_63pct_10min1"" ""CS_63pct_10min"" ""ARR 63.2%"" ""CS_63pct_10min1"" 1 1, it is also documented in the online help.
  • Hydrology and Hydraulic model results when using Global Storms and Scenarios are now stored in a JSON file. This partly ensures fast response and reasonable .XP file sizes for those types of models.
  • Models that are saved in more recent versions can no longer be opened in older versions beginning in 2017.1. This has been implemented to ensure database compatibility and the integrity of the data.
  • Since the Global Storms is upgraded to include Ensemble groups when opening older models, the existing storms are now merged to an Ungrouped Ensemble to fit the new structure.
  • Infiltration values (Storm Losses) can now be imported from the ARR Data Hub text file. The import creates a Global Database record from the text file.
  • Double Precision engine selection is no longer forced for GPU solving of rain on grid models. This is desired for optimum run time and it is already part of the GPU solver. It is still recommended for CPU solutions.
  • After a Merge command, an automatic Save is no longer invoked. This means that the user must now decide to save the merged model. This new choice now allows a merged model to be discarded and does not force the acceptance of the merged model.
  • As part of the ARR enhancements and for the speed of processing many global storms, the subcatchment results are now stored and retrieved from a JSON file. This file will be located in the same folder as the .XP file and will be necessary to pass to another user wishing to retrieve catchment results without rerunning the model.
  • A full set of Object Names and Object ID are now written in the model output file. This allows easier recognition of tables in the output file when an object ID is used in place of long object names (>20 characters).
  • An issue with the combination of Global Storms or Scenarios and 1D flood maps has been resolved. In some cases, the individual storm results were not appearing but the Base Scenario result would appear in its place.
  • The user can now toggle on and off in Dynamic Long Section and Dynamic Section Views the X,Y display with the cursor. The default is ON. It is also persistent in the model.
  • The export of catchments now includes Catchment Name, Target Node, and Catchment Position (1-5) as the attributes in the exported GIS files.
  • The evaluation version of the software is now limited to 100 subcatchments. This is justified since there is a limit of five per node and 20 nodes. The limit was previously 50.
  • A message stating "Encountered an improper argument" has been removed when turning on 1D Flood maps when no 1D Flood Maps exist. Now, the dialog will launch showing a null range for the result.
  • Some cosmetic issues were addressed in the infiltration dialogs regarding the text alignment with the embedded images.
  • An abnormal termination was occurring when the model was attempted to be solved while result windows were open. Although a message occurred to close the Windows, they were not closed. This is now fixed for the 2017.2 version.
  • The menu items of New, Open, and Save As while in the Review Results window have been disabled as they are not pertinent in that view.
  • There were occasions where while leaving some result windows open, a crash could occur if the main program was closed before closing other windows. This has been fixed and no crash occurs when closing the program regardless of the choice when prompted to save the model after selecting a closing option.
  • The dialog Copy icon is now disabled as opposed to generating a database error message. This type of data cannot be copied from object to objects and hence the disabling of the icon is appropriate.
  • Clicking Run in the Utilities without entering underlying data for the utility will now correctly display the error and warning messages for all language versions.
  • Version 2017.2 and later allows the user to switch between supported languages. The translated strings are included as XML files for Japanese, Korean and Chinese. Other languages are anticipated for version 2018.1.
  • Various dialog cosmetic issues have been addressed for the Chinese version including the UK hydrology methods dialogs.
  • The text alignment in the subcatchments dialog has been improved for the Korean version.
  • An issue with very large models and non-English regional settings has been resolved. This issue was apparent only when the INI setting OPT_OBJ_NAME_ACCESS=ON was present.

Features and Improvements for 2017.1

  • The configuration parameters PUMP3_MAXQ or MAXQ_PUMP3 are now on by default. They allow the pump to choose the flow with the lowest head on the pump if the pump is found to be off the pump curve such as flowing downhill. Previous versions could not pump downhill without the parameter since no negative head values are on the pump curve and hence no corresponding flows for those pump situations.
  • Within the Grid Extent Properties dialog, you can now set the precision of the Cell Center Elevation from 0 to 10. Typically this will be 2 for US Customary projects and 3 for metric models. This is now extended to the 2D Map results. For example, when showing the Max Depth Result for every cell, the number can be set to show 2 decimal places to represent one hundredth of a foot or every cm for a metric model.
  • XPSWMM can now be configured for only 1D Sanitary Sewer modeling by selecting that menu item in the Configuration menu. This disables certain functions and layers in the layer control panel that do not pertain to that type of model such as 2D modeling.
  • Adaptive time stepping is possible for GPU model runs. It is accessible in the 2D Job Control 2D Only Mode section.
  • When resolving a model if there are opened result windows the user is now prompted to close all Tabs with one click.
  • When assigning catchments to node, those nodes that are on the perimeter or very close can be included in the selection of node as a possible target.
  • When a new Global Database record is added, it is automatically selected so that clicking the Edit button will allow the new record to be edited without clicking the item in the list.
  • The configuration parameter for allowing maximum flow through a pump, when the head is zero or negative, has been placed in the online help.
  • Review Results time series, such as Runoff hydrographs at nodes and stage graphs in Hydraulics, now include in all cases a first time step at time equals zero and a final time step in the displayed and graphed series.
  • The full build number is now being presented in the License Details.
  • The library for loading and reading CAD files has been updated to allow the latest versions of CAD files.
  • The installer has been upgraded and will no longer allow the XCF file to be moved on to itself by selecting the file from the same place as the target during installation, which caused issues in the past.
  • A new feature has been added to the Tools > Modify Elevations to match the crowns or match the inverts of a set of selected links and nodes.
  • xpdiagnostic.exe has been updated for the current version.
  • Maximum water surface elevations for bridge links are automatically set to 10 m or 30 ft, depending on units above the high cord value. This ensures that the weirs used for the overtopping remain weirs and do not become orifices or the SWMM default at the weir surcharge elevation.
  • The current XPSWMM/XPStorm installers no longer have a direct download for XPDRAINAGE but rather some links to learn more and request an evaluation copy.
  • GPU solves do not force Double Precision engines when there is a rain on Grid simulation.
  • The old CHM files are no longer part of the XPSWMM/XPStorm installers. The program help is all online except for the Japanese version at help.innovyze.com.
  • In an effort to streamline multiple language version of XP, we now use a single xps_res project for all resources dlls.