The following section provides a basic outline of how you can create a network model using XPSWMM.

Setting the Active Mode

When a new model (.XP file) is opened, it opens in the Hydraulics (Hdr) mode. Existing models will open in the current mode when they were last saved. 

The three available modes are Runoff (Rnf), Sanitary (San) and Hydraulics (Hdr).  The active mode is indicated by the highlighted mode tool.

 

The active mode may be changed by clicking the icon representing the desired mode.

Runoff Mode (Rnf) is used to perform hydrology calculations and contains many hydrology options, including a deterministic model of the hydrologic cycle named Runoff.

Sanitary Mode (San) is used to perform kinematic wave hydraulic routing, simulation of scour and deposition in sewers, development of dry weather flows and the simulation of BMPs. Many of the capabilities of this mode are duplicated in the other two modes.

Hydraulics Mode (Hdr) is used to simulate water flow using full dynamic wave routing in 1D and 2D networks.

The mode can also be set from Configuration Menu > Mode, in the Mode Properties dialog. 

Graphical Elements

The model network is created using a set of graphical objects primarily consisting of polygons for catchments and links and nodes for the hydraulic network. In a 2D model you may also find polylines and polygons to describe the terrain, boundaries and domain of the 2D model. The network of nodes is connected together by links, with some additional elements provided for annotation and background reference. 

XPSWMM supports the following types of objects: 

TypeSymbolDescription

Node

Used to represent physical objects such as manholes, inlets, ponds, outfalls or junctions of various links such as natural channels or closed conduits.

Link

Single connection between nodes of closed or open conduit geometry. They represent physical elements, e.g. pipes, channels, overland flow paths, etc. A polylink is special type of link that has vertices between the end nodes. Pumps orifices, weirs and special links must be created with multi-link below.

Multi-link

Multiple connections of conduits between nodes. Diversions such as pumps, orifices, weirs etc. are also created in multi-links.

Text

Lines of text annotation used for labeling the backgrounds.

Polyline

Polylines are used to represent 1D/2D connections, 2D boundaries and ridges and, gullies.

Polygon

Polygons are used to represent catchments, landuse zones, and the 2D domains of flooded areas.

Cross-section

A cross section is a temporary polyline that is draped on the DTM to create the geometry for a natural channel.

Each element of the network has certain editable spatial and display properties and a unique name. Display properties include the colour and line thickness of the object. Colours may be edited using the Windows colour panel. Spatial attributes include the position and dimensions of the object. Digital images and text notes can also be attached to nodes through the Properties dialog.

Creating the Network

The network is created using the tools (icons) contained in the tool strip.

To create a network:

  1. Create nodes in your network:
    1. Select the node tool from the tool strip. The cursor shape changes to a node object symbol indicating a node is being created. 
    2. Click on the window to create a node. The application defines the position of the node and gives it a unique name. 

      You can change the display properties (color, thickness, text height, and node size) by right clicking the node, selecting Properties, and then clicking the Display Properties button. 
  2. Create the link between nodes:
    1. Select the link tool from the tool strip. The cursor shape changes to link object symbol indicating a link is being created. 
    2. Click the first node and then click another node that you wish to connect. The arrow indicates the direction of flow from upstream to downstream. An arrow is placed on the downstream end of the link indicating the direction of positive flow. The position of the second end of the link (the end towards which flows are directed) is indicated by a dotted outline that tracks the mouse movement.

XPSWMM performs a series of validity checks to verify a correct network is being created and, if the connection satisfies all of the rules, the link is created. For example, only one link can be created between two nodes and nodes cannot overlap.

An additional feature of the link tool is the ability to create a default end node. If you attempt to create a link without creating a node first, a default node will be created. It is not necessary to first create nodes and then join them with links, but rather perform both operations simultaneously.

Converting the type of multiple selected links simultaneously

XPSWMM has the functionality to simultaneously convert multiple selected links to a different type. To convert the type of multiple selected links:

  1. Hold the <Ctrl> key and click the various links that you want to convert.
  2. Right-lick and select from the drop-down list the type of link you wish the selected links to be converted into. For more information about the types of links, refer to Links
You cannot convert multi-link to river link.

Changing the naming convention

A default unique name is automatically created for any object requiring a name. However, you can change the prefix of the objects based on your requirement. For example, you may wish to preface all nodes with “mh”. Then as each node is created, the names will be numbered sequentially using the prefix such as mh1, mh2, and so on.The direction of the link can be modified from the link menu by selecting reverse direction.

To change the prefix of the object name:

  1. Go to File > Properties.
  2. In the File Properties and Options dialog:
    1. Select Node Defaults > Node Drawing, and change the prefix in the Node Name Prefix field.
    2. Select Link Defaults > Link Drawing, and change the prefix in the Link Name Prefix field.
  3. Click OK.

As you draw a link, you may create a polylink (bent link) by holding down the <Ctrl> key as you click. This will create a vertex at each point at which you click. Terminate the link by clicking without holding down the <Ctrl> key.

You may change an existing link to a polylink by first selecting the link, then right-clicking and selecting Edit Vertices from the menu. Move the cursor to the location of the vertex. Click the vertex to move the bend in the link.

You may remove a vertex by first selecting the link, then right-clicking and selecting Edit Vertices from the menu. Move the cursor to the vertex, right-click and select Delete Vertex.


Naming an Element

Every object in the network must have a unique name. No node may have a name already used by another node or link in the database. 

For the names are generally limited to 80 alphanumeric characters. Three methods are available to name a network object, the last two of which invoke the Properties dialog box.

  1. Highlight the node or link then double-click on the name and modify the name directly on the screen. Follow the editing with an enter keystroke to terminate editing.
  2. Select the node then click the right mouse button. This will bring up a pop-up menu. Select "Properties" to enter the object name in the dialog.
  3. Highlight the node or link then select "Properties" from the Edit menu.

If method (2) or (3) above is chosen, a dialog box similar to that shown below is then displayed. 

  

If the object selected is a link, the coordinate boxes are not shown.

Picture File

A bitmap image can be attached to a node or link by entering the name of a graphics file in the Picture File field. The formats currently supported are BMP, DXF, EPS, FAX, IMG, JPG, PCD, PCX, PNG, TGA, TIF, WMF, WPG, XBMP, XDCX, XEPS, XJPG, XPCX and XTIF. With an image selected the node and link pop-up menus will display an active "View Image" menu item.

   

Setting Default Labels

The default prefix for new nodes and links in the network can be set in the Node Drawing and Link Drawing dialogs – accessed by selecting Properties in the File menu.

Manipulating Network Objects

As an object-oriented, graphical hydrologic modelling system, XPSWMM allows users to easily manipulate objects within the network design.

The following topics describe the available options for manipulating objects within XPSWMM

Selecting an Object or a Group of Objects

Many menu commands operate on the set of currently selected objects. Note that the ability to select objects can be modified with the Layer Control Panel. Objects are selectable only when the check box in the third column of the Layer Control Panel is on. A selected object is indicated by it being displayed with cyan highlighting.

Selecting a Single Object:

Choose the pointer tool from the tool strip, point to the desired object and click the primary mouse button.

Selecting a Group of Objects:

A group of objects may be selected by using any combination of the following techniques:

    1. Click in open space and with the mouse button held down dragging a cyan colored rectangle around the desired group. If more than half the object is included in a rectangle the object is selected.
    2. Select individual non-contiguous objects by clicking the mouse with the <Ctrl> key held down.
    3. All the objects in the path between two end nodes can be highlighted by clicking on the first node, and then with the Shift key held down, clicking on the second node.
    4. If a node has been selected, right-click over the node to open the pop-up context menu to: 
        1. Select Downstream Objects
        2. Select Upstream Objects
        3. Select Objects 
           
      Choosing "Select Objects" will launch the following dialog:

      This tool may be used to identify non-connected objects or select objects based on connectivity.

The selections can be extended to include or exclude objects by using the <Ctrl> key in conjunction with the mouse button. It has the effect of toggling the state of the object between selected and unselected.


Selecting all Nodes or Links:

All nodes or all links may be selected by:

    • Using the or the tools on the Network Viewing and Navigation toolbar.
    • Choose Select Objects from the View Menu.
    • Entering <Ctrl> A for all nodes and <Ctrl> L for all links.

Deselecting All Objects:

Objects may be deselected by clicking on any white space (away from any network object).

Moving an Object

A selected (highlighted) group of objects can be moved by dragging any object from the highlighted set - the rest will follow. A dotted outline of all affected objects tracks the mouse movements until the button is released, indicating the final position of the moved objects in real time.

Note: Objects cannot be moved unless the Movable property for the object is enabled in the Layer Control Panel.

Reconnecting Objects

A link can be reconnected to another node by first selecting it, then positioning the pointer near one end of the link and dragging the end of the link to the new node. A cyan outline tracks the movement of the link in real time. Note: The cursor changes to a conduit reconnection shape.

Creation of the new link is subject to the same connectivity rules applied during network creation, i.e. an illegal network cannot be created through re-connection.

Deleting Objects

A selected (highlighted) individual object or group of objects can be removed from the model by invoking the “Delete Objects” menu command, from the Edit menu or selecting the Del key on the keyboard. A confirmation dialog will be displayed before the delete is accomplished allowing you to confirm or abandon the deletion process.

NOTE

  • A link cannot exist without both end-nodes; thus when one end-node is removed, the link is also deleted.
  • Deleting cannot be undone. Accidental deletion of objects will require you to recreate the objects and reenter the data or revert to a previously saved version of the model.

Using the Layer Control Panel

The Layer Control Panel can be used to manage (create, delete, edit, and access the display properties of) objects in the XPSWMM network. Make sure the layer of interest is visible and unlocked before accessing the Layer Control Panel Features.

In a 1D network, the Layer Control Panel is used to access the following layers:

Network building and editing:

Nodes:

Labels

Catchment Connections

Links

Cross-sections

Water Level Lines

Labels

Texts

Model results:

Spatial Reports

Graphical Encoding

Read more about this feature in the Layer Control Panel page.

Nodes

Highlight the Nodes or Node Label row and right click to launch a pop-up menu. 

The following are the available options :

Properties - Loads the Node Properties dialog  

Import from GIS File - Add nodes from the network using an existing GIS .shp file

Export to GIS File - Exports the existing Nodes into a GIS .shp file 

Delete All to remove all nodes from the network 

Import Nodes from GIS


Use this tool to import nodes from a GIS layer (.shp of .mif file). Additional data may be imported with the Import/Export External Databases tool. 

  1. Click on the ellipses (…) to open Windows Explorer. Navigate to the source file and select Open.
  2. To import selected data, check the Import Selected Data box. Select the property from the drop list of attributes. Specify the value of the attribute for imported nodes.
  3. Click Import to launch the Node Import Dialog.



  4. For the Node Names, choose the Default Names or use the attribute data and select attribute name from the drop list. Mappings can be made to given variables at this point in the import process. To map a GIS database variable with the associated xp variable simply highlight the desired variable row and select the Set radio button, finally select the variable from the available options.
  5. Click OK to begin importing Node data. XPSWMM will report the number of nodes Read, Invalid, and Ignored. A text file listing warnings and errors will also open.

     
  6. Click OK to close the dialog and view the network. 

Export Nodes to GIS File

Right clicking on the Nodes layer and selecting Export to GIS File… from the popup menu will launch the GIS Export: Node dialog. 

 

The export dialog allows the exporting of not only the spatial node data (node name and x,y coordinates) but also object variables, such as Node Invert and Spill Crest levels. The Export to GIS dialog allows variable selections to be made manually or to be pre-filled from the XP Table. In version 2013 and later, nodes can also be exported to DXF with the associated graphical encoding.

To finalize the export, click Export, navigate to the location where the file will be stored, and click Save.

Catchments

Catchment Connection Export

Catchment data can be exported to GIS shape files (*.shp) from the Catchments layer in the Layer Control Panel. xp also exports details on target node,  catchment number, and catchment name  by default.

To export catchment data from the layer control panel: 

  1. Right-click the Catchments layer under 1D Network → Nodes in the layer control panel. 
  2. Select "Export to GIS file.
  3. In the "Export to GIS Files" dialog, you can choose to export either All Objects or Selected Objects. 
  4. Click "Export" to save the file to a specific folder.  

The above steps will generate three files: *.dbf, *.shp, and *.shx. The *.dbf file contains the attributes tables for the exported catchment data. 


 

Add Catchment to Drawing

Catchment polygons may be added to a model by three methods:

  1. Drawing with the polygon tool.

  2. Importing from a GIS or CAD file.

  3. Importing an XPX file with the Catchment command.

After the catchments have been added,

  1. They may be linked to nodes.

  2. The areas may be calculated.

If Catchment polygons have been established many Runoff Node Subcatchment parameter values can be automatically applied based on area weighting of GIS polygon areas/attributes, using the Import Hydrologic Parameters option under the GIS Layer.

To add a Catchment to a model:

  1. Highlight Catchments in the Layer Control Panel. Use the Snap Tool to align vertices with other layers
  2. Select the Polygon tool from the Object Creation Tools set. The cursor will show the polygon shape
  3. Draw the outline of the catchment by clicking on each vertex. Double click to complete the polygon.
     

The completed catchment polygon is shown below.

After, the catchment polygon has been created, link the catchment to a node.

Linking a Catchment to a Node

There are currently two supported methods for linking a catchment to to a node. 

Method 1: Using the Pointer Tool: 

  1. The Catchments Layer must be viewable and selectable.
  2. Select the Pointer tool from the Object Creation Tools set.
  3. Select the catchment polygon and locate the centroid. It will be shown with a square once the catchment polygon is selected.
  4. Left click on the centroid and drag (move mouse while holding the left button down) a line to the node.
  5. The cursor will change to a double lined cross at the selected node. Release the left button.
     
  6. A pop up list will ask for the available subcatchment numbers to be linked to the node. Left click on the subcatchment number to be selected. Note that subcatchments already assigned are disabled. A maximum of 5 subcatchments can be assigned to a node.


Method 2: Using the Calculate Drainage Tool:

  1. With the catchments layer set as active and visible, select the Catchment Drainage tool from the menu. (Tools ->  Calculate Node -> Catchment Drainage)


  2. Depending on the placement of the nodes, the tool will display four options for linking catchments to nodes: 
    1. Nodes in Catchment
    2. Node Nearest a Catchment Centroid
    3. Node Nearest a Catchment Vertex
    4. User Selection/All Nodes in Model
  3. The tool will display the available nodes based on the above selection criteria
  4. If there are multiple nodes that meet the same selection criteria (e.g., there are two or more nodes within a catchment area), a drop down menu will become available with the appropriate Node names. 
  5. Mark the check box beside the node name/selection method to link the catchment to a node.

Up to five (5) catchments can be linked to a Node.


Change the Catchment Connections Display Properties

  1. Highlight Catchment Connections in the Layer Control Panel and right click.
  2. Select Properties to launch the Catchment Connections Drawing Attributes dialog. Edit the color, style and size of the connections.

Import Catchments

To import catchment from GIS or CAD file:

  1. Move the mouse over Catchments in Layer Control Panel and right click.

  2. Select Import from GIS/CAD fil.

  3. Navigate to the source file.

  4. To filter the polygons in the file, select field in the Property Name drop list and enter the Property Value for polygons to be selected. Check the box Import Selected Data.


  5. Click on Import

  6. In the Catchment Data Mappings dialog, map attributes in the shape file to model variables. The Node Name is selected from a drop list of attributes. The Catchment Number can either be selected from an attribute or appended as new catchment. To map a field (attribute) select the field and click on Set to open the Variable Selection dialog. Click on Import.
     

The progress bar displays the status of the import. When it is completed, a message displays information on the polygons and vertices that were imported. The application will check for vertices sharing the same x, y location and will not allow this to happen.

To view, select and edit the catchment polygons the appropriate boxes must be checked in the Layer Control Panel.  

Sewersheds

XPSWMM 2015 and later now provides the ability to define Sewersheds within a network. 

The process for adding a sewershed is similar to adding catchments. By default, sewersheds are represented by tan-colored polygons.

To add a Sewershed to a model:

  1. Highlight Sewersheds in the Layer Control Panel. Use the Snap Tool to align vertices with other layers
  2. Select the Polygon tool from the Object Creation Tools set. The cursor will show the polygon shape
  3. Draw the outline of the catchment by clicking on each vertex. Double click to complete the polygon.


To link a sewershed to a node:

  1.  Set the Sewersheds layer as visible and selectable. 
  2. Select the Pointer tool from the Object Creation Tools set.
  3. Select the Sewershed polygon and locate the centroid. It will be shown with a square once the catchment polygon is selected. 
  4. Left click on the centroid and drag (move mouse while holding the left button down) a line to the node.


    The cursor will change to a double lined cross at the selected node. 
  5. Release the mouse button, and select the appropriate Dry Weather Flow pattern. 
  6. The selected DWF pattern be further configured by double-clicking the connected Node to launch the Node Data Dialog, and clicking the Dry Weather button in the Time Series Inflow section.

Read more about Dry Weather Flows in the Hydraulics Node Data section.  

Highlight the Links row and right click to launch a pop-up menu.

The following are the available options:

Properties - Launches the Link Properties dialog. 

Import from GIS file 

Export to GIS File

Delete All - Deletes all the links in the model.

Link Properties

Use this dialog to adjust the display properties of all links in the network.

 

The Link Label Opacity Flag causes a break in links to display the label.

The Show Link Arrow Head Flag shows an arrow at the downstream end of each link.

Import Links from GIS File

Use this tool to import links from a CAD (.dxf or .dwg) drawing or GIS layer (.shp or .mif). Note that XPSWMM requires a valid network at all times. The upstream and downstream node for each link must exist in the database when it is imported. Additional data may be imported with the Import/Export External Databases tool.

  1. Click on the ellipses (…) to open Windows Explorer. Navigate to the source file and select Open.
  2. To import selected data, check the Import Selected Data box. Select the property from the drop list of attributes. Specify the value of the attribute for imported nodes.
  3. Click Import.
  4. For the Link Names, choose the Default Names or use the attribute data and select attribute name from the drop list. Select the Upstream and Downstream Nodes from the drop lists.


  5. Mappings can be made to given variables at this point in the import process. To map a GIS database variable with the associated xp variable simply highlight the desired variable row and select the Set radio button, finally select the variable from the available options.
  6. Click on OK.
  7. XPSWMM will report the number of links Read, Invalid, and Ignored. A text file listing warnings and errors will also open.



  8. Click on OK to close the dialog and view the network.

Export Links to GIS File

Right click on the Links layer and select Export to GIS File… from the popup menu.

 

The export dialog allows the exporting of not only the spatial link data (link name, upstream and downstream node names) but also object variables, such as Conduit Shape, Length and Slope. The Export to GIS dialog allows variable selections to be made manually or to be pre-filled from the XP Table.

To finalize the export click on Export, navigate to the export file destination and click Save.

Water Level Lines

Water Level Lines are polylines used to display 1D open channel and 2D results together. They extend from the left bank to the right bank of the channel. These polylines are used to create a TIN from the 1D node results which is spatially displayed as a flood map. Water level lines may be manually added or generated automatically.

To manually add a single Water Level Line to given link perform the following:

  1. Select and right click on a Link. Choose Add Water Level Line from the popup menu.
     

  2. An x will appear next to the cursor, Click once to add a vertex

  3. Continue adding vertices by clicking on the network

  4. Double click to complete the polyline

Water Level Lines can also be automatically generated by using the Generate Water Level Lines option.

Cross-sections

Right-click the Cross-sections entry under the Links layer, and select Properties to launch the Cross-section properties dialog. This allows users to modify the display properties for cross-sections. 

Drawing Attributes

The Drawing Attributes tab can be used to customize the display attributes for cross-section links. 

Data

The Data tab is used to set the display properties for the left and right banks of a river or cross-section. Selecting a field and clicking the "Field Info" button displays the data attributes of the field.