The Quick-Start tutorial is designed for first-time users of Calibrator and provides a guided tour to core commands and functions used to create and execute a calibration run in InfoWater Pro. The Quick Start tutorial will help you become familiar with the core set of Calibrator features and should be used as a launching point to a more comprehensive understanding of the program. 

The estimated time to complete the Quick Start tutorial is approximately one hour.

The Quick Start tutorial will help you become familiar with the following:

  1. Creating calibration data.
  2. Setting important simulation options.
  3. Making a calibration run.
  4. Reviewing and analyzing calibration results.
  5. Exporting calibration results for various uses.

During the Quick Start tutorial, you will modify an existing project called "SampleCal". This project is provided with the typical Calibrator software installation and can be found in the InfoWater Pro Examples directory:

C:\Users\Public\Documents\InfoWaterPro\Examples\SampleCal.aprx (May be different for custom or Vista installations).

The SampleCal project modified in this tutorial illustrates how Calibrator calculates junction demands, pipe roughness coefficients, and pipe status to best match field conditions to model conditions.

The SampleCal model schematic is shown below. The model contains two pressure zones and consists of the following components:

  • One reservoir (storage node 101) 
  • One tank (storage node 103) 
  • Two pumps located at the water treatment plant and numbered 200 and 210 
  • One pressure reducing valve located at node 300 
  • One check valve located in pipe 78
  • Fifty-eight pipes 
  • Forty-five junction nodes 
  • One reference file containing the parcel and street layout (not shown in the illustration below)

During the tutorial, you will be guided through:

  1. Creating pipe and junction calibration groups.
  2. Choosing calibration simulation options.
  3. Performing three calibration runs based on different field data types; that is, steady state calibration, fire flow calibration, and extended period calibration. 
  4. Exporting calibration results.


The first step is to load the SampleCal project.

  1. Choose the Start menu, select Programs, and choose the InfoWater Pro program. ArcGIS will now start.
  2. In the ArcMap window, select an existing map option in the Start Using ArcMap With area and then click on the OK button. If the ArcMap window is not shown, simply choose Open command from the File menu. On the Open dialog box, navigate to the directory containing the "SampleCal" project and choose that file:
    C:\Users\Public\Documents\InfoWaterPro\Examples\SampleCal.aprx (may be different for custom installations)
  3. Go to the Tools menu, choose Extensions, click on the InfoWater Pro checkbox and then click on Close button. Click on the red down arrow icon to initialize InfoWater Pro. When initialized, the icons on the InfoWater Pro toolbars will be enabled for use. You are now ready to begin the first exercise.

  4. Before continuing, save the "SampleCal" project to a new project name. If you wish to restart the tutorial, the original project will be available. Choose the Save As command from the File menu. On the dialog box, enter the new project name "Tutorial". This becomes the active project. 

Steady State Model Calibration

You are now ready to begin the first exercise: Steady State Model Calibration.

Step 1: Select Steady State Mode

  1. From the Scenario pull-down menu in InfoWater Pro, select the “STEADY_STATE” scenario. Choose OK to verify the switch from the currently active to the “STEADY_STATE” scenario.
  2. From the InfoWater Pro ribbon, click Apps to open the Apps Manager dialog box.
  3. With the Apps Manager dialog box open, select Calibrator from the list of applications, and click Run. This will load the Calibrator dialog box. Select the Steady State command from the Mode menu. The dialog box appears as shown below.

Step 2: Select Pipe Calibration Groups

The second step in the calibration process is to define the pipe calibration groups. Pipes should be grouped together based on similar characteristics such as material, age, and diameter. It is assumed that all pipes within a group will have the same roughness coefficient.

For this example, four pipe calibration groups have already been created.

  1. Select the PIPE_GROUP database field in the Pipe Group Database Field drop-down list as shown below. The pipe IDs for each group will be displayed on the Roughness Group tab.
    To create different pipe groups, the following steps would then be required. 
  2. Select the New button and enter PGROUP in the Field Title of the New Pipe Group Database Field dialog box.

  3. Choose the DB Edit button and click on the Open button to open a database table. When the Open Table dialog box appears on the screen, choose the Pipe Information table from the drop-down list, select All (indicating you want the entire contents of the table to be displayed and available for editing), and choose OK. The Pipe Information table appears on the screen. 

  4. You will now enter the pipe calibration group ID for each pipe in the PGROUP data field as defined above. 

  5. Select the Save button and then choose the Close button at the top of the Database Editor window. 

  6. Close the Database Browser by selecting the Exit button at the top of the Database Editor.


Step 3: Define Bounds for Pipe Roughness Coefficients

The next step is to define the desired minimum and maximum limits for the pipe roughness coefficients and their associated increments for each of the four calibration groups. Use the table below as a guide when entering this data.



Based on the levels specified above, the roughness coefficient in pipe calibration group 1 will be incremented with equal increments of 7, the roughness coefficient in pipe calibration group 2 will be incremented with equal increments of 10, the roughness coefficient in pipe calibration group 3 will be incremented with equal increments of 10, and the roughness coefficient in pipe calibration group 4 will be incremented with equal increments of 10.

The Roughness Group tab now appears as follows:

Step 4: Select Junction Calibration Group

The fourth step in the calibration process is to define the junction calibration groups. Junctions should be grouped together based on similar characteristics such as demand types and geographical locations.

For this example, two junction calibration groups have already been created.

  1. Select the NODE_GROUP database field in the Junction Group Database Field drop-down list as shown below. The junction IDs for each group will be displayed on the Demand Group tab.

Step 5: Define Bounds for Junction Demands 

The fifth step is to define the desired minimum and maximum limits for the junction demands and their associated increments for each of the two calibration groups. The Demand Group tab now appears as follows.

Use the table below as a guide when entering this data.

Step 6: Define Unknown Pipe Status

The sixth step in the calibration process is to define the pipes whose status (i.e., open or closed) has to be determined based on field test data. For this example, pipes 98 and 96 have unknown statuses. Simply enter the pipe IDs in the Pipe Status table as shown below.

Step 7: Set Target Pressures

You will now specify the target pressure measurements at target junction nodes in the system. A total of 5 pressure measurements at 5 distinct junction nodes will be inputted. 

  • Choose the Junction Pressure tab and enter the data shown below.

Step 8: Set Target Flows 

You will now specify the target flow measurements at target pipes in the system. A total of 6 flow measurements at 6 distinct pipes will be inputted.

  • Choose the Pipe Flow tab and enter the data shown below.

Step 9: Select Calibration Run Options

Now that you have completed the process of creating a calibration run, the next step is to define your calibration run options. You will select “00:00” for the Calibration Time. You will choose “Psi” and “Gallon / Minute” for the pressure and flow measurements respectively. You will use a “Weighting Factor” of 1 for both pressure and flow data and an “Evaluation Threshold (%)” of 5 percent for both pressure and flow data. You will specify a type 1 objective function (default value), a “Fitness Threshold” of 0.001, a “Least Fitness Improvement” of 1 percent, a “Least Improvement Generation” of 100 (default value), and a maximum number of trials of 50,000 (default value).

  1. Choose the Options command from the Run menu and enter the data shown below in the Calibration Options dialog box. 
  2. Click on the OK button to close the dialog box.

Step 10: Run the Steady State Calibration Module

You have now entered all required information for the steady state calibration model. To run the Steady State calibration module, choose the Start command from the Run menu. The Run tab appears on the screen.

As shown in the Run tab, a fitness of 0.009 was reached after 24 trials for the type 1 fitness function specified. 

Step 11: Review Steady State Calibration Results

The steady state calibration results can be reviewed by choosing the Roughness Group, Demand Group, Pipe Status, Junction Pressure and Pipe Flow tabs as shown below.

The calculated pipe roughness for each pipe group is given below and satisfies the bound constraint.

The calculated demand scaling factor for each junction group is given below and satisfies the bound constraint.

The initial status is given for each pipe as shown below. Pipe 98 is closed while pipe 96 is open.

The table below shows the simulated pressures and the observed pressures.

The table below shows the simulated flows and the observed flows. 

You may also perform a more stringent calibration by selecting different calibration options to compare your calibration results.

Step 12: Export Steady State Calibration Results

You can export the steady state calibration results using the Export Results tab to the appropriate data sets. To do this, perform the following:

  1. Choose the Export Results tab and check the three export options.
  2. Click on the Browse button to enter the desired Data Set ID. Click on the New icon and enter “SS_RESULTS1, Steady State Model Calibration Results” for the Pipe Data Set ID and description. Repeat this above step twice for the Demand Set and Control Set. 

  3. Choose the Export button to execute the Export command. The calibration results are now saved to the appropriate data sets. The Export Results tab should appear as follows. Select the Exit command from the Mode menu.

Congratulations! You have now completed the Steady State Calibration tutorial.  

Fire Flow Model Calibration

Step 1: Select Fire Flow Mode

The first step is to select the appropriate model scenario and to launch Calibrator dialog box.

  1. From the Scenario pull-down menu in InfoWater Pro, select the “FIRE_FLOW” scenario. Choose OK to verify the switch from the currently active to the FIRE_FLOW scenario.
  2. From the InfoWater Pro ribbon, click on Apps to open the Apps Manager dialog box.
  3. With the Apps Manager dialog box open, select Calibrator from the list of applications and click on the Run button. This will load the Calibrator dialog box appears on the screen. Select the Fire Flow Test command from the Mode menu. The dialog box appears as shown below.

Step 2: Select Pipe Calibration Groups

The first step in the calibration process is to define the pipe calibration groups. Pipes should be grouped together based on similar characteristics. For this example, the same pipe calibration groups will be used as in the previous tutorial. 

Step 3: Define Bounds for Pipe Roughness Coefficient

The next step is to define the desired minimum and maximum limits for the pipe roughness coefficients and their associated increments for each of the four calibration groups. Again for this example, the same constraints will be used as in the previous tutorial. Use the table below as a guide when entering this data.

Step 4: Set Fire Flow Test Measurements

You will now specify the fire flow test measurements at target hydrants in the system. A total of 5 fire flow tests at 5 different junctions will be inputted. The same demand, control and boundary (tank and reservoir) conditions will be assumed as the same data sets are used for each fire flow test. Note that the appropriate data sets have already been created. 

  1. Choose the Fire Flow Measurement tab and enter the data shown below. 

Step 5: Select Calibration Run Option

Now that you have completed the process of creating a calibration run, the next step is to define your calibration run options. The same calibration options will be selected as in the previous tutorial. You will specify a type 1 objective function (default value), a “Fitness Threshold” of 0.001, a “Least Fitness Improvement” of 1 percent, a “Least Improvement Generation” of 100 (default value), and a maximum number of trials of 50,000 (default value).

Step 6: Run the Fire Flow Calibration Module

You have now entered all required information for the fire flow calibration model. To run the Fire Flow calibration module, choose the Start command from the Run menu. The Run tab appears on the screen. 

As shown in the Run tab a fitness of 0.0004952 was reached after 15 trials for the type 1 fitness function specified.  

Step 7: Review Fire Flow Calibration Results

The fire flow calibration results can be reviewed by choosing the Roughness Group and FireFlow Measurement tabs as shown below.

The calculated pipe roughness for each pipe group is given below and satisfies the bound constraint.

The table below shows the simulated pressures and the observed pressures. 

You may also perform a more stringent calibration by selecting different calibration options to compare your calibration results. 

Step 8: Export Fire Flow Calibration Results

You can export the fire flow calibration results using the Export Results tab to the appropriate pipe data set. To do this, perform the following:

  1. Choose the Export Results tab and check the export option.
  2. Click on the Browse  button to enter the desired Pipe Data Set ID. Click on the New icon and enter “FF_RESULTS1, Fire Flow Model Calibration Results” for the Pipe Data Set ID and description. 
  3. Choose the Export button to execute the export command. The calibration results are now saved to the appropriate pipe data set. The Export Results tab should appear as follows. Select the Exit command from the Mode menu.

Congratulations! You have now completed the Fire Flow Calibration tutorial. 

Extended Period Mode Calibration

Step 1: Select Extended Period Mode

The first step is to select the appropriate model scenario and to launch Calibrator dialog box.

  1. From the Scenario pull-down menu in InfoWater Pro, select the “EPS” scenario. Choose OK to verify the switch from the currently active to the EPS scenario.
  2. From the InfoWater Pro ribbon, go to Apps to open the Apps Manager dialog box.
  3. With the Apps Manager dialog box open, select Calibrator from list of applications and click on the Run button. This will load the Calibrator dialog box appears on the screen. Select the Extended Period command from the Mode menu. The dialog box appears as shown below.

Step 2: Select Pipe Calibration Groups

The first step in the calibration process is to define the pipe calibration groups. Pipes should be grouped together based on similar characteristics. For this example, the same pipe calibration groups will be used as in the previous tutorial. 

  1. Select the PIPE_GROUP database field in the Pipe Group Database Field drop-down list as shown below. The pipe IDs for each group will be displayed on the Roughness Group tab.

Step 3: Define Bounds for Pipe Roughness Coefficients

The next step is to define the desired minimum and maximum limits for the pipe roughness coefficients and their associated increments for each of the four calibration groups. Again for this example, the same constraints will be used as in the previous tutorial. Use the table below as a guide when entering this data. 

Step 4: Set Target Pressures

You will now specify the target pressure measurements at target junction nodes in the system. A total of 10 pressure measurements at 5 distinct junction nodes will be inputted. Two different loading conditions will be considered. 

 1. Choose the Junction Pressure tab and enter the data shown below.

Step 5: Set Target Flows

You will now specify the target flow measurements at target pipes in the system. A total of 12 flow measurements at 6 distinct pipes will be inputted. Two different loading conditions will be considered.

1. Choose the Pipe Flow tab and enter the data shown below. Click on the Set Rows button and enter “12” as the number of rows required. 

Step 6: Set Target Tank Measurements

You will now specify the target tank measurements at target tanks in the system. A total of 2 measurements will be inputted. Two different loading conditions will be considered. 

  1. Choose the Tank Head/Level tab and enter the data shown below.  

Step 7: Select Calibration Run Options

Now that you have completed the process of creating a calibration run, the next step is to define your calibration run options. Again, the same calibration options will be selected as in the previous two tutorials. 

Step 8: Run the Extended Period Calibration Module

You have now entered all required information for the extended period calibration model. To run the Extended Period calibration module, choose the Start command from the Run menu. The Run tab appears on the screen.

As shown in the Run tab, a fitness of 0.042928 was reached after 6,134 trials for the type 1 fitness function specified.

Step 9: Review Extended Period Calibration Results

The steady state calibration results can be reviewed by choosing the Roughness Group, Demand Group, Pipe Status, Junction Pressure and Pipe Flow tabs as shown below.

The calculated pipe roughness for each pipe group is given below and satisfies the bound constraint.

The table below shows the simulated pressures and the observed pressures.

The table below shows the simulated flows and the observed flows. 

The table below shows the simulated tank levels and the observed tank levels.

You may also perform a more stringent calibration by selecting different calibration options to compare your calibration results. 

Step 10: Export Extended Period Calibration Results

You can export the extended period calibration results using the Export Results tab to the appropriate pipe data sets. To do this, perform the following:

  1. Choose the Export Results tab and click on the Apply New Roughness Settings in option.
  2. Click on the Browse button to enter the desired Pipe Data Set ID. Click on the New icon and enter “EP_RESULTS1, Extended Period Model Calibration Results” for the Pipe Data Set ID and description. 
  3. Choose the Export button to execute the export command. The calibration results are now saved to the appropriate pipe data sets. The Export Results tab should appear as follows.

Congratulations! You have now completed the Extended Period Calibration tutorial.