The Quick-Start tutorial is designed for first-time users of InfoWater Pro Demand Allocator and provides a guided tour to core commands and functions used for loading network models based on demand location and variation. The Quick Start tutorial will help first-time users become familiar with the core set of InfoWater Pro Demand Allocator features and should be used as a launching point to a more comprehensive understanding of the program.

The estimated time to complete the Quick Start tutorial is approximately 20 minutes.

The Quick Start tutorial will help first-time users become familiar with the following:

During the Quick Start tutorial, you will modify a project named “SampleAlloc”. This project is provided with InfoWater Pro Demand Allocator software installation and can be found in the InfoWater Pro -> Examples directory:

C:\Users\Public\Documents\InfoWater Pro\Examples\SampleAlloc.aprx (Note: The path may be different for custom installations.) 

The SampleAlloc project modified in this tutorial illustrates how InfoWater Pro Demand Allocator automatically calculates and distributes water consumption demands.

The SampleAlloc model schematic is shown below. The model contains two pressure zones and consists of the following components:

  • One reservoir (storage node 101) 
  • One tank (storage node 103) 
  • Two pumps located at the water treatment plant and numbered 200 and 210 
  • One pressure reducing valve located at node 300 
  • One check valve located in pipe 78 
  • Fifty-eight pipes 
  • Forty-five junction nodes 
  • One reference file containing the parcel and street layout (not shown in the illustration)

Step 1: Open the SAMPLEALLOC Project 

The first step is to open the InfoWater Pro project.

  1. Choose the Start menu, select Programs, choose the InfoWater Pro Version 2.5 or higher program group, and then choose InfoWater Pro.
  2. In the ArcMap window, select an Existing Map option in the Start Using ArcMap With area, and then click on the OK button. If the ArcMap window is not shown, simply choose Open command from the File menu. 
  3. On the Open dialog box, navigate to the directory containing the SampleAlloc project, and choose that file: C:\Users\Public\Documents\InfoWater Pro\Examples\SampleAlloc.aprx (Note: The path may be different for custom installations.)
  4. Click on the Red Arrow   icon to initialize InfoWater Pro. When initialized, the icons on the InfoWater Pro toolbars will be enabled for use. 
  5. Before continuing, save the “SampleAlloc” project to a new project name. If you wish to restart the tutorial, the original project will be available. Choose the Save As command from the File menu. On the dialog box enter the new project name “Tutorial”. This becomes the active project. 
  6. Go to InfoWater Pro ribbon, and then click on the Apps command. With the Apps Manager dialog box open, select Allocator from the list of applications, and click on the Run button. This will load the InfoWater Pro Allocator toolbar. 
  7. Click on the Add Data icon found under ArcMap's standard toolbar. In the Add Data dialog box, navigate to the directory containing the following three ESRI shapefiles and select those files: 
  • C:\Users\Public\Documents\InfoWater Pro\Examples\demarea.shp
  • C:\Users\Public\Documents\InfoWater Pro\Examples\intersect.shp
  • C:\Users\Public\Documents\InfoWater Pro\Examples\parcel.shp (Note: The path may be different for custom installations.)

Step 2: Register Polygon Layer

The next step in the demand allocation process is to register the polygon layers as primary and either secondary or intersected layers. The primary and secondary layers must be registered for the polygon intersection method. The intersected layer must be registered for the polygon extraction method only. The meter summation method requires registration of the primary layer only.

  1. Click on the More button from the Allocator section in the InfoWater Pro ribbon to view the drop-down menu, and then click on Active Layer from the drop-down menu to launch the Polygon Layer Registration dialog box.
  2. When the Polygon Layer Registration dialog box appears, click on the New  icon to launch the Register a Polygon Layer dialog box.
  3. Select “0: Primary” as the Polygon Layer Type. In the Registration Details area, select the Attach an Existing Polygon Layer option and choose the “demarea.shp” file in the drop-down list box. Finally, in the Junction Linkage (ID) Field area, select the “Existing Field” option and choose “ID” in the drop-down list box. The dialog box should appear as shown below. 
  4. Click on the OK button to close the dialog box. 
  5. Click again on the New icon of the Polygon Layer Registration dialog box to launch the Register a Polygon Layer dialog box.
  6. Select “1: Secondary” as the Polygon Layer Type. In the Registration Details area, select the Attach an Existing Polygon Layer option and choose the “parcel.shp” file in the drop-down list box. Finally, in the Usage Type (ID) Field area, select the Existing Field option and choose Zoning in the drop-down list box. The dialog box should appear as shown below.

  7. Click on the OK button to close the dialog box.
  8. Click again on the New icon of the Polygon Layer Registration dialog box to launch the Register a Polygon Layer dialog box. 
  9. Select 2: Intersected as the Polygon Layer Type. In the Registration Details area, select the Attach an Existing Polygon Layer option and choose the “intersect.shp” file in the drop-down list box. In the Junction Linkage (ID) Field area, select the Existing Field option and choose ID in the drop-down list box. Finally, in the Usage Type (ID) Field area, select the Existing Field option and choose Zoning in the drop-down list box. The dialog box should appear as shown below.
  10. Click on the OK button to close the Register a Polygon Layer dialog box. The Polygon Layer Registration dialog box should appear as shown below. 
  11. Click on the Close button to close the Polygon Layer Registration dialog box. 

In almost every application of InfoWater Pro Demand Allocator, you will use the primary layer and either a secondary or an intersected area, but not both. We register both here to guide you through how to use each of them later in this section.

Step 3: Launch the Demand Allocator Manager

Now you will launch the Allocation Manager dialog box by clicking on the Allocation Manager icon from the InfoWater Pro ribbon. The dialog box should appear as shown below. 

  1. Click on the Usage Data tab and Check Usage Type icon to populate the Usage Type column in the Usage Data table.
  2. Click on the Usage Type column header to highlight the column, and then click on the Sort Ascending icon. 
  3. Enter the following Water Duty values in gpm/Ac for the different usage types as shown in the table below. Select the appropriate Demand Field options for the different usage types as shown in the table below. Finally, populate the description fields as shown below (optional). 
  4. Change the Allocation Scaling Factor from 1.0 to 0.0000229 (1 Ac/43560 ft^2) because the Water duty factors are in units of gpm/Ac, but the model calculates areas in units of ft^2. This factor will allow for unit conversion consistency. The dialog box should appear as shown below. 

Step 4: Run InfoWater Pro Demand Allocator 

You will now run InfoWater Pro Demand Allocator. Five different methods will be presented as follows: the polygon intersection method, the polygon extraction method, the meter summation, the closest junction method, and the closest pipe method.

POLYGON INTERSECTION

  1. Going back to the Allocation tab of the Demand Allocation Manager dialog box, select the Polygon Intersection option in the Allocation Method area of the Demand Allocation Manager dialog box.
  2. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the Purge All Demands… button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. The dialog box should appear as shown below.
  3. Click on the OK button to close the Demand Allocator Options dialog box. 

  4. Click on the Save button of the Demand Allocation Manager dialog box to run the polygon intersection method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. Review the Allocation report to verify demands were allocated as expected:

  5. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box. 

  6. To verify your results perform the following: 

    • Select the Utilities->Locate->Node command and enter the following node ID “55”.  
    • Click on the Select Element icon from the InfoWater Pro Edit Network toolbar, and then click on Junction 55 to view its data on the Attribute Browser window. 
    • You should have the following results: demand1 = 0.00 gpm, demand4 = 0.00 gpm, demand5 = 1.52 gpm, and demand6 = 1.25 gpm
  7. Additional Considerations when Allocating demands: 

    It is a good idea to verify the Allocated demand in the Allocation report shown in Step 6 matches the expected demand based on the total area and water duty factors (or total meter demand expected depending on the allocation method used).  

    It is often a good idea to copy the allocation report to document the allocation results. 

    It is recommended to review the demand in the DB tables matches the expected totals to verify no simple mistakes occurred during allocation (e.g., allocation to inactive nodes, forgetting to delete previous demands).

    Increasing the decimal places in the model from the default of 2 to 4 can potentially increase the accuracy of the allocation and lessen the impact of rounding error.


POLYGON EXTRACTION

  1. Click on the Allocation Manager icon to launch the Demand Allocation Manager dialog box. Select the Polygon Extraction option in the Allocation Method area.
  2. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the Purge All Demands… button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. 
  3. Click on the OK button to close the Demand Allocator Options dialog box. 
  4. Click on the Save button of the Allocation Manager dialog box to run the polygon extraction method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. 
    Review the Allocation report to verify demands were allocated as expected:
  5. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box. 

  6. To verify your results perform the following:

  • Select the Utilities->Locate->Node command and enter the following node ID “59”. 
  • Click on the Select Element icon from the InfoWater Pro Edit Network toolbar, and then click on Junction 59 to view its data on the Attribute Browser window. 
  • You should have the following result: demand4 = 2.09 gpm.

METER SUMMATION

  1. Click on the Import Meter Data  icon to launch the Select Desired Meter Data File dialog box and navigate to the following directory: C:\Users\Public\Documents\InfoWater Pro\Examples\meter.csv 
  2. Select the meter data file and click on the Open button to launch the Create Meter Layer From… dialog box. In the Field Mapping area, specify the following:  
    In the X Coordinate Field drop-down box, select “Field 1(X-COORD)” .
    In the Y Coordinate Field drop-down box, select “Field 2(Y-COORD)”.
    In the Demand Field drop-down box, select “Field 6(DEMAND)” .
    In the Usage Type Field drop-down box, select “Field 4(USAGE)” .
  3. Enter “meters-new” in the File Name field (so as to not overwrite the existing solution meters.shp layer) and then click on the Save button to close the dialog box. The Create Meter Layer From… dialog box should appear as follows.
  4. Click on the Allocation Manager  button to launch the Demand Allocation Manager dialog box. 
  5. Select the Meter Summation option in the Allocation Method area of the Allocation Manager dialog box. 
  6. Under the Polygon Layer(s) section, specify the Primary Layer that contains the demand area polygons for which meter demands are to be grouped and spatially allocated. For this example choose the background layer demarea.shp used previously. 
  7. In the Meter Configuration area, select the “HX_DMD” option in the Demand Field drop-down list box, select “HX_JNT” in the Junction ID Field, and select the “HX_USAGE” option in the Usage Type Field drop-down list box. Finally, in the Meter Layer drop-down list box, select the following shapefile you just created: C:\Users\Public\Documents\InfoWater\Examples\meter-new.shp 
    Note: Path may differ if you saved to a different location. 
  8. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the Purge All Demands… button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. 
  9. Click on the OK button to close the Demand Allocator Options dialog box. 
  10. Change the Allocation Scaling Factor to 1.0 and click on the Save button of the Demand Allocation Manager dialog box to run the meter summation method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. Review the Allocation report to verify demands were allocated as expected:

    You have now imported a meter file into InfoWater Pro. We can now begin the process to allocate the meter demands to the hydraulic model.

  11. Review the Total Demand field and ensure that the value to be assigned reads “149.46” as this is the actual meter demand total of “94.13” when multiplied by the appropriate Water Duty factor indicated for each usage type. 
  12. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box. 
  13. Run a simulation of the current demands and review results. 
  14. Note: When allocating demand in your model it is also a good idea to open the DB tables and verify the demands match the allocation report totals. If there are differences, check to see if demands were allocated to inactive elements or if old demands were not purged before allocation occurred.

Allocation with Thiessen Polygons

  1. Click on the Create Thiessen Polygon Layer icon to launch the Create Polygon Layer dialog box as shown below.
  2. Select Convex Hull with Buffering Percentage of in the Outer Boundary area. Enter a value of “2” in the adjacent text box. 
    Note: This number is slightly smaller than expected as a few of the meters fell outside of the Thiessen polygons created and were not counted. This is a good reminder to check that all meters fall within the Thiessen Polygons when using this allocation method. Review the polygons after creation to verify no meters fall outside the polygons.
  3. Enter “convexhullboundary” in the Shapefile Name text box. You have now chosen the convex hull method to create your boundary layer for your Thiessen polygons and have chosen to save these polygons in the convexhullboundary.shp file as shown below.
  4. Click on OK to create Thiessen polygons and to close out of the Create Polygon Layer dialog box. Review the Thiessen polygons just created.
  5. Now register the Thiessen Polygon layer convexhullboundary.shp 
  6. Click on the Register Polygon Layer icon to launch the Polygon Layer Registration dialog box. 
  7. When the Polygon Layer Registration dialog box appears, click on the icon to launch the Register a Polygon Layer dialog box. 
  8. Select “0: Primary” as the Polygon Layer Type. In the Registration Details area, select the Attach an Existing Polygon Layer option and choose the “convexhullboundary.shp” file in the drop-down list box. Finally, in the Junction Linkage (ID) Field area, select the Existing Field option and choose “HX_JNTID” in the drop-down list box. The dialog box should appear as shown below.
     
  9. Click on the OK button to close the dialog box. 
  10. Click on the Allocation Manager button to launch the Demand Allocation Manager dialog box. 
  11. Under the Polygon Layer(s) section, specify the Primary Layer that contains the demand area polygons for which meter demands are to be grouped and spatially allocated. For this example, choose the new Thiessen layer convexhullboundary.shp. 
  12. In the Meter Configuration area, select the “HX_DMD” option in the Demand Field drop-down list box, select “HX_JNT” in the Junction ID Field, and select the “HX_USAGE” option in the Usage Type Field drop-down list box. Finally, in the Meter Layer drop-down list box, select the following shapefile “meter-new.shp” you created previously: 
  13. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the  Purge All Demands… button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. 
  14. Click on the OK button to close the Demand Allocator Options dialog box. 
  15. Verify the settings are as follows before proceeding: 
  16. Change the Allocation Scaling Factor to 1.0 and click on the Save button of the Demand Allocation Manager dialog box to run the meter summation method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. Review the Allocation report to verify demands were allocated as expected: 
  17. Review the Total Demand field and ensure that the value to be assigned reads “142.02”.

    This number is slightly smaller than expected as a few of the meters fell outside of the Thiessen polygons created and were not counted. This is a good reminder to check that all meters fall within the Thiessen Polygons when using this allocation method. Review the polygons after creation to verify no meters fall outside the polygons.


  18. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box. 
  19. Run a simulation of the current demands and review results.

CLOSEST JUNCTION

  1. Click on the Allocation Manager icon to launch the Demand Allocation Manager dialog box.
  2. Select Closest Junction option in the Allocation Method area of the Demand Allocation Manager dialog box. 
  3. In the Meter Configuration area, select the “HX_DMD” option in the Demand Field drop-down list box, select “HX_JNT” in the Junction ID Field, and select the “HX_USAGE” option in the Usage Type Field drop-down list box. Finally, in the Meter Layer drop-down list box, select the following shapefile you previously created:
    C:\Users\Public\Documents\InfoWater\Examples\meter-new.shp NOTE: Path may differ if you saved to a different location 
  4. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the Purge All Demands… button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. 

  5. Click on the OK button to close the Demand Allocator Options dialog box. 

  6. Change the Allocation Scaling Factor to 1.0 and click on the Save button of the Allocation Manager dialog box to run the closest pipe method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. Review the Total Demand field and ensure that the value to be assigned reads “149.46”.
    Review the Allocation report to verify demands were allocated as expected:


    7. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box.
    8. Run a simulation of the current demands and review results.

CLOSEST PIPE

  1. Click on Allocation Manager icon to launch the Demand Allocation Manager dialog box.
  2. Select Closest Pipe option in the Allocation Method area of the Demand Allocation Manager dialog box. 
  3. In the Meter Configuration area, select the “HX_DMD” option in the Demand Field drop-down list box, select “HX_PIPE” in the Pipe ID Field, and select the “HX_USAGE” option in the Usage Type Field drop-down list box. Finally, in the Meter Layer drop-down list box, select the following shapefile you created previously. C:\Users\Public\Documents\InfoWater\Examples\meter-new.shp NOTE: Path may differ if you saved to a different location. 
  4. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the Purge All Demands… button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. 
  5. Click on the OK button to close the Demand Allocator Options dialog box. 
  6. Select Spatial Join in the Closest-Pipe Assignment Method area and Closest Junction in the Meter Assignment Option. 
  7. Change the Allocation Scaling Factor to 1.0 and click on the Save button of the Allocation Manager dialog box to run the closest pipe method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. 
    Review the Total Demand field and ensure that the value to be assigned reads “149.46”. 
  8. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box. 
  9. Run a simulation of the current demands and review results.

ADJUSTING METER ASSIGNMENT

Demand Allocation methods such as Meter Summation, Closest Junction, and Closest pipe will assign a junction or pipe ID to the “HX_JNT” and “HX_PIPE” fields depending on the allocation method. However, once the values are assigned the user may wish to verify and edit the value of the “HX_JNT” and “HX_PIPE” fields based on review.

  1. Before running the Meter Assignment tool find your meter layer in the ArcGIS Table of Contents and select the layer so that it is highlighted as follows: 
  2. Click on the Assign Meters  icon from the Allocator section in the InfoWater Pro ribbon to launch the Meter Assignment dialog box as shown below. 
  3. Select the Select Meter(s) button in the Junction-Meter Association box. Now browse and select meters for a portion of the system. Once selected in ArcGIS they will turn blue, and when finished selecting right click and select ENTER to continue. The program will draw a red line form each meter to the junction in is currently assigned to in the “HX_JNT” field of the meter layer. Note the one meter that is assigned to the wrong street. 
  4. To reassign a given meter to a different junction select the Assign Junction button to adjust the assignment of one or more meters. 
  5. Note: Follow the instructions located in the message board. (included below) 
    First, select the Junction you wish to assign meters to (select Junction 29) 
    Next, select the meter(s) and when finished selecting right click and select ENTER to continue. 
  6. Once completed the new lines for the meters selected will be redrawn to the junction selected. Repeat this process for any meters you wish to reassign. 
  7. A similar process can be used to view or reassign the “HX_PIPE” field used for any meter as well. Try selecting meters and reassigning meters in the Pipe-Meter Association box using similar methodology as done for junctions. 
  8. Note: Make sure to select the button to clear all meter assignment lines from the model and select Close to exit the Meter Assignment dialog box. 
  9. Once all meter assignments are completed proceed to the next section to see how you can re-run allocations using your manual adjustments to the meter assignments by using the Meter-Junction and Meter-Pipe Allocation methods. 


METER-JUNCTION and METER-PIPE ALLOCATION

The Meter-Junction and Meter-Pipe Allocation methods are additional meter allocation methods that can be used once the “HX_JNT” and “HX_PIPE” fields have been populated in the meter layer being used from another allocation method. These two methods will not reassign new values to the “HX_JNT” and “HX_PIPE” fields in the meter layer, but will simply sum up the demands based on the values already entered.


The following are procedures for running the Meter-Junction Allocation assignment.

  1. Click on the Allocation Manager button to launch the Demand Allocation Manager dialog box.
  2. Select Meter-Junction option in the Allocation Method area of the Demand Allocation Manager dialog box. 
  3. In the Meter Configuration area, select the “HX_DMD” option in the Demand Field drop-down list box, select “HX_JNT” in the Junction ID Field, and select the “HX_USAGE” option in the Usage Type Field drop-down list box. Finally, in the Meter Layer drop-down list box, select the following shapefile you previously created C:\Users\Public\Documents\InfoWater\Examples\meter-new.shp 
    Note: Path may differ if you saved to a different location.
  4. Click on the Options… button to launch the Demand Allocator Options dialog box. Click on the Purge All Demands…  button. Click on the OK button in the Confirmation dialog box. Finally, confirm that the first three options in the Demand Allocator Options dialog box are selected. 
  5. Click on the OK button to close the Demand Allocator Options dialog box. 
  6. Change the Allocation Scaling Factor to 1.0 and click on the Save button of the Allocation Manager dialog box to run the closest pipe method. The Allocation Report and Water Duty Calculator dialog box will appear upon completion of demand allocation. Review the Total Demand field and ensure that the value to be assigned reads “149.46”.  Review the Allocation report to verify demands were allocated as expected: 
  7. Click on the OK button to close the Allocation Report and Water Duty Calculator dialog box. Click on the Close button to close the Allocation Manager dialog box. 
  8. Run a simulation of the current demands and review results.


Congratulations! You have now completed the Quick-Start tutorial.