The Model Explorer of InfoWater Pro is a very important component as it allows the user to activate a scenario, choose an output source, view the information of the active element, access all hydraulic modeling objects such as curves and patterns, and launch any available command of InfoWater Pro.

The Model Explorer window has three tabs - Attribute tab, Operation tab, and Command Center tab. The Attribute tab shows all input and output information for the active element. The top of the Attribute tab also contains some commands about scenarios and output sources, and a number of toolbars for the active element. The Operation tab shows a tree of different object types and a toolbar on the top. The Command Center tab includes all available commands within InfoWater Pro, where the user can launch from.

To display or hide the Model Explorer, go to the InfoWater Pro tab -> View group, and then select the Model Explorer button.


Attribute Tab

The Attribute Tab provides you with tools to view, modify and alter data pertaining to any one InfoWater element such as a pipe, junction, valve, pump, tank and/or a reservoir. It provides also a quick means to inspect output data relating to that element. The Output data section is available only after a successful model run. Additionally other features allow you to locate (search) elements, create default values and assign specific values through the Tools menu.

Scenario Explorer and Current Scenario - Contains the toolbar button to access the Scenario Explorer and displays the pull down menu to select the current active scenario.

Run Manager and Current Output - Contains the toolbar button to access the Run Manager and displays the pull down menu to access the current available output and the refresh selector. Check the box to refresh the current output.

  •  Run Manager - Use this button to launch the Run Manager dialog box. Click here to learn more about the InfoWater Run Manager.

  •  Change Output - The change output drop down is used to select a previously created output and make it the active simulation Output.

  •  Refresh Output Data - When checked this will automatically refresh your output data after every simulation run.

  •  Time - Displays the presently selected simulation time on the toolbar.

  •  Time Bar - Use this to specify the time for an EPS run. Drag the slider to the desired time or use the Forward and Back arrows to move one timestep at a time


Current Time & Time Selector - Displays the current simulation time of the output displayed and includes a slider to change the current output time.

Attribute Toolbar - For toolbar information See: Attribute Toolbar

Browser History - Lists the history of the elements that have been displayed in the Model Explorer - Attribute Tab. Use this list to return to any previously displayed element.

ID & Description - Displays the ID of the element presently highlighted in the InfoWater project and the Description. The data corresponding to this element is displayed in the rest of the Model Explorer - Attribute Tab. You may also select another element in the InfoWater project by just typing in the new ID and clicking on Enter. You can also add or change the description

Geometry Data - All the Geometry Data for the element is displayed here. You may modify or alter any or all the data. For Pipes you may reverse the pipe downstream node and the upstream node by clicking on the Reverse button. Click here to learn more about Geometry data.

Modeling Data - All the modeling Data for the element is displayed here. You may modify or alter any or all the data. Click here for more information about the Modeling data. Additionally double clicking on "Minor Loss" will bring up the Pipe Minor Loss dialog box.

Information Data - All the information Data for the element is displayed here. You may modify or alter any or all the data. Click here for more information about the Information data.

Output Data - This section displays all the output variables for the active Data element. This section will only contain results after a successful Simulation Run. The Output is also available in graph and Table format from the Output Report & Graph Dialog Box.

  • Browser Tabs - The Browser Tabs select the browser's function, See: Operation Tab, Annotation Tab and Contour Tab for details.

    • Attribute Tab: The Attribute Tab displays the element attributes for the model data elements.

    • Operation Tab:  The Operation Data tab contains all of the operational features of InfoWater. Click here to learn more about the Operation Data feature of InfoWater.

    • Command Center: The Command Center tab contains all of the Command features of InfoWater.


Note: The check box on the heading line of the data sections controls the visibility of the data section. If the check is removed, the data will not be visible.

Operation Tab

This section of the Model Explorer provides you with tools to create, edit and operate on the different operational features of InfoWater.

See below to learn more:



  • Annotation - The annotation folder allows you to add, edit or display annotation on the map display. See Annotation Dialog Box

  • Contour - The Contour Folder of the Operation Tab allows you to display, add or edit contours on the map display. See Contour Dialog Box

  • Curve - Add, edit or display curve data. Right Click for the Curve menu or double click an existing Curve to edit. Curves are objects that contain data pairs representing a relationship between two quantities.  A curve is used to comparing one value against another (ex. Head vs. Flow).  Curves are assigned to data elements through the Attribute Tab. See: Curve Dialog Box

  • DB Query - Add, edit or display a DB Query. Right click for the DB Query menu or double click an existing DB Query to edit. A query of a database allows the user to extract a record (or records) of a data using logical statements on a field (or fields) stored within a specific database.  With InfoWater, the user is able to select network components and related data by creating logical query statements through the user-friendly DB Query feature. See: DB Query Dialog Box

  • Output Relate - Add, Edit or Display the output relate. Right click for the Output Relate Menu or double click an existing Output Relate to edit. The Output Relate option is used to establish relationships between modeling input data and modeling results.  Once a relate (link) is established, you can then apply queries against the current project based on modeling inputs and simulation results simultaneously. See: Output Relate Dialog Box

  • Pattern - Add, edit or display Pattern data. Right click for Pattern Menu or double click an existing Pattern to edit. A pattern is a graph (assigned to an element) - used to represent temporal (time-dependent) variations within the system.  See: Pattern Dialog Box

  • Query Set - Add, edit or display Query Set data. Right Click for Query Set Menu or double click an existing Query Set to edit. A Query Set is a collection of individual database queries (made from the DB Query command) stored as a unique set of data.  Query sets are used to group logical expressions for InfoWater network elements (pipes, junctions, etc) for network management and graphical presentation purposes. See: Query Set Dialog Box

  • Selection Set - Add or edit Selection Set data. Right click for the Selection Set menu or double click an existing Selection Set to edit. Selection sets are collections of data elements that can be saved and later recalled for activation.  See: Selection Set Dialog Box

  • Simulation Options - Add, edit or display Simulation Options. Right click for the Simulation Options Menu or double click an existing Simulation Option to edit. The Simulation Options dialog box is used to adjust some facet of the model simulation prior to a model run.  You may create and customize the simulation Options for each scenario. See: Simulation Options Dialog Box

  • Simulation Report - Add, edit or display Simulation Report options. Right click for the Simulation Report Menu or double click an existing Simulation Report to edit. A simulation report can be created as part of a scenario or simulation run and controls the data that is stored in the simulation report file. See: Simulation Report

  • Simulation Time - Add, edit or display Simulation Time options. Right click for the Simulation Time Menu or double click an existing Simulation Time to edit. The Simulation Time feature of InfoWater allows the user to change the time-step at which an extended period simulation is to be analyzed or to select a Steady State simulation. See: Simulation Time Dialog Box

    Command Center Tab

          This section of the Model Explorer provides you with tools to create, edit and operate on the different operational features of InfoWater.

               See below to learn more:



 Edit Menu:

 The Edit folder allows you to Group Editing, Rule-Base Control, Real Time Data Connection, SCADA Interface, Delete Selection, Delete Domain, Undo Delete(ReCall), Redo Delete.


 

      

  

Group Editing... - The Group Editing command allows you to specify modeling properties of multiple network components in a single operation. See: Group Editing on Domain or Selection

Rule Based Control... - Rule Based Logic Controls are used by InfoWater to perform a given action during a hydraulic simulation when a user specified condition is met.  However, unlike Simple Controls, rule based controls allow for the creation of multiple conditions to be satisfied before an action is performed. See: Rule Data Edit Dialog Box

Real Time Data Connection... - The Real-Time Data Connection allows the user to associate recorded data files (from pressure loggers or SCADA downloads) which can span a number of days.  When conducting EPS simulations, you are able to compare a set of recorded data against simulated data.  This feature is especially helpful during the calibration of a model, as it allows the user to select a particular day to compare a model’s simulation results. See: Real Time Data Connection Dialog Box

SCADA Interface... - The intent of the SCADA module is to update InfoWater with the most recent SCADA data and to monitor your hydraulic system. It provides the ability to automatically read and compare SCADA data with the simulation model. See: SCADA Integration - SCADA System Data Editor

Delete Selection... -The Delete selection button allows you to delete any of the components of an InfoWater water distribution system model; pipes, pumps, valves, junction nodes, tanks and reservoirs.  After clicking on this icon, select the network components you want to delete by using the square white cursor. Left click too select the first corner. Draw a box around the selected components and right click to select the components. Also you may click on one element at a time to select it. Once the elements have been selected, press enter or right click and select Enter or Cancel from the menu. Also see: Toolbars - Delete Selection 

Delete Domain... - Use this command to delete InfoWater elements such as Junctions, tanks, reservoirs, pumps, valves and pipes which are included as part of a domain. Create a domain including the different InfoWater elements such as junctions, pipes, pumps, valves, reservoirs and/or tanks using the InfoWater Domain Manager that you want to delete. Then click on this command to delete the domain. Also see: Toolbars  - Delete Domain

     

Undo Delete/Recall - Undo or un-delete nodes and links beginning with the most currently deleted item. Also see: Toolbars  - Undo

Redo Delete/Recall - Redo or re-delete previously deleted nodes and links beginning with the most currently deleted item. Also see: Toolbars  - Redo


Exchange Menu:


The exchange menu is used to Import or Export data from or into an InfoWater project. It provides a means of transferring model data between InfoWater and other applications such as GIS, database files, shapefiles and EPANET. When used to import data from other applications, the Utilities Menu which contains valuable tools for repairing and fixing data can be used in conjunction with the Exchange Menu functions to help create a working model.

                       

Import Manager - Use this to import data from external files into the InfoWater project database. See: Import Manager Dialog Box To learn more about the Import procedure click here.

Export Manager - Choosing this option launches the InfoWater Export Manager dialog box. Use this to export data files from InfoWater to other applications. See: Export Manager To learn more about the Export procedure click here.

ODBC Exchange - The Open DataBase Connectivity (ODBC) module of InfoWater allows the user to actively link to any external database and import that data into the current InfoWater session.  Likewise, the user can also update an external database with InfoWater data. See: ODBC dialog box

EPANET 2.0 - This command is used to import and export EPANET 2.0 text (INP) files. See: EPANET v2.x Import/Export Methodology

Generate File - ArcInfo Generate Files are a means of transferring data to and from ArcInfo to InfoWater. See: ArcInfo Generate File Methodology

Append Nodes - The Append Node function is used when pipe data has been imported into InfoWater without separate node data. This function will append nodes to the endpoints of the pipes and link nodes together that are within a given radius from each other. See. Append Nodes Dialog Box


Scenario Menu:

The different tools to create, edit and operate on scenarios are provided here. The Scenarios allow the user to create "what if" situations throughout a water system. The different data sets that constitute a scenario such as Demand Sets, Tank Sets, Reservoir Sets, Pump Sets, Valve Sets, Pipe Sets, Control Sets, Energy Sets, Fireflow Sets, Logical Sets, Pattern Sets, Curve Sets, Quality Sets may be accessed through this menu for data edits and modifications. You may also launch your Data Set Manager that provides a centralized location to modify your data sets. Additionally you may also launch your Scenario Explorer from here. The Scenario Explorer is where InfoWater allows the user to create, delete and modify scenarios. You may also compare data sets for two different scenarios through the Compare Data Scenario command.



Scenario Explorer - The Scenario Explorer is where InfoWater allows the user to create, delete and modify scenarios.  The Scenario Explorer allows the user to create "what if" situations and model current and future simulations of the water system. See: Scenario Explorer

Dataset Manager - The Dataset Manager is a "quick view" dialog box that allows the user to create, view and edit data sets in one easy to use location. See: Dataset Manager Dialog

Edit Active Scenario - The Active Scenario dialog box allows the user to select any of the scenarios created in an InfoWater project and to activate the datasets to be associated with each scenario. See: Edit Active Scenario Dialog

Compare Data Scenarios - The Compare Scenario command allows the user to monitor the differences between any two scenarios in a model. See: Compare Data Scenarios


Tools Menu:

Use the different options provided here to run your model (Batch Simulation Manager) and analyze your results through the different options such as the Customized Report, Query report, Output Report Manager. Modify your output Units through the Output Unit manager. Also create and view your Animations through the Animation Viewer.


Batch Simulation - The Batch Simulation Manager is used to run models for numerous user-selected scenarios in a single operation.  This command is especially useful where several simulations are simultaneously required for a large model.  With the Batch Simulation Manager, the user can select the desired scenarios and run each model in a "batch" process. See: Batch Simulation Manager Dialog

Customized Report Manager - The Customized Report provides you with a means to customize your output report and to create a combination of input and output data. See: Customized Report Manager-Define Data Source

Query Report Manager - A query report is used to selectively choose which input and output data will appear in a report.  However, unlike a customized report, a query report is required to relate data from an Output Relate with output data in a report format. See: Query Report Dialog Box

Query Summation Report - Use this to launch the Query Summation Report. The Query Summation report may be used to evaluate and view data relating to all the elements that concur with the data base query. Click here to learn more about the Query Summation Methodology.

Output Units Manager - This will initialize the Output Unit Manager which enables the user to change the output units used in InfoWater.  (For example, using flow units of cfs instead of gpm.)

Animation Editor - Map animations display simulation results for EPS timesteps in succession, thereby creating a "movie" effect that allows the user to save and view simulation results. See: Animation Viewer Methodology. The Animation Editor is used to create New Animation Sets to display InfoWater Map renderings. See: Animation Editor Dialog

Animation Viewer - Map animations display simulation results for EPS timesteps in succession, thereby creating a "movie" effect that allows the user to save and view simulation results. See: Animation Viewer Methodology. The Animation Viewer is used to retrieve and display map animations created and saved through the Animation Editor. See: Animation Viewer Dialog

Pipeline Costing - Use this to launch the pipeline costing dialog box. The ability to determine costs for replacing water distribution infrastructure can be one of the most timely and difficult tasks in preparing a master plan.  The pipeline costing function has been provided to assist the user in establishing these costs for replacing certain pipes as based on a wide range of criteria.

Elevation Extractor - InfoWater's Elevation Extractor, as the name implies, extracts the elevation of junctions from digital topographic maps such as the DEM files thus simplifying the effort it takes to create this data. The elevation extractor interpolates ground surface elevations for the nodes in the distribution system from digital maps of various formats including vector data, raster data, and spot elevation data and other digital contour data formats compatible with ESRI. See: Elevation Extractor Dialog Box

Hydraulic Calculator - The Hydraulic Calculator is a calculation tool that is used to determine the velocity and headloss for any given pipe in the distribution system. See: Hydraulic Calculator Dialog

Project Preferences - The Preferences command is used to control the InfoWater system settings. See: Preferences.


Utilities Menu:

The Utilities menu provides various advanced editing tools and operating tools such as the Locate command to locate your elements graphically on your Map. Use the Merge Node and Switch Node commands to move and modify your data elements graphically. Manage the InfoWater Database. Additionally verify Connectivity issues and Recall deleted elements. Another very useful command available from the Utilities menu is the Change ID command that allows you to change InfoWater element IDs.

Click on any section for more information.




Locate - The Locate command is used to find a node/pipe/element by ID within an InfoWater project. This function is also available from the Model Explorer - Attribute Tab toolbar                         . See: Locate

Merge nodes - This command is used to combine two separate nodes into a single node.  The user is first asked to select a node to be deleted, then to select the node to represent the merged node.  Pipes connected to the two nodes will be reconfigured to the merged node location.  If the Auto Length Calculation is turned on, then the lengths for connecting pipes will be adjusted according to the new node location.

Switch Node - The Switch Node command is used to reassign a pipe(s) from one node to another.  For example, if pipes 45 and 75 are connected to node "A", but you want those pipes to be connected to node "B", use the switch node command to relocate the downstream node for those pipes from node "A" to node "B".  This command greatly facilitates having to redraw the geometry of pipes just because a downstream node of a pipe is desired at a different node.

Change ID - The Change ID command allows the user to change the InfoWater database identification for any element from one value to another (as long as the new value for that element is unique).  Merely select the Desired Element Type to change, type in the Old ID then the New ID.  Clicking Apply will change the ID for that element.  Click here to learn more.

Connectivity - The connectivity feature has many elements that assist the user in ensuring that connectivity is established prior to a model being run.  It is important to note that connectivity is required for InfoWater to run a hydraulic simulation.  Click here to learn more.

Network Review/Fix - The Network Review/Fix Tool is a comprehensive network drawing examination and correction application for use in constructing reliable, credible working models ready for analysis. It offers users functionality to quickly identify and correct network topology problems and data flaws that may arise from digitizing a model or building it using pre-existing GIS and CAD datasets. See: Network Review/Fix Tool

Database - The database feature allows the user to utilize database management from within InfoWater to find and correct database flaws or problems.  Click here to learn more.

Recall - The recall command (or Undelete) allows the user to recall a deleted pipe or node from the project database.  It is important to note that when a record is deleted from a database, it is only "marked" for deletion (unless the user has turned on the Auto Database Packing feature in the Project Preferences).  Click here to learn more.

Update DB from Map - This feature allows the user to recreate some or all of the project databases from the graphics in the InfoWater project from the project databases.  Click here to learn more.

Update Map from DB - This feature allows the user to regenerate the map graphics from the project database to ensure that the map view and the database contain the same data.  Click here to learn more.

Update Spatial Indexes - The Update Spatial Index command will help to speed up the map refresh in ArcMap. When there are tables joined to an InfoWater layer, ArcMap will not update the spatial indexes when those tables have been modified. The Update Spatial Indexes command will update the joined tables for an improved map refresh rate.


Help Menu:

Use this to launch the InfoWater help topics as well as to see information about the current InfoWater installation and open the License Management dialog box.


Content - Use this to launch the InfoWater help file. You may click on any topic to learn more about it. Alternatively you may launch the Index section of the help file by clicking on the Index tab. You may also search for specific topics using the Search tab of the InfoWater help file.

Index - Use this to launch the Index section of the InfoWater help file. Click on any index if you want to search for topics containing the specific index word.

Technical Support - Use this for information about the  Innovyze(R) Technical support.

Innovyze(R) on the Web - This link provides you with two options i.e., either to access the Latest Update from the Innovyze(R) Download web page or to access the Innovyze(R) Home Page at http://www.Innovyze.com.

About InfoWater - Use this to learn more about the InfoWater software version and license data


The About InfoWater Dialog Box will show the current version and update of the software as well as information about the current project and any additional licensed modules that are installed. The Check Update button will automatically check the Innovyze(R) web site for any updates that are available. The License Details button will open the License Manager and allow you to Activate, Deactivate, Upgrade and Renew your InfoWater license