The InfoSurge Quick Start Tutorial uses the Sample project file. The system is shown below:

Use the following as a reference when completing this tutorial.

In this tutorial, you will add data required carrying out a pressure surge analysis as follows:

  • InfoSurge options
  • Wave speed for each pipe section 
  • Speed curves describing the cause of the transient 
  • Surge protection device data


You will be guided through several transient simulations using the “SampleSurge” project file. For the InfoSurge simulations, the pumps lose power and run down in two seconds.

Step 1: Open the Sample Project

The first step is to open the InfoSurge project.

  1. From the Start menu, select Programs, choose the InfoSurge for InfoWater Pro program group, and then choose InfoSurge. In the ArcMap window, select an Existing Map option in the Start Using ArcMap With area and then click on the OK button.
  2. On the Open dialog box, navigate to the directory containing the “SampleSurge” project and choose that file. At this point, the network map will be drawn on the screen: C:\Users\Public\Documents\InfoWater Pro\Examples\SampleSurge.aprx (the path may be different for custom installations) 
  3. Click on the Red Down Arrow icon to initialize InfoWater Pro. When initialized, the icons on the InfoWater Pro toolbars will be enabled for use. 
  4. Before continuing, save the “SampleSurge” project to a new project. If you wish to restart the tutorial, the original project will be available. Choose the Save As command from the File menu. On the dialog box, enter the new project name “Tutorial”. This becomes the active project.


Step 2: Define Basic Options for the Surge Analysis 

Before running a transient simulation, you will identify basic project options and hydraulic properties.

  1. Click on the Run  button. The Run Manager dialog box appears on the screen and then select the Surge tab.
  2. Set the following simulation parameters: 
    • Cavitation Head to –33.21 (feet)
    • Pipe Segment Length Toleration to 10 (feet)
    • Simulation Run Duration to 100 (seconds)
    • Monitoring Pressure Head Range to 50 and 150 (feet)

Step 3: Define Pipe Wave Speeds

We will assume that the pipe material is ductile iron. This will result in a wave speed in the pipes of 3,700-4,100 ft/sec depending on the ratio of the diameter to the wall thickness. For this tutorial, we will use a wave speed of 3,900 ft/sec for all pipes. To input this data enter 3,900 for the Global Wave Speed as shown below.

  1. In the Surge tab of the Run Manager dialog box, set the Global Wave Speed to 3,900 (ft/sec). The Surge tab of the Run Manager dialog box should appear on the screen as shown below.
  2. Click on the OK button of the Run Manager dialog box to close the Run Manager dialog box. 

Alternately, wave speeds can be entered for individual pipes by clicking on the Pipe Wave Speed  icon on the Attribute Browser window.

  1. Click on the Select icon of the Attribute Browser window and then select the pipe.
  2. In the Attribute Browser window, click on the Pipe Wave Speed icon. The Pipe Surge Data dialog box appears on the screen, and then enter the Wave Speed as shown in the example below.

Step 4: Define Cause of the Transient (Changes)

The pumps are described using a head/flow curve. For this description type we need to specify time and speed ratios to define the changes in pump speed following the loss of pump power. It is a good practice to hold the steady state condition for 1 or 2 seconds to help verify that a stable initial condition has been defined. We will use the following ratios to set the speed performance for both pumps.

TimeRation
01
21
40

This holds the steady state (speed ratio = 1) for two seconds and then ramps down the speed to zero over the next two seconds.

Create a Curve 

  1. Select the Operation tab from the Table of Contents, click once on Curve and then right-click and select the New command .You are prompted to enter a new ID and description for the curve. Enter “SPEED1, Pump Shutdown” and choose the OK button. You will enter three data points to represent the pump shutdown curve. 

    Row NumberTime (X)Ratio (Y)
    101
    221
    340
  2. Choose the Set Rows button and enter a value of “3” and choose OK. Go to each row and enter the data points from the table above. Press the Tab key to apply the change. Click on the Save button at the top of the Curve dialog box. Curve SPEED1 now contains three data points and is ready for use. Choose the OK button to close the Curve dialog box.

The following illustrates how the curve should appear on the dialog box when properly entered.


Select a Pump and Assign a Curve 

Pump speed curves are assigned to pumps one pump at a time. Perform the following steps for both Pump 200 and Pump 210. Both share the same speed curve.

  1. Click on the Select  icon of the Attribute Browser window, place the cursor on Pump 200 and then click on the left mouse button.
  2. Click on the Pump Operation Change icon on the Attribute Browser window. The Pump Operation Change Data dialog box appears on the screen. 
  3. Select the Speed option in the Disturbance Type field and choose SPEED1 curve in the Speed Curve drop-down list. 
  4. Click on the Create button to close the Pump Operation Change Data dialog box. The Pump Operation Change Data dialog box should appear on the screen as shown below. 

Repeat steps 1 through 4 for the second Pump 210. Remember that both pumps share the same speed curve.

Step 5: Modify Component Attributes for Surge Analysis 

For surge analysis the characteristics of the check valves for the pumps must be specified. Perform the following steps for both Pump 200 and Pump 210. Both share the same check valve characteristics.

  1. Click on the Select icon of the Attribute Browser window, place the cursor on Pump 200 and then press the left mouse button.
  2. Click on the Pump Surge Data  icon on the Model Explorer window. The Pump Surge Data dialog box appears on the screen.
  3. Select the following parameters: 

    • Select the Check Valve Installed option 

    • Set the CV Resistance to 0.001

    • Set the CV Opening/Closing Time to 0.01 second 

    • Select the Non-Reopen CV option 

  4. Click on the Create button to close the Pump Surge Data dialog box. The Pump Surge Data dialog box should appear on the screen as shown below.

Step 6: Run a Steady State Simulation 

You have now entered all required information for the model. It is always wise to first run a Steady State analysis and review the initial conditions for the surge analysis. To run a Steady State simulation, perform the following:

  1. Click on the InfoWater Pro ribbon, and then choose the Run  command. The Run Manager dialog box appears on the screen. Choose the Surge tab.
  2. Check the Hydraulic Run Only checkbox. 
  3. Choose the Run icon at the top of the Run Manager dialog box. Upon successful completion of the simulation, the status stoplight on the Run Manager should show green, indicating successful completion of the simulation run. 
  4. Choose the OK button to close the Run Manager dialog box.

Step 7: Review Steady State Results 

InfoSurge offers numerous tools for reviewing and analyzing model results. In this step, you will be introduced to using the Report Manager for reviewing results in tabular form. To do this, perform the following:

  1. Click on the InfoWater Pro ribbon, and then choose the Report Manager command. 
  2. Choose the New button and when the Output Report & Graph dialog box appears on the screen, choose the “*Active*:Surge” Output Source, choose the Tabular Report button, choose Pump Report, and then choose Open. Click on the Close button to close the Output Report & Graph dialog box.

To run the Surge simulation, perform the following:

  1. Click on the InfoWater Pro ribbon and then choose the Run command. The Run Manager dialog box appears on the screen. Choose the Surge tab. Uncheck the Hydraulic Run Only checkbox and set the Monitoring Node ID to 3.
  2. Choose the Run  icon at the top of the Run Manager dialog box. The InfoSurge Transient Analysis dialog box appears on the screen showing the pressure transient for Junction 3. 
  3. The status stoplight on the Run Manager should show green, indicating successful completion of the simulation run as shown below.  
  4. Choose the OK button to close the Run Manager dialog box.

Step 8: Run A Surge Simulation 

To run the Surge simulation, perform the following:

  1. Click on the InfoWater Pro ribbon and then choose the Run command. The Run Manager dialog box appears on the screen. Choose the Surge tab. Uncheck the Hydraulic Run Only checkbox and set the Monitoring Node ID to 3.
  2. Choose the Run  icon at the top of the Run Manager dialog box. The InfoSurge Transient Analysis dialog box appears on the screen showing the pressure transient for Junction 3. 
  3. The status stoplight on the Run Manager should show green, indicating successful completion of the simulation run as shown below. 
  4. Choose the OK button to close the Run Manager dialog box.

Step 9: Review Surge Results 

For reviewing the results of a surge analysis it is best to view graphical results. In this step you use the Report Manager for reviewing results in graphical form one network component at a time. To do this, perform the following:

  1. Click on the InfoWater Pro ribbon, and then choose Report Manager  button.
  2. Click the New button and when the Output Report & Graph dialog box appears on the screen, and choose the “*Active*:Surge” Output Source. 
  3. Click on the Graph Report button, choose Surge Node Graph, and then choose Open
  4. Place the cursor on the Junction Node 3 and press the left mouse button. A graph is then displayed on the screen showing pressure variation for the selected node. 
  5. Click on the Close button to close the Output Report & Graph dialog box.

Step 10: Additional Simulations 

A rapid pump shutdown produces a relatively small transient because the system is operating at a very low percentage of full capacity. The total loss in hydraulic grade is the order of 1 foot and the velocities are generally less than 1 ft/sec. Surge is of much greater concern when systems operate nearer their full capacity. To illustrate this, the demands are increased by a factor of two. In addition, a demand of 2,000 gpm is defined at Node 67. This could simulate a connection to provide water to an adjacent distribution system, which is feasible because of the large excess capacity of this system.

  1. Click on the InfoWater Pro ribbon and then select the DB Editor command. 
  2. When the Open Table dialog box appears on the screen, choose the Junction Demand (Modeling) Data table from the Element Hydraulic Data section. 
  3. Then select Entire Table in the Data Scope area and click once on the OK button. The Junction Demand (Modeling) Data table appears on the screen. 
  4. To adjust the contents of an entire field, in this case “DEMAND1”, click once on the column header with the mouse. The entire column should be highlighted. You will adjust all demands by multiplying the current demands by 2. 
  5. Choose the Block Editing  button while the “DEMAND1” field remains highlighted. When the Block Editing dialog box appears on the screen, choose the “Multiply by” operation, enter “2” for the value to be multiplied, then choose the OK button. All demands should now be increased by a factor of 2. 
  6. Select the Save button. The following picture illustrates how the DB Editor should appear after increasing the demands by a factor of 2. 


  7. Choose the Close icon at the top of the DB Editor window. Close the DB Editor by selecting the Exit icon at the top of the window. 

To define a demand of 2,000 gpm for Junction 67, perform the following:

  1. Click on the Select  icon of the Attribute Browser window, place the cursor on Junction 67 and then press the left mouse button.
  2. In the Modeling section of the Attribute Browser window, click once on the DEMAND 1 field and enter “2,000”. 
  3. Finally, click once on the Save button in the Attribute Browser window. 

When performing transient analysis, it is useful to run the steady state analysis for the starting and ending conditions. The pressure results for these two simulations will be reviewed. It will be seen that a relatively small pressure drop occurs when the system is only supplied by Tank 103 (final condition with both pumps closed). This confirms that the system can easily supply the increased demands and the new connection at Junction 67. You will first run these two Steady State analyses and review the pressures.

Run a Hydraulic Run Simulation - Both Pumps On 

To run a Standard Hydraulic Steady State simulation with both pumps open, perform the following:

  1. Select the Operation tab from the Table of Contents, choose the Simulation Time  BASE, BASE SIMULATION TIME SETTING and double-click. The Simulation Time dialog box should appear on the screen.
  2. Check the Steady-State checkbox. Choose the OK button to close the Simulation Time dialog box. 
  3. Click on the Select icon of the Attribute Browser window, place the cursor on Pump 200 and press the left mouse button. To define the Initial Status of Pump 200, click on the Tools icon of the Attribute Browser window, and then choose the Initial Status command. 
  4. The Pump Initial Status dialog box appears on the screen (see below). Choose Open option and then click on the Create button to close the Pump Initial Status dialog box. 
  5. Repeat the above 2 steps for Pump 210. 
  6. Click on the InfoWater Pro ribbon and choose the Run Manager  command. The Run Manager dialog box appears on the screen. 
  7. Choose the Standard tab and click on the Run icon at the top of the Run Manager dialog box. Upon successful completion of the simulation, choose the OK button to close the Run Manager dialog box. 

The model results are now stored in an output source entitled *Active*:Standard. When you want to access results from this run, you will choose the output source with that name. 


You will now customize the network map display by labeling junctions with calculated pressures. Junction nodes will also be color-coded based on pressures. Specify map customization options as follows:

  1. Click on the Map Display  icon  from the InfoWater Pro ribbon. The Map Display dialog box appears on the screen. 
  2. Choose the Junction option in the Element Type area and select the Active Output option in the Data Source area. This output data source stores the results of your most recent simulation run. 

  3. Select Pressure as the Data Field that will be displayed. Enter “5” in the Classes field. 

  4. Now choose the colors and range breaks used to display pressure. Perform the following to define five classification range breaks as shown below. 

    ColorBreakLabel
    Blue60Less than 60
    Cyan8060 ~ 80
    Green10080 ~100
    Yellow120100 ~120
    Red140
    Greater than 120
  5. For this example, enter “60” in the Break section as the first break value and assign the corresponding label and color to highlight all junctions with a pressure less than 60 psi. Single-click on the corresponding color box in the Color section, choose the corresponding color, and then click on the OK button. Repeat the above step using the range breaks shown in the table above.

  6. Choose the Label Properties tab and check the Show Unit check-box and the Show Label check-box. Click on the Apply button and then click on the OK button to close the window. The nodes will be redrawn to reflect your choices as shown below.  

Run a Steady State Simulation - Both Pumps Off 

To run a Steady State simulation with both pumps closed, perform the following:

  1. Click on the Select  icon of the Attribute Browser window, place the cursor on Pump 200 and press the left mouse button. Click on the Tools icon of the Attribute Browser window, then choose the Initial Status command. The Pump Initial Status dialog box appears on the screen. Choose Closed option and then click on the Update button to close the Pump Initial Status dialog box. Repeat this step for Pump 210.
  2. Click on the InfoWater Pro ribbon and choose the Run Manager  command. The Run Manager dialog box appears on the screen. Choose the Standard tab and click on the Run icon at the top of the Run Manager dialog box. 
  3. Upon successful completion of the simulation, choose the OK button to close the Run Manager dialog box. The network map will be redrawn automatically by labeling and color-coding the junctions with pressure results.

Run a New Surge Simulation  

The transient analysis due to the rapid pump shutdown can now be repeated. To re-run the surge simulation, perform the following:

  1. Click on the InfoWater Pro ribbon and choose the Run Manager command. The Run Manager dialog box appears on the screen. Choose the Surge tab. Verify that the Hydraulic Run Only checkbox is not selected.
  2. Choose the Run  icon at the top of the Run Manager dialog box. The InfoSurge Transient Analysis dialog box appears on the screen showing the surge simulation running. 
  3. The status stoplight on the Run Manager should show green, indicating successful completion of the simulation run. Choose the OK button to close the Run Manager dialog box. 
  4. Click on the InfoWater Pro ribbon, and then choose Report Manager  button. 
  5. Choose the New button and when the Output Report & Graph dialog box appears on the screen, choose the “*Active*:Surge” Output Source, choose the Graph Report  button, choose “Surge Node Graph”, and then choose Open
  6. Place the cursor on the Junction Node 35 and press the left mouse button. A graph is then displayed on the screen showing pressure variation for the selected node. Click on the Close button to close the Output Report & Graph dialog box. 


For this case a much larger transient occurs. In addition, some very low pressures are predicted as shown below for Junction 35. This is an undesirable situation and the need for some form of surge protection is indicated.

Step 11: Adding Surge Protection 

A closed surge tank can be added at about the midpoint of the line connecting the pumps to the distribution system. The tank is connected to the system using a 6-foot long, 4-inch diameter pipe with two elbows. In addition, the compressor tank is initially half full of water. The resistance for flow into and out of the surge tank is computed as 8.90 using the Resistance Calculator dialog box shown below and the connection data noted above.

A junction which has exactly two (2) connections is added just downstream from the pumps (between Junctions 3 and 5). For the general location of Junction nodes 3 and 5, refer to the network map provided on page 3-1. This junction will be defined as a Surge Protection Device by selecting the Surge Protection Device  icon of the Element Attribute.

Now digitize the Surge Protection Device between Junctions 3 and 5 as follows:

  1. Click on the Add/Insert Junction icon from the InfoWater Pro Edit Network toolbar. Click on the Yes button in the Confirmation dialog box to split Pipe 4. You are then prompted to enter the identifier for the new junction. Enter “J10” in the New ID field of the New Junction ID dialog box and then press the OK button to close the dialog box. Junction J10 should now appear on the screen as a green circle.
  2. In the Attribute Browser window, perform the following: Enter “Surge Tank” in the Description field; Enter “100” in the Elevation field; and Leave all other fields blank. 
  3. Click on the Surge Protection Device icon on the Attribute Browser window. This will launch the Surge Protection Device Data dialog box shown below and the Device Type can then be selected.
  4. Select Closed Surge Tank in the Device Type drop-down listbox and enter the following: 
    • Enter “8.90” in the Inflow Resistance field;
    • Enter “8.90” in the Outflow Resistance  field;
    • Enter “15.0” in the Diameter field; 
    • Enter “0.00” in the Initial Level field; 
    • Enter “100.00” in the Tank Volume field; 
    • Enter “50.00” in the Initial Gas Volume field;
    • Enter “1.20” in the Expansion Constant field.
  5. Click on the Create button to close the Surge Protection Device Data dialog box. The Surge Protection Device Data dialog box should appear on the screen as shown below.
  6. Click once on the Save button of the Attribute Browser window. 

To re-run the surge simulation, perform the following:

  1. Click on the InfoWater Pro ribbon and choose the Run Manager  button. The Run Manager dialog box appears on the screen. Choose the Surge tab.
  2. Choose the Run icon at the top of the Run Manager dialog box. The InfoSurge Transient Analysis dialog box appears on the screen showing the surge simulation running. Upon successful completion of the simulation, click on the OK button of the InfoSurge Surge Run Completed dialog box. 
  3. The status stoplight on the Run Manager should show green, indicating successful completion of the simulation run. Choose the OK button to close the Run Manager dialog box. 
  4. Click on the InfoWater Pro ribbon and choose the Report Manager  command. 
  5. Choose the New button and when the Output Report & Graph dialog box appears on the screen, choose the “*Active*:Surge” Output Source, choose the Graph button, choose Surge Node Graph, and then choose Open
  6. Place the cursor on the Junction Node 35 and press the left mouse button. A graph is then displayed on the screen showing pressure variation for the selected node. Click on the Close button to close the Output Report & Graph dialog box.

Finally, an excellent tool for reviewing surge analysis results is a pipeline profile with a head envelope showing the extremes during the transient. This plot is created as follows:

  1. Click on the InfoWater Pro ribbon, and choose the Report Manager command.
  2. Choose the New button and when the Output Report & Graph dialog box appears on the screen, choose the “*Active*:Surge” Output Source, choose the Graph Report button, choose “Surge Head Profile”, and then choose Open
  3. A profile of the pipes between the Fixed Head Reservoir 101 and Junction 67 (demand of 2,000 gpm) will be created. Select Pipes 2, 200A, 200B, 4, P10, 6, 8, 10, 16, 98, 96, 94, 90, 86, 82, 78 and 58 and then select the Enter key. 
  4. A graph is then displayed on the screen showing pipeline profile with a head envelope for the selected pipes. Click on the Close button to close the Output Report & Graph dialog box. 
    Plotted results for that path are shown below for the system with no surge protection and for the protected system.

Pressure Profile - No Surge Protection 

Pressure Profile - With Surge Protection 

You have now completed the InfoSurge Tutorial. You should now have the skills necessary to develop and analyze distribution system network transient models with the extensive and powerful suite of tools provided by InfoSurge.